BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with Link on X5-X6 on Virtual Connect FlexFabric modules

chuckk281
Trusted Contributor

Problem with Link on X5-X6 on Virtual Connect FlexFabric modules

Andrea had some FlexFabric questions:

 

*******************

 

Hello people.

 

We’re experiencing a very unexplainable problem on a customer, I’m reporting here and opening a CALL.

 

On two enclosures (INEM and NGDC) and two different Virtual Connect FlexFabric each we have FOUR links coming from two different Nexus7000 in aggregation 2+2 with HRSP and Cisco Virtual Port Channel (vPc) and configured on VC with a SUS/Eth Net called “data_trunk”.

 

We are experiencing the problem where some cables goes “link UP” only on X1-X4 ports and not (or not always) on “X5-X6” ports.

 

Tried all troubleshooting switches possible like:

-          exchanging the port from an SFP with no link to an SPF that shows link (problem follows X-port of the module)

-          exchanging SFPs with same cable (nothing changes)

-          tried “Auto”, “10Gb” on Link setting: nothing changes

 

It seems that the ports X5 and X6 are not able to negotiate link, but don’t know why.

 

Different situation on different Enclosure (INEM): one of the X5 ports goes UP, but the other don’t (on other VC-FF module).

 

All Fibers are OM3 (300m range with SFP+ SR).

 

********************

 

Edwin answered:

 

***********************

 

I assume the Nexus 7000 is using F-modules which are connected to the VC module Uplink X5-X8. We are hearing customer having this issue only with F-Modules and not with the M-Modules

 

As a workaround you can set the debounce timer to 2000 instead of the default 100ms

 

Example interface config (part of trunk)

interface Ethernet1/10

  description Flex1

  lacp rate fast

  switchport mode trunk

  switchport trunk allowed vlan 1-119,121-3967,4048-4093

  link debounce time 2000

  channel-group 100 mode active

  no shutdown

 

Make sure you get a case elevated to support including the log files generated after the problem is duplicated:

  • Date/time problem occurred
  • VC SUPPORT DUMP
  • CISCO SHOW TECH
  • OA SHOW ALL
  • Port layout: which cisco port connected to which VC Uplink port

 

In case other people are facing the same issue log a case to support and have it elevated to the ISS GCC.

 

************************

 

Are you seeing this? Any suggestions or input?