BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

RHEL / redhat virtualization bonding issues under flex10/10D

aslvbnnm
Occasional Visitor

RHEL / redhat virtualization bonding issues under flex10/10D

Hi Guys,

 

Hoping someone can help me here since i tried to find any documentation describing RHEL/CentOS 7.x bonding support under HPE virtual connect Flex10 technology and failed to do so.. the setup consists of a RedHat virt cluster running rhvh 4.1 (based on rhel 7.3).

now the c7k encl is running 2 flex10/10d under FW version 4.5 and the server blades are BL460 Gen10 with 536FLB FlexNic installed.. the profiles utilizing map mode and the SUS is conf in LACP.

the issue is that when setting up a mode2  or mode4 bonds causes the virtual connect loop detection to shutdown one of the ports.

this behaviour is unheard of / reproducible in RM servers from HPE nor is it in same blade HW connected to a fully fledged switch such as the HPN 6125xx line.

can someone help with this one ? did anyone encountered a similar behaviour  running RHEL 7.x / RHV 4.x in such a setup?

much obliged,

Gil

 

1 REPLY
AmRa
New Member

Re: RHEL / redhat virtualization bonding issues under flex10/10D

For Linux, VC supports any NIC bonding type that does not require 802.3ad (static or dynamic using LACP) on the server NIC ports. hence please use supported bonding mode with VC, 1, 5 and 6 mode.

https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-c01386629-13

Also refer article with regards to RedHat Enterprise Linux 3/4/5 - Bonding Is Not Working Properly with Virtual Connect

https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-c03100531