BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

Serious Enclosure (stack split brain) / Enclosure loss problem

 
chuckk281
Trusted Contributor

Serious Enclosure (stack split brain) / Enclosure loss problem

Bela was having a network issue and needed some advice:

 

****************************

 

We detected serious problems for loss of all network connections externally to the blades, when
ENC1/VC1 and ENC2/VC2 was simulated to broken ( unplugged ) -> loss of all VC stacking links between the enclosures,
or get the same problem when the 1st enclosure has loss of all power.

In this case all of the still running blades lost external uplinks.

Please give us urgent answer, as we are currently not known is multi-enclosure VC domains has bug, or this is a standrard  split-brain
prevention behaviour, or multi-enclosure config was not designed well for deploying in separated server rooms.

 

*****************************8

 

Vincent replied after looking at their configuration:

 

*********************************

 

If you power off Enc1/VC1 AND Enc2/VC2, you’re powering off one end of each of the 2 stacking links in the drawing so of course you’re losing both stacking links. If you want to protect against such a double failure, you’d need to put more stacking links.

As to server communication to the outside, we’d need to know how the servers are configured, whether their profiles have connections to both uplink sets. A VC show all could help.

 

**************************************

 

Lajos was also involved and replied:

 

*******************************

 

Hi Vincent,

 

There is good news. The VC firmware upgrade to 3.10 solved the uplink failure problem.

Now the customer can power off any enclosure. Network traffic on surviving blade servers not impacted by loss of stacking links.

 

*******************************

 

Always good news when things are finally working!