BladeSystem Virtual Connect

VC 3.01 issues general heads up when connecting to a Cisco Nexus 5000

Trusted Contributor

VC 3.01 issues general heads up when connecting to a Cisco Nexus 5000

Lionel, Andrea, and Armand were having issues when using LACP between Virtual Connect and a Cisco Nexus 5000.


Andrea had worked an issue:

Nexus 5000 also gave me serious problems last year with LACP: it was a serious bug in Nexus code because the timing of the LACP negotiation in the Nexus was not fixed.


In that case the Nexus tried randomly to renegotiate the LACP in fast mode (1sec lacp-bpdu response timeout) while it was previously in slow mode (30s timeout).

So the Nexus 5000 started expecting that the VC replied to LACP negotiation in 1sec instead of 30sec the result was that the link aggregation dropped.


Lionel reported what he was seeing on this issue:

I faced as well the same issue with several customers and apparently there is a fix with NX-OS 4.2(1)N2(1).


As Andrea said, the problem is linked to the LACP negotiation timing. Some NX-OS version cannot move to short timeout (1s) automatically, this is what you might be facing. One workaround given by Cisco is to change the Nexus Partner LACP timeout to LONG timers but it is not configurable under VCM… so there is only one solution for you is to ask your customer to upgrade their Nexus to 4.2(1)N2(1).


To make sure this problem is related to the LACP Timeout, you can enter the following command on the Nexus 5k, this should give you the Timeout mismatch between VC /Nexus 5K:
Nexus 5000: show lacp interface ethernet x/y

Interface Ethernet1/4  is individual
  Channel group is 4  port channel is Po4
  PDUs sent: 395402
  PDUs rcvd: 42817
  Markers sent: 0
  Markers rcvd: 0
  Marker response sent:  0
  Marker response rcvd:  0
  Unknown packets rcvd:  44212
  Illegal packets rcvd:  44212
Lag Id: [ [(0,  0-0-0-0-0-0, 0, 0, 0), (0, 0-0-0-0-0-0, 0, 0, 0)] ]
Operational as  aggregated link since Fri Mar 26 14:22:15 2010

Local Port: Ethx/y    MAC Address= 0-d-ec-f2-c9-7c
  System  Identifier=0x8000,0-d-ec-f2-c9-7c
  Port  Identifier=0x8000,0x104
   Operational key=32772
  LACP_Timeout=Long  Timeout (30s)         <<<<<<<<<<<<< Nexus 5k LACP Timeout is 30s
  Partner information  refresh timeout=Short Timeout (3s)      <<<<<<<<<<<<<< VC is the partner
Actor  Admin State=(Ac-1:To-1:Ag-1:Sy-0:Co-0:Di-0:De-0:Ex-0)
Actor Oper  State=(Ac-1:To-0:Ag-1:Sy-1:Co-1:Di-1:De-1:Ex-0)
Neighbor:  0/0
  MAC Address=  0-0-0-0-0-0
  System  Identifier=0x0,0-0-0-0-0-0
  Port  Identifier=0x0,0x0
  Operational  key=0
  LACP_Timeout=short  Timeout (1s)  <<<<<<<<<<<<<<  Mismatch in parameters of LACP with VC
Partner Admin  State=(Ac-0:To-1:Ag-0:Sy-0:Co-0:Di-0:De-0:Ex-0)
Partner Oper State=(Ac-0:To-1:Ag-0:Sy-0:Co-0:Di-0:De-0:Ex-0)


Armand also had issues but could not get the latest Cisco NX-OS update:

I’ve found same behavior on N5k updated with 4.2(1)N1(1) version.


I did not found the 4.2(1)N2(1) as mentioned below on the HP download site  or the Cisco site!


Jean-Yves suggested a method to get access to the update from Cisco:

We'll  need to open a Tac case in order to get it.


Have you had these issues? What have you done to solve the problem? Suggestions?