BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

VC STATUS: INCOMPATIBLE

AlanMacEionn
Occasional Advisor

VC STATUS: INCOMPATIBLE

Hi,

 

I currently have a hp virtual connect 4GB FC module showing to be in an incompatible state.

 

I have run the vcsa utility and it's showing that one of the modules is on another firmware.

 

I'm not sure how this happened

 

 29 13:21:49 2015] ===============================================================================
[Wed Jul 29 13:21:49 2015] Enclosure   Bay  Module             Current Version       New Version          
[Wed Jul 29 13:21:49 2015] ===============================================================================
[Wed Jul 29 13:21:49 2015] GB8904F5TY  1    HP VC Flex-10      3.15                  4.41                 
[Wed Jul 29 13:21:49 2015]                  Enet Module        2010-10-09T07:18:16Z  2015-03-05T20:13:31Z
[Wed Jul 29 13:21:49 2015] -------------------------------------------------------------------------------
[Wed Jul 29 13:21:49 2015] GB8904F5TY  2    HP VC Flex-10      3.15                  4.41                 
[Wed Jul 29 13:21:49 2015]                  Enet Module        2010-10-09T07:18:16Z  2015-03-05T20:13:31Z
[Wed Jul 29 13:21:49 2015] -------------------------------------------------------------------------------
[Wed Jul 29 13:21:49 2015] GB8904F5TY  3    HP Virtual         1.41 7.12.4.11        2.05 9.5.4.06        
[Wed Jul 29 13:21:49 2015]                  Connect 4Gb FC                                                
[Wed Jul 29 13:21:49 2015]                  Module                                                        
[Wed Jul 29 13:21:49 2015] -------------------------------------------------------------------------------
[Wed Jul 29 13:21:49 2015] GB8904F5TY  4    HP Virtual         1.32 7.12.2.04        2.05 9.5.4.06        
[Wed Jul 29 13:21:49 2015]                  Connect 4Gb FC                                                
[Wed Jul 29 13:21:49 2015]                  Module                                                        
[Wed Jul 29 13:21:49 2015] -------------------------------------------------------------------------------
[Wed Jul 29 13:21:49 2015]
[Wed Jul 29 13:21:49 2015] Total execution time: 00:03:41

 

 

What steps can I take to resolve this issue. I'm not sure about updating the firmware as I believe the process runs on everything and not just the virtual connect that has the problem.

 

I want to try and avoid lossing connectivity on the current working HP Virtual connect.

 

 

11 REPLIES
Torsten.
Acclaimed Contributor

Re: VC STATUS: INCOMPATIBLE

Check the release notes of VC firmware. There is a list what modules are NOT supported with current firmware and what is the maximum version for these modules.

 

 

...Beginning with VC 3.70, the HP 1/10Gb VC Enet Module (399593-B22) and the HP 1/10Gb-F VC Enet Module (447047-B21) are no longer supported. Beginning with VC 4.10, the HP 4Gb VC-FC Module (409513-B21) is no longer supported.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
AlanMacEionn
Occasional Advisor

Re: VC STATUS: INCOMPATIBLE

What's not supported the firmware or the hardware or both?

 

Also it's not quite my question.

 

My question was how can I go about upgrading the firmware on this incompatible VC to get it back into a working state?

 

And also withouth bringing down the other VC during the process.

Torsten.
Acclaimed Contributor

Re: VC STATUS: INCOMPATIBLE

Let's take this:

 

Beginning with VC 4.10, the HP 4Gb VC-FC Module (409513-B21) is no longer supported.

 

If you have a 409513-B21, the last version before 4.10 (version 4.01) is the maximum that you can run on your enclosure because of this module.

 

If you try a newer firmware on these modules, they will be shown as incompatible.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Torsten.
Acclaimed Contributor

Re: VC STATUS: INCOMPATIBLE

If you re-install version 3.15 now, the second FC module would be upgraded from 1.32 to 1.41 (which matches VC version 3.15).

 

Force the upgrade with option "-health" only, not "-version".

 

 

 

 

Firmware-FC-Uebersicht-4.30.jpg


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
AlanMacEionn
Occasional Advisor

Re: VC STATUS: INCOMPATIBLE

Thanks, do you know where I can dowload the firmware 3.15 from.


I'm finding it difficult to find on the hp.com website.

AlanMacEionn
Occasional Advisor

Re: VC STATUS: INCOMPATIBLE

scratch that I managed to find the firmware.

 

 

If I use that force option it's going to also upgrade the working virtual connect card.

 

Can I specify for it just too upgrade the incompatible one?

 

 

AlanMacEionn
Occasional Advisor

Re: VC STATUS: INCOMPATIBLE

I have run the vcsa utility as below

 

vcsu -a report -i <ip> -f health -u <user> -p <Password> -l "E:\vc\vcfwall315.bin"

 

However it doesn't appear to have upgraded the firmware.

 

I have attached the log

 

 

Torsten.
Acclaimed Contributor

Re: VC STATUS: INCOMPATIBLE

Link to 3.15:

 

ftp://ftp.hp.com/ftp1/pub/softlib2/software1/pubsw-linux/p673331540/v64365/


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Torsten.
Acclaimed Contributor

Re: VC STATUS: INCOMPATIBLE

From your log:

 

[Wed Jul 29 17:35:24 2015] Would you like to continue with this update? [YES/NO]:
[Wed Jul 29 17:35:50 2015] User has canceled the firmware update

 

 

Answer

 

YES


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
AlanMacEionn
Occasional Advisor

Re: VC STATUS: INCOMPATIBLE

Getting a bit further but still have this soap error

 

 

Torsten.
Acclaimed Contributor

Re: VC STATUS: INCOMPATIBLE

What was your commend line?

 

There was a timeout for any unknown reason.

 

 

Better try to run vcsutil as administrator and use interactive mode. Select manual reboot/activation. Once the module is updated, reboot this module from OA.

 

 

Sometimes with older versions it helps to reset (reboot) the VC manager running on the primary module.

 

from CLI:

 

> reset vcm


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!