HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

VC, VCEM and firmware...

 
WizWas
Occasional Contributor

VC, VCEM and firmware...

Recently started at a new place and given the task to review all the firmware on the Blade enclosures (2 of them). All up to date apart from virtual connect....

we have 2x HP VC Flex-10 Enet modules & 2 VC 8Gb 24-Port FC Modules per enclosure. 

The Flex-10 Enet modules are at version 3.10, and the 24-Port fibre channel are at version 1.03  (according to SUM 106.04.0 report (attached), oh and I have tried updated through SUM - but wont because it's locked out to VCEM).

So tried to logon to VC and update, but I can't logon because the VC  Manager is locked out to VCEM. We don't use VCEM, and nobody here remembers ever using it. The IP Address points to our current backup server - which doesn't have VCEM (or HP-SIM) installed. We don't currently have licenses for VCEM (and this place being tighter the buttocks of Scandinavian fruit fly, we are unlikely to get them!), do I even need a license to update the firmware ?

Anyway on advise from hpe  I have installed VCEM on our current HP-SIM server and I can now see the VC domains and have an option to update the firmware, but I can't because the VC domains are not part of a group. So I tried to create a group and them add the VC domains to it, but it can't create a group because the VC modules are not at a supported version.So I have logged a call with HP, and am going round in circles.

In the mean-time can any of you offer advice on what else I can try? Oh and I have no previous knowledge of VCEM, just to make things interesting !

Many Thanks in advance 

Pete

5 REPLIES

Re: VC, VCEM and firmware...

If it is truly managed by VCEM, then there will be a external manager (VCEM). 

Login to VC CLI and run show external-manager

What is output?

WizWas
Occasional Contributor

Re: VC, VCEM and firmware...

Many Thanks for this. Attached is the output. The IP address it points to is our backup server, which has neither VCEM on...

Rgds

Pete

 

 

 

 

 

 

 

 

 

 

 

Robert_Jewell
Honored Contributor

Re: VC, VCEM and firmware...

Here is the means to manually remove a VC Domain from being managed by VCEM:

1. Disable the external manager account
   -  Display the username of the external manager account:
      > show external-manager
   - Disable the account:
      > set external-manager Username=xxxx Enabled=false


2. Delete the external manager and release the VC domain from VCEM control
   - To do this the values for each MAC, WWN and Server Serial Numbers must be specified. Command syntax is as follows:

remove external-manager [-quiet] [UserName=<username>][MacType=<Factory-Default| User-Defined>] [MacStart=<MAC address>] [MacEnd=<MAC address>][WwnType=<Factory-Default|User-Defined>] [WwnStart=<WWN address>] [WwnEnd=<WWN address>]
[ServerIdType=<Factory-Default| User-Defined>][ServerIdStart=<ServerId address>] [ServerIdEnd=<ServerId>

For example:

remove external-manager UserName=A18493022 MacType=User-Defined MacStart=00-17-A4-77-00-00 MacEnd=00-17-A4-77-03-FF WwnType=User-Defined WwnStart=50:06:0B:00:00:C2:62:00 WWnEnd=50:06:0B:00:00:C2:65:FF serverIDType=Factory-Default

 

EDIT:  Format of this doesnt look very good to me.  I attached a picture of a page that has this same info.

-Bob

 

 

 

----------------
Was this helpful? Like this post by giving me a thumbs up below!
WizWas
Occasional Contributor

Re: VC, VCEM and firmware...

Bob

YOU THE MAN!!!!  Worked a treat, no issues at all. I can now do the upgrades 

Many Thanks


Pete

Re: VC, VCEM and firmware...

So this was defintelty managed by VCEM, no doubt. VCEM is the external-manager under control and removing control from external-manager gives control back to local user Domain accounts which have privileges to update firmware.