BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

VC together with Solaris 10

johsod
Visitor

VC together with Solaris 10

Hi,

 

I'm installing a Solaris 10 server on a 460c G7 blade in a VC environment. Since the server is going to boot from SAN I need to load and install the driver for the HBA during the installation. Unfortunately I've only been able to find instructions how to load the driver after the OS installation has been completed (http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=3709945&prodSeriesId=4194735&swItem=MTX-18eadf789f56473b8c762b0927&prodNameId=4194638&swEnvOID=2023&swLang=8&taskId=135&mode=4&idx=1). The installation program therefore is unable to detect the shared SAN disks.

 

I now wonder if anyone have any solution how to solve this?

 

Regards,

 

/Johan

1 REPLY
ZGennady
Occasional Visitor

Re: VC together with Solaris 10

Solaris 10 u9 has driver for VC, but old version, that does not work with NC553i.

 

You can use SUNWemlxs.iso ( look SUNWemlxs-2.55s-solaris10-i386.tar.gz  ) for install new driver during Solaris installation. But it will not work, because this ISO has only one package SUNWemlxs and does not have package SUNWemlxu.

 

I recommend install Solaris without network and then install Recommended PatchCluster. It have new version OCE driver that works with NC553i. If you have installed driver from HP site, before installing PatchCluster, remove it and install SUNWemlxs & SUNWemlxu from Solaris10.

 

http://h30499.www3.hp.com/t5/HP-BladeSystem-Server-Blades/Solaris-10-on-G7-blade-server-network-notes/m-p/5296935#M271

 

This new driver has trouble. It does not support working statistics - netstat -i. Because of that Veritas Cluster can`t monitor OCE interface. 

Does anyone know a solution to this problem?

 

WBR