cancel
Showing results for 
Search instead for 
Did you mean: 

VCEM Upgrade

Gavin_30
Regular Advisor

VCEM Upgrade

Hi All,

 

I will be embarking on a VCEM upgrade. According to support matric for IC/VCEM 6.3 the below versions are supported. Is this a normal inplace upgrade or is there something I need to do to make this painless.

 

Current versions:

 

Insight Control 5.3

VCEM 1.2

OA's 2.32 and 3.30

VC's 3.18 and 2.10

 

 

25 REPLIES
Gavin_30
Regular Advisor

Re: VCEM Upgrade

Hi just an update on this. I started the upgrade of the SIM and VCEM. SIM went through 100% and mentioned that after the SIM install that the VCEM will need to be upgraded. Strange that it did not do it all in one.

 

Via integrated Installer i started the VCEM install and it complains about the following "Installed version is older incompatible than bundled version" and then cancels installation. Has any body come across this?

Hongjun Ma
Trusted Contributor

Re: VCEM Upgrade

which SIM and VCEM version you are trying to upgrading to?

 

latest SIM version is 6.3 and latest VCEM version is 6.3.1. You can try to use SIM 6.3 installation DVD for SIM 6.3 and VCEM 6.3 installation and after that run VCEM6.3.1 patch exe file to upgrade VCEM to latest 6.3.1

My VC blog: http://hongjunma.wordpress.com



Gavin_30
Regular Advisor

Re: VCEM Upgrade

Hi yes this is with the 6.3 upgrade media. will only run patch 6.3.1 after 6.3 loaded.

Hongjun Ma
Trusted Contributor

Re: VCEM Upgrade

it should work.

 

Checking the 6.3 release notes here: http://bizsupport1.austin.hp.com/bc/docs/support/SupportManual/c02786886/c02786886.pdf

 

Which indicates the following, again on page 4:

VCEM 6.3 can be installed as a new console or used to update existing installations of VCEM

1.20, 1.3x, 1.40, 6.0,6.1 or 6.2, and is delivered on Insight Software media 6.3 which can be

downloaded from http://www.hp.com/go/vcem.

 

Will email offline so you can send screencapture of error message.

My VC blog: http://hongjunma.wordpress.com



Gavin_30
Regular Advisor

Re: VCEM Upgrade

Hi I got more details re this:

 

So SIM upgraded from 5.3.1 to 6.3 100%. I ran the advisory again and for VCEM i get following error

 

"[Thu Dec 01 10:07:40][INFO ] Checking if VC Domain Group(s) are running on Firmware version 2.10 or above :

[Thu Dec 01 10:07:40][INFO ] Detected Firmware version -- 2.00  VC Domain Group name -- GER_VC_DOMAIN_GROUP

[Thu Dec 01 10:07:40][INFO ] Detected Firmware version -- 2.00  VC Domain Group name -- GER_VC_FC_DOMAIN_GROUP

[Thu Dec 01 10:07:40][INFO ] VC Domain Group(s) running on unsupported Firmware version

 

As we are running VCEM 1.2 there was no option to Update Domain Group Firmware via VCEM. As i am unable to get this to 2.10 it will not allow me to upgrade to VCEM 6.3. Wha are othe options here?

Hongjun Ma
Trusted Contributor

Re: VCEM Upgrade

Could you send screen capture for your current domain group firmware level?

 

How many VC domains do you have managed by VCEM? How many domain groups do you have?

 

Do your VCs run 2.00 or 2.10? In your first post, you said your VC runs 3.18 and 2.10 but the logs says 2.00

 

 

 

My VC blog: http://hongjunma.wordpress.com



Gavin_30
Regular Advisor

Re: VCEM Upgrade

Could you send screen capture for your current domain group firmware level?

 

  1. Name:

    GER_VC_FC_DOMAIN_GROUP

    Status:

     Configuration in synch

    VC Firmware Mode:

    2.0x

 

How many VC domains do you have managed by VCEM? How many domain groups do you have?

 

 1. 2 x VC domain groups, 5X VC domains

 

Do your VCs run 2.00 or 2.10? In your first post, you said your VC runs 3.18 and 2.10 but the logs says 2.00

 

  1. VC are running 2.10 and 3.18. Both supported for 6.3.

 

Hongjun Ma
Trusted Contributor

Re: VCEM Upgrade

since your VC is running 2.10 and 3.18, your VCEM 1.20 can only supports up to VC 2.0x version so very likely your VC domains are running 2.0x compability mode in VCEM but my undersanding is that even with that, you should be able to upgrade VCEM1.2 directly to VCEM6.3 per release notes. I also got confirmation internally that you should be able to do it.

 

unless others offer some other solutions, the next step maybe is to open a HP support case so we can do some troubleshooting.

My VC blog: http://hongjunma.wordpress.com



Gavin_30
Regular Advisor

Re: VCEM Upgrade

Tx Hongjun,

 

Yes as I have read it should be possible to Upgrade. It is just the fact that  VCEM 1.2 does not have the ability to update the VC domain Group firmware. As far as I know this gets updated via the VCEM upgrade.

Hongjun Ma
Trusted Contributor

Re: VCEM Upgrade

I'm not clear why you think you need to upgrade VCEM1.20 domain group firmware mode to the version above 2.0x in order to continue 6.3 upgrade. VCEM1.2 can support VC version up to 2.0x, which means at most VCEM domain group firmware mode is 2.0x.

 

If VCEM6.3 release notes say that you can upgrade from VCEM1.2 directly, that means VCEM6.3 can do the upgrade when your VCEM1.2 domain group firmware mode is 2.0x.

My VC blog: http://hongjunma.wordpress.com



Gavin_30
Regular Advisor

Re: VCEM Upgrade

Agreed, but then explain the following error as mentioned above from the Upgrade process.

 

[Thu Dec 01 10:07:40][INFO ] Checking if VC Domain Group(s) are running on Firmware version 2.10 or above :

[Thu Dec 01 10:07:40][INFO ] Detected Firmware version -- 2.00  VC Domain Group name -- GER_VC_DOMAIN_GROUP

[Thu Dec 01 10:07:40][INFO ] Detected Firmware version -- 2.00  VC Domain Group name -- GER_VC_FC_DOMAIN_GROUP

[Thu Dec 01 10:07:40][INFO ] VC Domain Group(s) running on unsupported Firmware version

Hongjun Ma
Trusted Contributor

Re: VCEM Upgrade

that's the reason I suggest you open a HP support case to track down why you get this error. Personally I don't know.

 

Another option but risky is to try download VCEM6.0 iso to see if you can get any luck because it's a upgrade version after VCEM1.2. However, since your SIM is at 6.3 level now and I have no idea if SIM can let you just upgrade VCEM1.2 to VCEM6.0 alone and then from 6.0 to VCEM6.3.

My VC blog: http://hongjunma.wordpress.com



Gavin_30
Regular Advisor

Re: VCEM Upgrade

Where do I get hold of VCEM 1.4 as I think this could possibly fix my problem.

Hongjun Ma
Trusted Contributor

Re: VCEM Upgrade

i don't think it's available any more.

 

if you go

http://www.hp.com/go/vcem

 

and click download software and login with your HP Passport account, 6.0 is lowest version available.

 

 

My VC blog: http://hongjunma.wordpress.com



Gavin_30
Regular Advisor

Re: VCEM Upgrade

Hi Hongjun, I think the best will just to remove VC's from VCEM, Scrap VCEM and reinstall 6.3.

 

That way I dont have to worry about upgrading and might just work out better in the long run.

Hongjun Ma
Trusted Contributor

Re: VCEM Upgrade

that may turn out to be the best approach.

 

You may want to test one VCM to remove  and join VCEM so you want monitor MAC/WWN assignment. Just want to make sure that the same MAC/WWN is maintained. it should but just in case. also try to back up your config in case anything goes wrong.

My VC blog: http://hongjunma.wordpress.com



Tusc
Advisor

Re: VCEM Upgrade

Any gotchas when upgrading from 6.3 to 6.3.1?

Hongjun Ma
Trusted Contributor

Re: VCEM Upgrade

not that I'm aware of. it's a updated patch over existing 6.3.

 

this doc has live capture of 6.3 upgrade to 6.3.1

http://hongjunma.wordpress.com/2011/12/14/virtual-connect-enterprise-managervcem-quick-start-white-paper-is-published-on-hp-com/

 

My VC blog: http://hongjunma.wordpress.com



Tusc
Advisor

Re: VCEM Upgrade

awesome.. thanks man

Tusc
Advisor

Re: VCEM Upgrade

Well the upgrade finished fine.. I can see my VC domain groups and server profiles.. but I cannot see VC domains and I get this when trying to edit a server profile:

 

Database operation error. Check that VCEM is installed correctly and that the database service is running.

Hongjun Ma
Trusted Contributor

Re: VCEM Upgrade

hmm,I didn't see this before. you might need to open a HP support case to get help. user guide has some general troubleshooting steps

 

VCEM 6.3.1 user guide:  http://h20000.www2.hp.com/bc/docs/support/SupportManual/c02985927/c02985927.pdf

 

Resolving database operation errors
Errors might occur during database operations if:
• VCEM tables are missing.
• Systems Insight Manager database is not running.
To resolve this issue:
1. Check the mxdomainmgr.0.log file for errors related to the database. This log file may
indicate that the transaction log has filled up or that the database is experiencing some other
error.
2. If VCEM tables are missing, restore the VCEM database backup. For more information, see
“Backing up and restoring VCEM” (page 133).
3. Check the Systems Insight Manager database server status:
a. If the database server is remote, then log in to the database server.
b. In the Windows taskbar, check if the Microsoft SQL Express or MSDE service is running.
A red status means they are not running.
c. Right-click the status, and then select Start.
4. If this issue still occurs, then uninstall and reinstall VCEM.

 

 

My VC blog: http://hongjunma.wordpress.com



Tusc
Advisor

Re: VCEM Upgrade

^^ thanks.. I spent some time with support today and we didn't get far. They are going to try and pull in a SQL resource on Monday.

 

Curious.. can I "downgrade" back to 6.3 by reinstalling over 6.3.1? Or any other way to revert back? I am guessing no but figured I would ask.

 

Hongjun Ma
Trusted Contributor

Re: VCEM Upgrade

I'm not DB guy but I'd wait for HP support to figure out before downgrade again. I think nobody can be certain what will be your after-downgrade state when you have this DB error.

My VC blog: http://hongjunma.wordpress.com



Tusc
Advisor

Re: VCEM Upgrade

Understand.. curious.. I assume 6.3.1 adds new tables to the DB? What account perms are invoked to create those tables\update the DB, the service account or the person logged into the server?