BladeSystem Virtual Connect
Showing results for 
Search instead for 
Did you mean: 

Virtual Connect Enterprise Manager and Virtual Connect firmware upgrade

Trusted Contributor

Virtual Connect Enterprise Manager and Virtual Connect firmware upgrade

David had a customer problem that was needing some attention:




Here is a situation.  Customer had VC 3.01 and ID 6.0 with VCEM 6.0 running fine.

They decided to update to ID 6.1 and VC fw 3.10 but they started by putting VC in maintenance mode at VCEM and updated vc fw to 3.10 (wrong starting point).Now, he can’t move VCEM from maintenance mode back to normal because VCEM 6.0 does not support this firmware.


He tried to upgrade to ID 6.1 but VCEM 6.1 module upgrade process failed because VCEM 6.0 was in maintenance mode.

So he gave up and tried to downgrade VC 3.10 to 3.01 but vcsu 1.5.0 comes with this message:


Internal Error: Downgrade from this version of Virtual Connect firmware to the

target version would result in destruction of domain. Please manually delete

the Virtual Connect domain and run Virtual Connect Support Utility again.


Is this really necessary? Any other way to turn this situation back to normal (with all components upgraded) without mayor disruption?





Dave had some good answers:




                You may want to try the VCSU v1.5.1:


Utility - Tools


1.5.1 (17 Sep 2010)

Operating System(s):

Microsoft Windows Server 2003, Microsoft Windows Vista, Microsoft Windows XP Professional


File name:

vcsu-1.5.1-x86.msi (3.0 MB)



» Description



» Enhancements



» Installation Instructions



» Release Notes






» Revision History







Upgrade Requirement:
Critical - HP requires users update to this version immediately.

Important Notes:
     Read the latest version of HP BladeSystem c•Class Virtual Connect Support Utility Release Notes. It can be found in the “User Guide” section, under the URL:

Problems Fixed:
     •Resolved an issue were the Virtual Connect Manager (VCM) domain suffered corruptions with a firmware update when being used with the serial activation method. The corruption would result in the domain getting deleted and when a user would log in, it would prompt the user to import your domain (or restore from backup).
     •Resolved an issue were when the serial activation method was used, it may have the primary Virtual Connect (VC) module comes up with an old configuration.
     •Resolved an issue with Virtual Connect Support Utility (VCSU) not allowing "/" or "@" as part of the LDAP user authentication credentials.
     •Resolved an issue with the default method of activation were VCSU may activate primary VC modules while it is reconfiguring other VC-Enet modules that were just activated.

Known Issues:
     •When running Virtual Connect Support Utility in Interactive Mode, do not use quotation marks around the firmware package path even if the path has spaces. Only use quotation marks around the firmware package path when specifying the package location on the command line with the "-l" command-line parameter.
     •Virtual Connect Fiber Channel modules may fail to complete the firmware upgrade in certain large configurations. Temporary work around is to temporarily remove or power off some of the VC-FC modules and try the update again. If successful, then reinsert or power on remaining VC-FC modules and run VCSU again to complete upgrade operation.






Other suggestions or comments?