BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

Virtual Connect Flex-10 Active/Active with Nexus VCP

Robert_Myhre
Occasional Visitor

Virtual Connect Flex-10 Active/Active with Nexus VCP

We currently have a c7000 with 2x Flex-10 Interconnects.  I have two Etherchannels set up: Bay 1: Ports 2 and 3 are active with Etherchannel LACP bundle, and Bay 2: Ports 2 and 3 are Standby with another Etherchannel LACP bundle.  I can't figure out why I cannot get Active/Active with this configuration.  The Nexus 5K shows both VCP Bundles are established with LACP.

 

Any hints or thoughts what is wrong? 

4 REPLIES
Hongjun Ma
Trusted Contributor

Re: Virtual Connect Flex-10 Active/Active with Nexus VCP

did you config one Shared Uplink Set on VC to cover 4 10G ports or 2 seperate SUS(one SUS per VC module)?

 

the correct way is 2 SUS(one per VC module).

 

If you are doing one SUS with 4 10G links, you'll get 2 links as standby for sure because VC itself doesn't do cross-module LACP so it will block 2 links to prevent loop.

 

please check my white paper how to get active/active in this setup.

1) VC+IRF, this can show you how to config in GUI. You can forget IRF, VC config side is the same with vPC

2) VC+vPC, this one is CLI based, but you'll get an idea by looking at how you config VC SUS in CLI.

 

both white papers can be found on my blog link below

My VC blog: http://hongjunma.wordpress.com



Robert_Myhre
Occasional Visitor

Re: Virtual Connect Flex-10 Active/Active with Nexus VCP

I've gone through your documentation but I still don't see what I am missing.  I have two SUS, one on each VC module as noted above.  Each one of the SUSs is connected to a different Port Channel.  I thought that a SUS would be active as long as all of its member were on the same VC module, but I am not getting that behavior.

Robert_Myhre
Occasional Visitor

Re: Virtual Connect Flex-10 Active/Active with Nexus VCP

I'm not sure what happened this time but I deleted the SUS and recreated it again and this time it came up as active. Try, try again I guess.
Hongjun Ma
Trusted Contributor

Re: Virtual Connect Flex-10 Active/Active with Nexus VCP

i was about to ask you to send VC config for 2 SUS. From what you described, they should become active/active. Next time you see this happen, you may want to open a HP support case to track down or try to bounce the ports by shut/no shut to see if it can achieve the same thing.

My VC blog: http://hongjunma.wordpress.com