BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

Virtual Connect GUI Display Issues

chuckk281
Trusted Contributor

Virtual Connect GUI Display Issues

James was looking for somehelp with VC upgrade issues he was seeing:

 

****************

 

I was working on a customer site doing some upgrades from very old versions of the Virtual Connect and have encountered the following issue I am hoping someone might be able to help with.

 

Because of the age of the firmware we are having to do a multi hop upgrade, the first version we upgraded to is 3.15. We as expected hit a couple of issues during the upgrades but nothing major but we are left in the following condition.

 

When we log onto the Virtual Connect Manager all seems ok, however if we try to go to any menu that uses the newly installed java functionality we just get a blank page as show below. There are no errors just a blank page. We have tried different browsers, different settings, different versions of Java all without any success. Has anyone seen this issue before? At the moment the customer won’t allow us to continue with the upgrade until we can explain or solve this.

 

The only issue we have found is that the original Virtual connect domain name was over 31 characters long. This is now shortened in the GUI to 31 characters but if you SSH into the modules they still show the name as being 35 characters long. But I am not sure if that would cause this issue.

 

webpic197.jpg

 

webpic196.jpg

 

************

 

Reply from Hoa:

 

******************

 

I wouldn’t go to version 3.15 for the no_comm issue or you needed upgrade VC in steps.    That said, certain VC firmware rev at 2.x when upgrading OA FW during its reset can drop your VC Ethernet connections where if BFS can trigger unplanned outage.     Do you have flash 10.x or higher?    Have you cleared browser cache?   

 

***************

 

Info from Mark:

 

****************

 

Make it simple here.

The GUI will only show 31 characters so if the CLI shows 35 characters long that you are truncated in the GUI and the Domain name needs to be shortened else when “calls” are being made when the pages load, the 32+ Domain name is aborting and the rest of the page doesn’t load.

Go to that Domain and really shorten it, make it like 10 characters, verify the CLI shows 10 characters and then test those pages, if it works then reset the Domain name to whatever you want because the new firmware will not let you configure more than that is allowed.

If the pages are still not loading and the Domain name shows 10 characters in CLI/GUI, then it is not being caused by this. I suspect though if the CLI shows 35, you have the problem.

 

******************

 

Comments or suggestions?