BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

Virtual Connect, NIC Teaming W2K8 R2 4 NIC's ACTIVE/ACTIVE

 
Ethern27
Collector

Virtual Connect, NIC Teaming W2K8 R2 4 NIC's ACTIVE/ACTIVE

Hey Group,

I need some assistance if not guidance on achieving
active/active scenario with blade nic teaming

I have a c7000 with various BL680 G5’s and BL460c, virtual
connect module 1/10 F connected to bays 1,2, 5,6,7,8

 

On one of the BL460c, I have installed W2K8 R2 64bit,
updated with the latest drivers and firmware. The blade has a 1GB quad port NIC
card installed on mezzanine 2. As you all know, each port by default is mapped  a single virtual connect module at the back of
the enclosure. On port 2 of each virtual modules on bay 5,6,7,8 , I have cross
connected these ports to core switch and configured the ports on the switch for
etherchannel. Within the HP nic teaming application , all four ports are part
of the same team group and I am using switch-assisted load balancing with fault
tolerance  (SLB)as the team type. By
using SLB, I am able to see that all 4 ports are configured for Tx\Rx -  active\active – within the Nic teaming
application.

Going to the virtual connect manager, I created a new Ethernet
group and added the 4 ports to the group, connection type – auto. The problem
is that when I look at the Ethernet group from with virtual connect manager , I
am showing that 2 of the ports are active and the other 2 are on active\standby.
What can I do to get all the 4 ports active? 
I am already seeing packets getting dropped on the teamed nic indicating that there is a
problem with setup and I think it’s related to the 2 active\standby ports.

Is it possible to team all the nic ports in a blade and
achieve active\active scenario with combine throughput of all the ports ? Is
active\active teaming scenario only possible with nics mapped to the same
module?

5 REPLIES
Bart_Heungens
Honored Contributor

Re: Virtual Connect, NIC Teaming W2K8 R2 4 NIC's ACTIVE/ACTIVE

Hi,

 

If you want all active paths, you will need to create 4 ethernet networks, 1 per VC module...

 

For all details take a look at the VC Ethernet Cookbook where you can find all possible scenario's...

http://h20000.www2.hp.com/bc/docs/support/SupportManual/c01990371/c01990371.pdf

 

 

Kr,

Bart

--------------------------------------------------------------------------------
If my post was useful, clik on my KUDOS! "White Star" !
Ethern27
Collector

Re: Virtual Connect, NIC Teaming W2K8 R2 4 NIC's ACTIVE/ACTIVE

That makes sense. I now have 4 networks created, 1 per VC module. Each of these networks have been assigned to a NIC port on the 460c blade.

The 4 ports are part of the same nic team group with SLB enabled and TCP IP4 Checksum ofload disabled. On the upstream switch (cisco 6509), the ports are part of the same etherchannel group.

The problem that I am seeing now is occassional ping packet dropped (request timed out) when pingin the Team IP from an external device.

Pings from within the blade to an external device seem ok - no drops there.

What could be casue of the drops? NIC Teaming App / Upstream switch ?

 

 

Bart_Heungens
Honored Contributor

Re: Virtual Connect, NIC Teaming W2K8 R2 4 NIC's ACTIVE/ACTIVE

Mmm don't see directly what is going on...

I don't understand the fact that the ping from a server inside the enclosure to the outside works fine without drops, and the same ping from outside to the inside you have drops? Should be the same path...

 

Take also a look at the following document "Virtual Connect for the Cisco Administrator" for the optimal configuration on the Cisco side:

http://h20000.www2.hp.com/bc/docs/support/SupportManual/c01386629/c01386629.pdf

--------------------------------------------------------------------------------
If my post was useful, clik on my KUDOS! "White Star" !
james_sr
Occasional Advisor

Re: Virtual Connect, NIC Teaming W2K8 R2 4 NIC's ACTIVE/ACTIVE

Hello, 

 

I know this is an old post but I would like to know if you were able to resolve your issue. 

 

I think I'm encountering this kind of issue. 

 

Thanks, 

Casper42
Trusted Contributor

Re: Virtual Connect, NIC Teaming W2K8 R2 4 NIC's ACTIVE/ACTIVE

You never Port Channel (LACP) ports together if they are going to DIFFERENT VC modules.

Only ever Port Channel ports that arrive at the same VC Module. Even if your Catalyst has VSS (or your Nexus has vPC), the VC Side has no similar support at this time. So they are not going to handshake properly.

James, if you still need help, I encourage you to start a new thread so it gets more attention. Include as much detail as possible.