BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

Why does Firmware Update DVD 9.20b / SUM not detect the need to upgrade VC firmware?

chuckk281
Trusted Contributor

Why does Firmware Update DVD 9.20b / SUM not detect the need to upgrade VC firmware?

Tom had a customer ready to do firmware upgrades:

 

******************************

 

A customer of mine is prepping to update on enclosure with Firmware Update DVD 9.20b. When we runs this in online mode and points it to the OA on the enclosure, it discovers the OA needs a firmware update but not that the 8 VC modules in that same enclosure need an update, which they do. He sent me the VCSU health check which sees all 8 modules but also says it could not find a primary VC module – yet if you look at output from that run below it clearly shows bay 1 as primary.

 

Any ideas why this is happening?

 

*************************

 

Steve provided the answer:

 

**********************

 

You may have the firmware on the DVD but you can’t use SUM to update it. Per the VC 3.15 Release Notes:

 

“Firmware update

HP BladeSystem c-Class Virtual Connect Support Utility v 1.5.1 or later is required to install the HP VC

3.10 or later firmware package.”

 

***********************

 

Some confusion out there at to what is on the DVD and for what it actually does the automated upgrades.

1 REPLY
chuckk281
Trusted Contributor

Re: Why does Firmware Update DVD 9.20b / SUM not detect the need to upgrade VC firmware?

More info on this from Sam:

 

*****************

 

Does Firmware Update DVD 9.20b contain VC firmware?

Yes – VC 3.10

 

Can Firmware Update DVD 9.20b update VC module firmware?

Yes – HP SUM

 

I want 3.15, not 3.10, how do I load VC 3.15 on my VC modules?

1 – download from the VC support page, the VC 3.15 Smart Update component for either Windows or Linux

 

2 – Follow FW DVD / HP SUM documentation that explains where to place the component  you downloaded from step 1.

3 – run HP SUM, and VC 3.15 should be a selectable option.

 

HPSUM01.jpg

 

-or-

1 – Follow FW DVD 9.20b instructions.  This will level-set the enclosure firmware set.

2 - download from the VC support page, the VC 3.15 BIN file and use VCSU 1.5.2 to update the VC modules.

 

Here’s a friendly reminder how VC FW update through HP SUM works: http://h20000.www2.hp.com/bc/docs/support/SupportManual/c01857420/c01857420.pdf

 

 

Btw – always use the latest VCSU version, otherwise you may see output like at the bottom of the email thread.  I’m guessing the VC modules were at v3.x and an old VCSU 1.4.1 was used to run a health check.  VCSU 1.4.1 was released before VC 3.0 and is not compatible with each other.  VCSU 1.5.2 is the latest.

 

***********************

 

Great info from Sam.

 

Other comments or suggestions?