BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

compatiblity issue with Gen8 blades and older 1/10Gb interconnect module (399593-B22)?

 
SOLVED
Go to solution
Mike O.
Regular Advisor

compatiblity issue with Gen8 blades and older 1/10Gb interconnect module (399593-B22)?

We have a blade environment that has been in place for several years.    Our general production environment has two C7000 chassis with a number of BL465C G5 and G7 blades, and some BL460c G7's.   We're running VMWare 5.0 and 5.1 on the blades.

 

We are using virtual connect for the interconnect modules, but not flex-10 (yet), so the onboard flex-10 NIC's on the G7 blades show up as 1G connections.

 

We recently purchased a BL460c Gen8 server.  I installed it in the chassis and installed VMWare, but after the install, it showed the onboard flex10 NIC's as "not connected".  I reset the VC server profile for that blade, but no change.  I then moved it to another chassis, but saw the same result.

 

I temporarily put it in a different chassis that we purchased last year for a special project.  This chassis does have the newer Flex10 interconnect modules.  In that chassis, the onboard NIC's showed up fine.

 

The chassis has OA firmware 3.70, and the VC firmware 3.60.   According to the release notes, these versions are compatible with the Gen8 blades.

 

I realize the older, non-flex10 modules (1/10Gb, 399593-B22) modules are being retired, but on the G7's we have, the onboard flex10 NIC's do show up as 1G; I was expecting the Gen8 blade to do the same thing.

 

I've opened a ticket with HP, but since it's not really a hardware failure, I'm not sure what they will be able to tell me.

 

Is there any known incompatibility with the Gen8 blades and the older 399593-B22 modules?

 

5 REPLIES
Avi
Occasional Advisor

Re: compatiblity issue with Gen8 blades and older 1/10Gb interconnect module (399593-B22)?

Hello Mike,

As per the quick specs of BL460c Gen8 & when we look at the supported interconnects, it is directed for the Flexible LOM adapters.

http://h18004.www1.hp.com/products/quickspecs/14208_div/14208_div.HTML

0Gb FlexibleLOM Adapters     
HP Ethernet 10Gb 2-port 560FLB FIO Adapter     684214-B21
HP FlexFabric 10Gb 2-port 554FLB FIO Adapter     684212-B21
HP Flex-10 10Gb 2-port 530FLB FIO Adapter     684211-B21

All these adapters are compatible with the below interconnect modules. Request you to go through each & every adpater quick specs shows the general compatible interconnect modules.  

Supported Interconnect Modules HP Virtual Connect Flex-10 Ethernet Module
HP 1/10Gb Virtual Connect Ethernet Module
HP 1/10Gb-F Virtual Connect Ethernet Module HP
HP 6120XG Blade Switch
HP 6120G/XG Blade Switch
HP 1:10Gb Ethernet BL-c Switch
Cisco Catalyst 3120G Blade Switch for HP
Cisco Catalyst 3120X Blade Switch for HP
Cisco Catalyst 3020 Blade Switch
Cisco Fabric Extender B22HP for HP
HP GbE2c Layer 2/3 Ethernet Blade Switch
HP 10GbE Pass-Thru Module
HP 1GbE Pass Thru Module

NOTE: Except for the HP Virtual Connect Flex-10 Ethernet Module, HP Virtual Connect Flex Fabric Module, HP 6120XG, HP 10GbE Pass-Thru Module and the Cisco B22 Fabric Extender, all other supported interconnects are limited to 1Gb per port connection.

In case, if you are using NC530FLB with 1/10 VC Enet modules & running Vmware 5.0 & 5.1 OS, then experiencing Not linked messages on the downlinks of VC 1/10 Modules, request you to update the NIC 530FLB to driver/firmware to respective versions :

1. Update NC530 FLB NIC controller driver to 1.74.19.v5.1 on ESXi 5.1/5.0 U2
https://my.vmware.com/group/vmware/details?downloadGroup=DT-ESXI5X-BROADCOM-BNX2X-17419V501&productId=285&download=true&fileId=50031822&secureParam=&downloadType=

2. Update FLB530 NIC Controller Firmware to 7.4.22
http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=3709945&prodSeriesId=5214873&swItem=MTX-d1f64c6a7302438998f95fdf42&prodNameId=5214874&swEnvOID=4004&swLang=8&taskId=135&mode=4&idx=1

Regards,

Avi

I am an HP employee
Jeroen_Kleen
HPE Pro

Re: compatiblity issue with Gen8 blades and older 1/10Gb interconnect module (399593-B22)?

Mike, it would be good2know your FLB that you have on the blade. Is it a 554? Emulex based? Then I would suggest to update the low level OneConnect fw to revision:  4.2.401.605 (19 Feb 2013)  ftp://ftp.hp.com/pub/softlib/software12/COL46628/co-115438-1/OneConnect-Flash-4.2.401.605.iso

THat might help; if not please let us know what FLB you are using on the Gen8 Blade.
We have seen more connectivity issues with older 1GB IC's and on most or not all of them we have provided by now updated NIC FW levels to resolve those. Cheers, Jeroen

 

(I am an HPE employee and a HPE OneSphere evangelist)
Engage as well with HPE OneSphere experts at our new slack channels for quick and agile discussions around HPE OneSphere and HPE Dev: https://www.labs.hpe.com/slack
If your question is resolved then please acknowledge that and/or provide Kudo's.
Mike O.
Regular Advisor
Solution

Re: compatiblity issue with Gen8 blades and older 1/10Gb interconnect module (399593-B22)?

We're using the Broadcom FLB.

 

I opened a ticket with HP.  After sending it to the blade group, here was their response:

 

"I checked this case with my resources, found that there is no fix as of now, the back end team is currently working on this issue and a new FW version 2.7.18 intended to be released.

 

As of now we do not have a estimate time frame"

 

A follow to them asking what firmware needs to be updated, and they said it was "for the OS Network adapters".

 

 

 

p33tew
Occasional Advisor

Re: compatiblity issue with Gen8 blades and older 1/10Gb interconnect module (399593-B22)?

I believe there is an issue with Vmware 5.0 u2 running on Proliant BL465 G8. Which has this firmware applied to the onboard network adapter: FLB firmware version: 4.2.401.6 may be the problem (this was installed from SPP 2013.02)

 

Firmware on a replacement adapter: 4.0.493.0 worked fine - running the same OS /driver.

 

to get the f/w version - ethtool -i vmnicX

 

This is being investigated by HP.

 

 

thanks
Iaj
Occasional Visitor

Re: compatiblity issue with Gen8 blades and older 1/10Gb interconnect module (399593-B22)?

Avi, 

 

Could you please Suggest Best Upgrade Path for Virtual Connect which is currently running on 3.60, Considering All the blades are at the latest firmware level.

 

Thanks in Advance.

 

Regards,

Amar.