BladeSystem Virtual Connect
cancel
Showing results for 
Search instead for 
Did you mean: 

update FW virtual connect got stuck

 
topokin
Advisor

update FW virtual connect got stuck

I am trying to update our VC Firmware from 3.50 to 3.70, only this got stuck on 20% completed on step 3.

 

The log file indicated these entries, which are just being be repeated:

 

[Wed Jan 16 13:25:13 2013] (2696)[VcsuActivate.cpp:1529] : Checkpoint Validation Failed
[Wed Jan 16 13:26:13 2013] (2696)[VcsuActivate.cpp:1531] : Retrying again
[Wed Jan 16 13:26:13 2013] (2696)[VcsuCore.cpp:4203] : checkCheckPoint FAILED
[Wed Jan 16 13:26:13 2013] (2696)[VcsuCore.cpp:4203] : ErrorCode :94  Error :Checkpoint pending redundancy

I attached a complete log file.

 

Since the VC is now in a state of neither failed nor completed. How should I proceed?

What will be the state of the VC, especially its configuration if I interrrupted the process.

 

Thanks

 

3 REPLIES
topokin
Advisor

Re: update FW virtual connect got stuck

I eventually got failed result after almost 2 hours with these entries in log file.

 

[Wed Jan 16 13:44:27 2013] (2696)[VcsuActivate.cpp:2116] : Failed to activate Primary and Backup modules
[Wed Jan 16 13:44:27 2013] (2696)[VcsuActivate.cpp:2117] : Aborting further activations as this would destroy the VC Domain configuration.
[Wed Jan 16 13:44:27 2013] (2696)[VcsuProgress.cpp:177] : VC Enet Activation Failed
[Wed Jan 16 13:44:27 2013] (2696)[VcsuUpdate.cpp:652] : Firmware update failed on one or more modules
[Wed Jan 16 13:44:29 2013] (2152)[GetUpdateStatus.cpp:234] : [GB87505WD7:5] Update Status: update_result= 0, updateThreadStatus= 0, updateState= 4
[Wed Jan 16 13:44:29 2013] (2152)[GetUpdateStatus.cpp:234] : [GB87505WD7:6] Update Status: update_result= 0, updateThreadStatus= 1, updateState= 5
[Wed Jan 16 13:44:30 2013] (2152)[VcsuInit.cpp:884] : vcsuCleanUp::Could not logout(User) of OA
[Wed Jan 16 13:44:30 2013] (2152)[VcsuLib.cpp:90] : Cleanup failed for one or more reasons

 

What I discovered why cross-checking through OA is that one actually got updated showing the new Firmware version, but the second VC was not updated.

 

What could be the cause and how should I proceed resolving it.

 

Thanks

topokin
Advisor

Re: update FW virtual connect got stuck

I eventually reset the VCs and OAs, then both VCs indicated the recent vesion.

I also used "version and healthcheck" in virtual Connect Utility to check the status, both also indicated espected ok status.

Psychonaut
Respected Contributor

Re: update FW virtual connect got stuck

I went through the same thing on an update from 3.55 to 3.70 back in late November.  I didn't restart the OA, just the VC and that resolved it.  It was disconcerting, but the domain has been trouble free since then.