Client Automation Standard Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

Error with migration from CAS 7.5 to 7.8

Frequent Advisor

Error with migration from CAS 7.5 to 7.8

Hi,

I have installed out-of-box CAS 7.5. I would like to do migration to 7.8 version. I am doing everything with 7.8 migration guide, but i have errors.

Error from command line:

20100601 11:17:41 Info: Would copy C:/HPCABackup/HPCABackup/rms/queues/default/qf10.20100601T075 to C:/Program Files/Hewlett-Packard/HPCA/Data/MessagingServer/default/qf10.20100601
T075
20100601 11:17:41 Info: Would copy C:/HPCABackup/HPCABackup/rms/queues/default/qf10.20100601T080 to C:/Program Files/Hewlett-Packard/HPCA/Data/MessagingServer/default/qf10.20100601
T080
20100601 11:17:41 Info: Would copy C:/HPCABackup/HPCABackup/rms/queues/default/qf10.20100601T081 to C:/Program Files/Hewlett-Packard/HPCA/Data/MessagingServer/default/qf10.20100601
T081
20100601 11:17:45 Error: "C:/migrate/etc" is not a directory
20100601 11:17:45 directory""
20100601 11:17:45 Info: error "\"$dir\" is not a directory"
20100601 11:17:45 Info: }"
20100601 11:17:45 Error: **************************************************
20100601 11:17:45 Error: An error occured while processing (rms) Messaging Server
20100601 11:17:45 Error: Module Reported Errors:
20100601 11:17:45 Error: C:/migrate/etc" is not a directory while executing"error "\"$dir\" is not a directory"" invoked from within"if ![file isdirectory $dir] {
error "\"$dir\" is not a directory" }" (procedure "recursive_glob" line 5) invoked from within"recursive_glob [list $rmsEtcDir] [list *.sql]" (object "::migrate::rm
s::rmsSql2" method "::migrate::rms::RmsSql::load" body line 8) invoked from within"load $rmsEtcDir" while constructing object "::migrate::rms::rmsSql2" in ::migrate::rms::Rms
Sql::constructor (body line 4) invoked from within"::migrate::rms::RmsSql ::migrate::rms::#auto C:/migrate/etc" ("eval" body line 1) invoked from within"eval "$className $
objName $args"" (procedure "::migrate::common::createObject" line 7) invoked from within"::migrate::common::createObject ::migrate::rms RmsSql C:/migrate/etc" ("eval" body
line 1) invoked from within"eval "::migrate::common::createObject ::migrate::rms $class $args"" (procedure "::migrate:::rms::new" line 2) invoked from within"::migrate:::
rms::new RmsSql [getTemplatesEtcDir]" (object "::migrate::rms::rmsRestoreCas0" method "::migrate::rms::RmsRestoreCore::migrateSqlFiles" body line 8) invoked from within"migra
teSqlFiles $preview" (object "::migrate::rms::rmsRestoreCas0" method "::migrate::rms::RmsRestoreCore::execute" body line 5) invoked from within"execute true" (object "::mi
grate::rms::rmsRestoreCas0" method "::migrate::rms::RmsRestore::preview" body line 2) invoked from within"$actionObject $methodName" (procedure "callActionMethod" line 50)
invoked from within"callActionMethod ::migrate::rms::RmsBackup ::migrate::rms::RmsRestore
20100601 11:17:45 Error: Refer to C:/HPCABackup/HPCABackup/logs/RMS-restore-preview.log for more information
20100601 11:17:45 Error: Please contact HP Support for further assistance
20100601 11:17:45 Error: **************************************************

Press [ENTER] to end.



Error from C:/HPCABackup/HPCABackup/logs/RMS-restore-preview.log

"20100601T09:17:45Z";"rms";"preview";"DEBUG";"including sql file C:/HPCABackup/HPCABackup/rms/etc/wbem/hp/win32_timezone.sql"
"20100601T09:17:45Z";"rms";"preview";"DEBUG";"including sql file C:/HPCABackup/HPCABackup/rms/etc/wbem/hp/win32_usbcontroller.sql"
"20100601T09:17:45Z";"rms";"preview";"DEBUG";"including sql file C:/HPCABackup/HPCABackup/rms/etc/wbem/hp/win32_useraccount.sql"
"20100601T09:17:45Z";"rms";"preview";"DEBUG";"including sql file C:/HPCABackup/HPCABackup/rms/etc/wbem/hp/win32_videocontroller.sql"
"20100601T09:17:45Z";"rms";"preview";"DEBUG";"including sql file C:/HPCABackup/HPCABackup/rms/etc/wbem/hp/win32_winsat.sql"
"20100601T09:17:45Z";"rms";"preview";"ERROR";""C:/migrate/etc" is not a directory while executing"error "\"$dir\" is not a directory"" invoked from within"if ![file isdirectory $dir] { error "\"$dir\" is not a directory" }" (procedure "recursive_glob" line 5) invoked from within"recursive_glob [list $rmsEtcDir] [list *.sql]" (object "::migrate::rms::rmsSql2" method "::migrate::rms::RmsSql::load" body line 8) invoked from within"load $rmsEtcDir" while constructing object "::migrate::rms::rmsSql2" in ::migrate::rms::RmsSql::constructor (body line 4) invoked from within"::migrate::rms::RmsSql ::migrate::rms::#auto C:/migrate/etc" ("eval" body line 1) invoked from within"eval "$className $objName $args"" (procedure "::migrate::common::createObject" line 7) invoked from within"::migrate::common::createObject ::migrate::rms RmsSql C:/migrate/etc" ("eval" body line 1) invoked from within"eval "::migrate::common::createObject ::migrate::rms $class $args"" (procedure "::migrate:::rms::new" line 2) invoked from within"::migrate:::rms::new RmsSql [getTemplatesEtcDir]" (object "::migrate::rms::rmsRestoreCas0" method "::migrate::rms::RmsRestoreCore::migrateSqlFiles" body line 8) invoked from within"migrateSqlFiles $preview" (object "::migrate::rms::rmsRestoreCas0" method "::migrate::rms::RmsRestoreCore::execute" body line 5) invoked from within"execute true" (object "::migrate::rms::rmsRestoreCas0" method "::migrate::rms::RmsRestore::preview" body line 2) invoked from within"$actionObject $methodName" (procedure "callActionMethod" line 50) invoked from within"callActionMethod ::migrate::rms::RmsBackup ::migrate::rms::RmsRestore""
"20100601T09:17:45Z";"rms";"preview";"DEBUG";"Exiting with return code: 30"
"20100601T09:17:45Z";"rms";"preview";"DEBUG";"EXIT(30)"


Please help me.

Regards,
Marcin Wiecek

5 REPLIES
Frequent Advisor

Re: Error with migration from CAS 7.5 to 7.8

Hi,

I have created in c:\migrate etc folder and problem disappeared, but I don't know if it is a right way.

Regards,
Marcin
Trusted Contributor

Re: Error with migration from CAS 7.5 to 7.8

Did the backup complete and this is failing during the restore?

Frequent Advisor

Re: Error with migration from CAS 7.5 to 7.8

yes Sir

Regards,
Marcin
Trusted Contributor

Re: Error with migration from CAS 7.5 to 7.8

Ok, can you answer a few questions
1. Did you copy your migrate folder from the DVD media to c:\migrate?

2. did creating that etc folder get past your issue? That looks like a defect that I've seen before and I believe it was environmental but I am not 100% sure.

If #2 worked for you, have you verified after upgrade that everything looks right?

1. all devices there?
2. all groups there?
3. all services you published there?
Frequent Advisor

Re: Error with migration from CAS 7.5 to 7.8

1, yes
2, yes, everything seems good

Regards,
Marcin
//Add this to "OnDomLoad" event