Client Automation Standard Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

Syncronization error

Occasional Advisor

Syncronization error

some idea about this problem?

20050518 18:55:07 Info: CA Begin ...
20050518 18:55:08 Info: IC Begin ...
20050518 18:55:13 Error: can't read "k": no such variable
while executing
"if { $k == "_BASE_INSTANCE_" && [string is true -strict $cfg(-ignore_base)] } {
unset R
continue
}"
(procedure "Class/Copy" line 8)
invoked from within
"Class/Copy ::sync::master::PATCHMGR::PATCH ::sync::slave::PATCHMGR::PATCH *"
("uplevel" body line 1)
invoked from within
"uplevel 1 $args"
(procedure "PERFORM" line 9)
invoked from within
"PERFORM IC [$master name].$I Class/Copy $master $slave $I"
(procedure "Class/Add" line 7)
invoked from within
"Class/Add ::sync::master::PATCHMGR::PATCH ::sync::slave::PATCHMGR PATCH"
("uplevel" body line 1)
invoked from within
"uplevel 1 $args"
(procedure "PERFORM" line 9)
invoked from within
"PERFORM CA [$master name].$C Class/Add [$master get $C] $slave $C "
(procedure "Domain/Compare" line 30)
invoked from within
"Domain/Compare ::sync::master::PATCHMGR ::sync::slave::PATCHMGR *"
("uplevel" body line 1)
invoked from within
"uplevel 1 $args"
(procedure "PERFORM" line 9)
invoked from within
"PERFORM DC $cfg(-domain) Domain/Compare [$master get $cfg(-domain)] [$slave get $cfg(-domain)] $cfg(-class)"
(procedure "sync::main" line 58)
invoked from within
"sync::main -dsn rpm -dsn_user rpm -dsn_pass rpmswec -host radia://idefix.swec.capgemini.es:3464 -rcs_user RAD_MAST -rcs_pass {} -db_type oracle"
("eval" body line 1)
invoked from within
"eval sync::main $args"
(file "E:/Novadigm/IntegrationServer/modules/patch.tkd/bin/sync.tcl" line 33)
invoked from within
"source $argv0"
(file "E:/Novadigm/IntegrationServer/modules/patch.tkd/bin/patch.tcl" line 30)
invoked from within
"source $tcl_startup"
2 REPLIES
Frequent Advisor

Re: Syncronization error

Hi Julio,

By any chance you are installing your patchmgr module from a copied source in your local harddisk? Or did you install it from the CD?

I know I've hit sync problems when I installed mine from copying the source from the CD. But if I install it directly from the CD, everything works fine.

Another way to resolve it would be to get the patch manager 2.1 CD and install it from there.
Should solve your problem.

hope it helps.

Cheers.

rdgs,
Matthew
Trusted Contributor

Re: Syncronization error

Hi Julio,

As suggested by Matthew this problem was solved with the Patch Manager v2.1.
Please upgrade to that version, or request fix RPM00301 from the OpenView Radia support team if you are still running Patch Manager v2.0

Best regards,

Francois
//Add this to "OnDomLoad" event