Client Support
Showing results for 
Search instead for 
Do you mean 

Can TRIM 7.3 client communicate with 6.2.5 database

Advisor

Can TRIM 7.3 client communicate with 6.2.5 database

we are planning to host both the clients 6.2.5 and 7.3 against a  common HP TRIM SQL Database

 

Can we have users in both 6.2.5 and 7.3 communicate with common SQL TRIM database.

5 REPLIES
Honored Contributor

Re: Can TRIM 7.3 client communicate with 6.2.5 database

You should definitely not do this. They are very diffident versions.
Advisor

Re: Can TRIM 7.3 client communicate with 6.2.5 database

 

We are visualising two work group servers in separate domains and a trim client user will have a fixed choice of only connecting a fixed dataset on that workgroup server.

 

so a client on 6.2.5 work group server connects to a dataset "x" which in turns maps to the sql database

on the same lines another client 7.3 connects to same dataset "x" which links to the same sql trim database like above

both requests are served fine.

 

I don't see a glitch here. we have this infrastructure running in current 6.2.5 and 7.1.2 and they work fine.

 

With recent introduction of TRIM 7.3 in our dept which we haven't yet deployed, and was wondering if there were issues, what kind of impact are we experiencing, if you can help here.


Thanks

Honored Contributor

Re: Can TRIM 7.3 client communicate with 6.2.5 database

Although it may function, I doubt you'd get any support from HP. Things that the workgroup server will try to do in the database will be significantly different.
Advisor

Re: Can TRIM 7.3 client communicate with 6.2.5 database

so in essence, If I understood that right,

 

HP TRIM doesn't support the configurations of 6.2.5 compliant Datasets on 7.3 Workgroup Servers

 

If WG server is 7.3 then the database has to be same version,

 

Please correct me if I got this wrong.

 

 

Thanks

Honored Contributor

Re: Can TRIM 7.3 client communicate with 6.2.5 database

Correct. There are so many things that could go wrong... it's just not worth the risk.

Officially I think the statement is that the version of the client and the server should match. So 7.1.0.1157 and 7.1.1.xxxx would be somewhat okay (because they are both 7.1). A 7.3 client and 7.1 may work, but it's not supported. Through 6.2.5 into the mix and I think you're just asking for trouble. :)
//Add this to "OnDomLoad" event