Showing results for 
Search instead for 
Do you mean 

ConnectionInfo failure in 8.1 webservice

Occasional Advisor

ConnectionInfo failure in 8.1 webservice

I used the webservice in 8.0 to make a call to ConnectionInfo to get the current user's uri. This worked ok. After upgrading to 8.1 the call now fails. The error
"ConnectionInfo failed: Get (or set) of this property is no longer supported - please check product documentation. (TRIM Connectivity Toolkit unique id = 1100061)"
is returned in the result. I checked the windows application log on the server and the following was logged:

"Request execution caused an unexpected error \"Get (or set) of this property is no longer supported - please check product documentation.\" for user \"TRIMW2008R2\Administrator\". The call stack is\r\n at TRIMSDK.DatabaseClass.get_LicenceNumber()
at TrimWebService.ConnectionInfo.Execute(Database db)
at TrimWebService.Engine.Execute(TrimRequest req) (TRIM Connectivity Toolkit unique id = 1000063)"


The code I am executing is:
ConnectionInfo ci = new ConnectionInfo();
TrimRequest request = new TrimRequest();
request.Items = new Operation[] { ci };
Engine engine = new Engine();
engine.Credentials = System.Net.CredentialCache.DefaultCredentials;
TrimResponse response = engine.Execute(request);

 

The license format has changed in 8.1 and there doesn't appear to be any License number any more.  Is there any patch for this or any workaround?

1 REPLY
HPE Expert

Re: ConnectionInfo failure in 8.1 webservice

Not sure what the new call is for ConnectionInfo, have you checked the doco? 

 

But the licensing has changed, no longer are keys supported. If you need a new license for 8.1 you can use the eval license for testing or if you need to upgrade your production environment, best to get into contact with your account manager.

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**
//Add this to "OnDomLoad" event