Showing results for 
Search instead for 
Do you mean 

Deployed Trim 6.2.3 doesn't remove properly?

Valued Contributor

Deployed Trim 6.2.3 doesn't remove properly?

A group of staff in our organization is testing Trim 7.1.  Since Trim easily malfunctions if a new version is installed on top of the old version, I have been manually uninstalling Trim 6.2.3.1147 (which was deployed to the computer accounts as an assigned administrative installation via Group Policy) so that I can manually install Trim 7.1.1132.  I have noticed multiple times now that after I uninstall Trim 6.2.3 (which completes without any error) and refresh the installed application list in Add/Remove programs, Trim 6.2.3 is still listed and when I try to uninstall it again, it goes through the motions as if it is removing Trim, but fails with the following message:

 

Internal Error 2753.

TRIMworkgroupDCOMProxy.exe.4A42DE65_71DD_4970_9E20_AC69399F44A1

 

Followed by:

Fatal error during installation.

 

When I refresh the program list again, Trim 6.2.3 is still listed and it will fail the same way each time I try to remove it normally.  I don't want any lingering software interfering with the new Trim installation, so it is at this point that I end up using Windows Installer Cleanup (which Microsoft no longer officially supports).  Trim 7.1 subsequently installs with no errors.  Is there a particular cause for this malfunction?

9 REPLIES
Honored Contributor

Re: Deployed Trim 6.2.3 doesn't remove properly?

Is it possible that these problem machines have a different 6.2 version installed?

Are you trying to uninstall manually on the machine or using Group Policy?

Was it a per-user install or per-machine?

 



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

INFORMOTION.com.au
Valued Contributor

Re: Deployed Trim 6.2.3 doesn't remove properly?

On some of the affected computers, Trim 6.2.3 may or may not have been deployed (as software assigned to the computer accounts) on top of Trim 6.2.1.  The uninstallation was being performed manually via the Add/Remove programs applet.

Honored Contributor

Re: Deployed Trim 6.2.3 doesn't remove properly?

Yeah, if it was deployed via GP, but uninstalling manually on the machine via Add/Remove, I've seen packages fail to uninstall properly. (Not a TRIM thing, just something I've seen with GP in general)


You might want to try the uninstall via GP instead and run a gpforce on these problem machines while logged in as an admin.



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

INFORMOTION.com.au
Valued Contributor

Re: Deployed Trim 6.2.3 doesn't remove properly?

That might work, but in essence, that would double the number of GPOs needed to maintain the gradual transition from one version of Trim to another:  For each remote office, one GPO to handle deployment of one version, and another to handle deployment of a newer version.

 

I still wouldn't consider this normal behavior of a program installer since, as far as I know, deployed software is supposed to be able to be removed manually.  Is this something that one of the developers would want to look into?

Honored Contributor

Re: Deployed Trim 6.2.3 doesn't remove properly?

Well yes, it would increase the administrative overheads in AD, but like I said, I've seen this problem with Group Policy in general.

 

In some environments I can always uninstall TRIM without issue, in others I get similar problems to what you described. (Uninstall failing or TRIM reinstalling at next logon etc)

The difference normally being with something I've played with in AD or on the GPO.



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

INFORMOTION.com.au
Valued Contributor

Re: Deployed Trim 6.2.3 doesn't remove properly?

Would this be considered defective behavior of Trim's installer or a defect of Group Policy?

Honored Contributor

Re: Deployed Trim 6.2.3 doesn't remove properly?

That depends on where the problem is.

In my experience, the standard Group Policy behaviour can be unpredictable, which is why there are so many application deployment products out there.

 

But I also wouldn't rule out a problem with the TRIM msi.

I suggest looking at the GP side of things and if you still can't get the package to uninstall correctly, then you may want to log a support case with HP. (Though support for GP is very limited and if we can't replicate, we probably wont be able to provide advice on this. Microsoft support may be an alternative so they can look into the GP side.)



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

INFORMOTION.com.au
Trusted Contributor

Re: Deployed Trim 6.2.3 doesn't remove properly?

Applications installed by GP are considered managed applications so if an application is installed using GP it should be removed using GP and vice versa. Any mixed method can cause unpredictable behavior.

 

If you search the web for applicants that are not uninstalled, i.e., still in the Add/Remove Programs list, you will see there are hundreds of applications that have this problem so the logical conclusion is that this is not a problem limited to TRIM …. so says Microsoft:

http://support.microsoft.com/kb/314481

_________________________________________
HP Application Information Optimizer (AIO) Support
Valued Contributor

Re: Deployed Trim 6.2.3 doesn't remove properly?

We're already testing the method of having Group Policy uninstall the managed application and installing the newer version of Trim.  So far, our results are that the Outlook integration is broken and causes Outlook to hang and eventually crash.  I have a ticket open with HP on this matter.

//Add this to "OnDomLoad" event