Showing results for 
Search instead for 
Do you mean 

Global Settings unstable and not working

Regular Advisor

Global Settings unstable and not working

On Trim - 32 bit  7.22 (3697) on Windows 7 - 64 bit we're continually having an issue with the majority of end-users not automatically getting global when they first start using Trim (the deployment package is set automatically to get global on first login - this isn't working.)

 

Additionally after logging in they run a manual get global but it takes about 4 attempts to get all the settings we have pre-set.

 

Following this they login again at a later date and all settings have reverted back to vanilla.

 

Global settings are set currently in:

 

C:Users<userid>\AppData\Roaming\Hewlett-Packard\HP TRIM\<dbid>

 

Has anyone had similar experience and / or have they got this working correctly by changing global locations to a network drive instead of "C:" ?

3 REPLIES
HPE Expert

Re: Global Settings unstable and not working

Get Global on first start up only works for the very first time a user logs on to TRIM, so after that first attempt they will need to Get Global manually.

 

In terms of it not sticking you need to make sure of a couple of things first.

 

- all users need to be in the same language version eg all on US english. 

 

- users will also need permission to write to their C drives and registry for the changes to stick. If the permissions are blocked obviously the changes will not be maintained.

 

- ensure that lock down mode is disabled in TRIM.

 

moving the settings to a network drive will not make this process any easy. C drive is always the preferred location.

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**
Regular Advisor

Re: Global Settings unstable and not working

Thanks Greg - when you mention the US English settings do you specifically mean the 'dictionary' or 'locale' too'? at present ours is set (for all users and both in locale and dictionary)  to 'English - International'  - do we need to switch this to US English for all, or should this work as long as all users are set with 'English - International' .

 

I also have read in another thread that if we remove the dword 'auto get global' key 

 

(HKEY_CURRENT_USER\Software\Hewlett-Packard\HP TRIM\DBID\<DataSetID>\AutoGetGlobal)

 

each user will get global each time they log in - could adding a startup script that removes this entry each time (for end users only) solve our problem?

 

The main objective with this is to keep our set global settings intact and not have user settings pop back to vanilla on a regular basis, and if at all possible, remove any need for users to have to get global manually each time they login

HPE Expert

Re: Global Settings unstable and not working

your locale, that is where the Global settings are installed to. If everyone is on English - International you will be fine.

 

I don't think removing that key will help. 

 

If the changes are not getting committed to the PC then I can say with some certainty that the issue will be related to group policy in your network, rather than being a TRIM issue (provided the lock down setting is off).

 

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**