Showing results for 
Search instead for 
Do you mean 

No preview of documents - Trim 7.1

SOLVED
Go to Solution
Frequent Advisor

No preview of documents - Trim 7.1

just noticed that I don't get any preview of documents.

 

The preview pane just says;

 

Preview not available in this context, due to audit log settings.

 

 

Does anyone know how to fix this?

 

I am running Trim 7.1 and trying to preview any documents - , .doc, .xls, .pdf   etc

11 REPLIES
Honored Contributor

Re: No preview of documents - Trim 7.1

Go to the properties for the Record Type that you are trying to preview and turn off all the Audit option as a test.

 

Let me know if that fixes the problem.

 

This was a bug back in 6.2.3 or so.... hope it hasn't come back again....



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

Kapish.com.au
Frequent Advisor

Re: No preview of documents - Trim 7.1

OK.  Unchecked all of the auditing for that document type.  Restarted Trim and it looks like preview is now working.

 

I then enabled the auditing on that document type again and restarted Trim.  The preview is still working.  Just a note that not all of the auditing was enabled on that record type, and when I re-enabled the auditing I only enabled it on what was enabled before.

Honored Contributor

Re: No preview of documents - Trim 7.1

Hmmm... CR 39968.

Still open though and isn't fixed yet.

 

I've flagged it again with R&D.

 

Workaround is to untick the 'Document Viewed' Audit option on the Record Type properties.

 



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

Kapish.com.au
Frequent Advisor

Re: No preview of documents - Trim 7.1

Just restarted Trim again and now the preview is not working again.  Checked the audit options and Document Viewed is enabled.

So for some reason, when I re-enabled it and restarted Trim preview was working.  So maybe it takes a bit of time for the toggling of auditing events to actually take effect.

 

So...HP please fix this.

Honored Contributor

Re: No preview of documents - Trim 7.1

 


Chum70 wrote:

So...HP please fix this.


 

I've turned up my R&D hassling level.

:smileyhappy:



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

Kapish.com.au
Frequent Advisor

Re: No preview of documents - Trim 7.1

Thanks.

 

It looks like this has caused another issue.  By using the Trim 7.1 client to change the record type audit events has caused the Trim form for this record type to go all screwy on anyone running Trim version 6.2.4... AAAAAAARGH!!!

 

I am looking at how to fix this now...it's urgent!!!

 

Honored Contributor

Re: No preview of documents - Trim 7.1

I'd suggest setting it to where you want it. (e.g. all Audit options you want except Document Viewed)

Then schedule a restart of the WG services.

 

There's probably some cached versions hanging around on some clients.

 

 

EDIT: Or did you do this with a 6.x backend? o_O



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

Kapish.com.au
Frequent Advisor

Re: No preview of documents - Trim 7.1

Disaster averted.

 

I had to edit the form for the record type using a Trim 6.2.4 client and uncheck 'restrict editable width' on any offending field.  Why this has occurred, no idea!!

 

Maybe, it was already checked in the previous version of Trim, however possibly it never actually worked until 7.1 and saving the changes using the 7.1 client actually applied it as it should.

 

 

Honored Contributor

Re: No preview of documents - Trim 7.1

/slap on the wrist for fiddling with 7.1 in 6.2.X production

 

 



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

Kapish.com.au
Frequent Advisor

Re: No preview of documents - Trim 7.1

Yes I should know better - However if I had done this in a test environment that no one uses I would not have found what impact it would have.

Frequent Advisor

Re: No preview of documents - Trim 7.1

Hi,

 

We've recently upgraded from 6.2.4 to 7.1 (1132) and encountered the same problem.  Has there been any update from R&D on a solution?

 

Cheers,

 

Michael