Client Support
Showing results for 
Search instead for 
Do you mean 

Record belongs to series - cannot create new part!

Valued Contributor

Record belongs to series - cannot create new part!

[ Edited ]


HP RM8.1.1.7760, win 7, SQL 2012, MS Office 2010 



in all Environments that i have, i cannot create the volume 2 of a corporate file level 4 because that corporate file belongs "within series" 000000 .... 

The file is from 2006, so old TRIM.


The picture gives more info about the issue: 


I tried in TRIM 734 environment, in production 8.1 and the latest one 8.2.01 , cannot be done, the relationship cannot be removed to allow the creation of the new part ... 


What can we do here?

I even asked the DBA Administrator to remove the relationship from the database, but thaere was none ... 


Last attempt was to create brand new file (As even the COPY file cannot be done) and then manualy change the old file to 06:1939-01 and manualy change the reocrd number of the newly made file to 06/1939-02 , and even third one 06/1939-03 but they are not related as parts...

If we do like this, how can we make it look like they are 3 related parts ... e.g. when we click on one: SHOW ALL PARTS to display volumes 1,2 and 3 ...?



HPE Expert

Re: Record belongs to series - cannot create new part!

Is there any additional information under 'view rights' it might have something further about why it cannot be added to a series.


Has the record been closed?

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**
Valued Contributor

Re: Record belongs to series - cannot create new part!


can't tell anything anymore, 

I made another file then i changed the HP RM record numbers and expanded numbers of the original file and newly made one 15/ to be like with Volume 1 ( -01 and -02) ..It worked..

then I related them as "the 02 is the latest part of the -01 ) 

it worked OK.

Off course , first all that was done in testing environment and also i exported (print merged) all possible metadata of these 2 files together with some other existing old files that have vol -01 and -02 and after importing in MS Excel and examining, there was no differences in these metadata.... 

In test, the volume 3 was made normal way, menaing, NEW PART creation..

Can anyone "confirm" that this is safe...e.g. no damage/isssues within a database in any way: retention...numbering system...or anything else?



Honored Contributor

Re: Record belongs to series - cannot create new part!

I feel your pain .....


So at somestage the record type you are using had the series option, and now it doesnt. So when you create copies, trim copies the series, and thats not allowed anymore for this record type. I think i have tried all the thing you have done as well at some stage.


I threw in the towel on this!


I reenabled Series Record on the record type, created a new series called NULL and added this as a default to the record type. then did a search of all records of that type without a series and set the series to NULL




Valued Contributor

Re: Record belongs to series - cannot create new part!


I also gave up on how to fix that and I just made that volume 2 as described above.... just wandering if that will cause some issues later ....

But thanks.. cheers


//Add this to "OnDomLoad" event