Client Support
Showing results for 
Search instead for 
Do you mean 

Run-time error 91: Object variable or With block variable not set

SOLVED
Go to Solution

Run-time error 91: Object variable or With block variable not set

Hi all!

 

Just wondering if anyone has run across the above error or anything similar in the past in relation to TRIM-Outlook integration. I haven't had much luck narrowing it down further than that...

 

TRIM 6.2.2.8617 running on WinXP SP3 with Office 2003 SP3.

 

(1) Outlook is closed.
(2) Start TRIM Context.
(3) Open a saved search (returns email-based inquiries awaiting assessment).
(4) Open each TRIM record.
(5) Open the email attachment (MSG file, starts Outlook.exe, but not the full client GUI).
(6) Read and then close the email message (doesn't seem to close Outlook.exe).
(7) Make comments in the TRIM record and mark it as assessed.
(8) Return to step 4, select the next record and repeat.
(9) Close TRIM once all records are assessed.

 

At this last step the error occurs and a pop-up "Run-time error 91: Object variable or With block variable not set" appears.  Both the TRIM and Outlook processes remain running in the background and must be killed via task manager before they can be used/accessed again.

 

The catch is that this seems to occur almost at random. Some days it doesn't happen at all, some days it occurs twice or more. It also occurs across multiple PCs.

 

The issue does not seem to be resolved by repairing or reinstalling TRIM or by repairing MS Office.

 

I noticed a few reports of similar issues on the old forums relating to linked folders in Outlook, but we don't use those here.

 

Has anyone had any experience with this particular error message with TRIM & Outlook?

 

Cheers

Ross

8 REPLIES
Occasional Advisor

Re: Run-time error 91: Object variable or With block variable not set

Hi

I am getting this error message currently. I get mine when I try to link an Outlook folder to a TRIM folder. My error says only: "Object variable or With block variable not set"

Frequent Advisor

Re: Run-time error 91: Object variable or With block variable not set

Hi,

We have experienced the same issue intermittently using linked folders with Groupwise integration.  Past forum notes detailed that this could be caused by having undisclosed receipients as one of the addresses in the To field.  We checked this out and could not find any occurances of this, but the emails that appeared to be cuasing issues have since processed.  Strange. 

Will be interested in any suggested solutions to this issue.

Re: Run-time error 91: Object variable or With block variable not set

There's a discussion on runtime error 91 and linked folders here in the old forums. Unfortunately, we don't use linked folders in our implementation, so that doesn't help solve my issue. Perhaps it will help with yours? :smileywink:

Occasional Advisor

Re: Run-time error 91: Object variable or With block variable not set

There was some talk some time ago about a bad version of MDAC causing this intermittent issue. My suggestion would be to simply reinstall MDAC 2.8 on the machines showing symptoms, then restarting the machine and seeing if that helps.

It can be downloaded from http://www.microsoft.com/downloads/details.aspx?familyid=6c050fe3-c795-4b7d-b037-185d0506396c&displaylang=en

Re: Run-time error 91: Object variable or With block variable not set

Thanks Greenie. I'll check the software catalogue on those machines, and if MDAC is installed, I'll try updating it and get back to you!

 

Cheers

Ross

Regular Advisor

Re: Run-time error 91: Object variable or With block variable not set

I also have a similar problem with a Vista computer running Trim 6.2.3 and Office 2003.

 

I get the error message "The list of linked folders could not be refreshed object variable or With block variable not set. 8"  This error occurs in Outlook when trying to create a linked folder or when trying to view the list of linked folders in Outlook.

 

MDAC is no longer available for Vista or Windows 7 as it has been replaced with Windows DAC and is integrated with Vista and Windows 7.  It is not supplied as a redistributable separate component as MDAC was.

 

So if anyone has encountered this issue with Vista or Windows 7, I am interested in a fix and what causes this to break.

 

Upgrading to 6.2.4 or 6.2.5 is not an option as bugs have been introduced in these versions which I believe are still to be rectified.

Re: Run-time error 91: Object variable or With block variable not set

Chum, as I mentioned in my post above, there were a couple of threads relating to run-time error 91 and linked folders in the old TRIM forums, but I can't seem to access them any more, getting connection refused errors. Perhaps an HP rep can comment on the availability of the old forums?

 

With regard to Greenie's suggestion around MDAC in my environment, the client PCs here are Windows XP SP3, which includes MDAC 2.8 SP1. However, I have had 2.8 SP1 stand-alone redeployed to the specific PC and am waiting to hear back from the user. Unfortunately the error is difficult to replicate on demand! I'll update this thread when I know more.

 

EDIT: old forums are accessbile again!

 

Spoiler

The relevant suggestion was:

 

Found a TechNote on the SSO site: KM769634

Error: Object variable or With block variable not set Error 91

Error Message
The following error occurs when using Linked Outlook folders in TRIM:
Object variable or With block variable not set Error 91

Cause
This error message is usually seen if there is a previously created link that exists in an Outlook profile between a Windows folder and TRIM and the Outlook profile has recently either been recreated or not been functioning entirely correctly so has left an orphaned queue in TRIM.  This especially can happen if the Outlook program was not shut down in the recommended fashion (so causes can include a hard reboot while Outlook is still opened and an Outlook crash when there are e-mails for TRIM to process from Outlook).

Workaround / Fix
Steps to resolve this issue:   
1.  Find the queue in TRIM that was linking to this folder, remove that queue
2.  Delete the link in the TRIM In Outlook Manage area
3.  Reboot the computer to make sure everything is gone from memory
4.  Recreate the TRIM link back to this folder in Outlook

 

Re: Run-time error 91: Object variable or With block variable not set

Follow-up with client reports that the issue has not been completely resolved by re-installation of MDAC/WinXP SP3. It does still occur, but far less frequently.