Client Support
Showing results for 
Search instead for 
Do you mean 

Setting up 'Auto Get Global' on 32 bit RM8 manually

Regular Advisor

Setting up 'Auto Get Global' on 32 bit RM8 manually

re: setup of RM8 on client workstations - Trim 7* contained an Auto  "Get Global Settings on first login' in the setup routine - where is this located in RM8 (build 6347) setup routines? Attached - image of old Trim 7 setting dialog

4 REPLIES
Honored Contributor

Re: Setting up 'Auto Get Global' on 32 bit RM8 manually

It's not available within the UI of the installer.  You can do it if you use the command line or administrative install point install features though.  Otherwise, manually update the MSISettings key in HKLM section of the hive.

Frequent Advisor

Re: Setting up 'Auto Get Global' on 32 bit RM8 manually

[ Edited ]

Hi Eric

 

Any info on how the registry switch works would be welcome.  I tried setting HKLM  AUTOGG to 1 and deleted the HKCU HPTRIM tree. Then firing up RM8.1 didn't access the Global settings.  Came up blank for the dataset.

 

Pete

Occasional Visitor

Re: Setting up 'Auto Get Global' on 32 bit RM8 manually

[ Edited ]

The first registry key below is created but as a String type (REG_SZ) instead of a DWORD value (shown below).

We also need the second registry key below, but it needs to be set to “0” to make AutoGetGlobal to run, at which point it reverts back to “1”. Therefore we can now, at any time, force an AutoGetGlobal by simply changing this value from 1 to 0.

 

[HKEY_CURRENT_USER\Software\Hewlett-Packard\HP TRIM]

"AutoGetGlobal"=dword:00000001

 

[HKEY_CURRENT_USER\Software\Hewlett-Packard\HP TRIM\DBID\xx]

"AutoGetGlobal"=dword:00000001

Frequent Advisor

Re: Setting up 'Auto Get Global' on 32 bit RM8 manually

I little extra information I found.

 

If the first value is set to 1 and the second key doesn't exist, AutoGetGlobal will run and the second key will be created with value = 1.

 

 

So I concur that if you want to change the global settings and force everyone to pick them up, ensure the first key is set to 1 and the second is either 0 or non-existent.

 

Regards