Client Support
Showing results for 
Search instead for 
Do you mean 

TRIM 6.2.4 1240 on server 2008 - Workgroup servers not communicating

Occasional Advisor

TRIM 6.2.4 1240 on server 2008 - Workgroup servers not communicating

Was wondering if anyone has any experience with 6.2.4 1240 and server 2008 sp2 (not R2).
 
I've got 2 workgroup servers which appear to not be communicating after a deployment. I'm receiving the following error message in the TRIM log files.
 
0    Error :   User: SERVER1 - ServiceAccount Failed to communicate with peer TRIM Workgroup Server at SERVER1:4322. [RCF:16] : Client connection attempt timed out., [OS:0] :  ***** Description follows *****  ***** Details follow ***** c:\62\trim\rcf\src\rcf\TcpClientTransport.cpp(182): void __thiscall RCF::TcpClientTransport::implConnect(class RCF::I_ClientTransportCallback &,unsigned int): : Thread-id=2920 : Timestamp(ms)=15944247: THROW : class RCF::Exception : [16: Client connect operation timed out (server not started?).][1: Operating system][0: The operation completed successfully.][What: ][Context: ]: ret=-2, err=0, timeoutMs=2000, mIp=SERVER1, mPort=4322,
 
I'm getting the same on the first server, except replace server1 with server 2.
 
- I've disabled all firewalls.

- Service account is local admin on both workgroup servers.

- I can Telnet to port 1137 and 4322 to each server

 

I'm also unable to connect or detect a dataset when connecting to the local workgroup server with the client.

 

Obviously i'm missing something fairly critical!
 
As there is no documentation (that i can find) on installing TRIM 6.2.x on server 2008. Is there any other prerequisites other than installing the runtimes?

2 REPLIES
Occasional Advisor

Re: TRIM 6.2.4 1240 on server 2008 - Workgroup servers not communicating

For anyone that cares.

 

I have resolved part of this issue. Secret is to make sure you run TES as an administrator under 2008.

 

Unfortunately this handy tip is not included 6.2.4 doco. I'm told it will be included in 6.2.5 doco.

 

I'm yet to figure out why i'm getting these weird comm problems. But for the moment this is not effecting client connections.

Regular Advisor

Re: TRIM 6.2.4 1240 on server 2008 - Workgroup servers not communicating

Did you figure out what the communications problem was?

I'm having the same error, and I cannot figure it out.

-------------------------------------------------------------------------
Environment:
Windows 7 32-bit/64-bit desktops
Windows Server 2012 R2 64-bit App, Idol & Event servers
SQL Server 2012
RM 8.1.0.7517