Client Support
Showing results for 
Search instead for 
Do you mean 

TRIM 7.1 SP 1 Weird Behavior when drag/drop into folder

Honored Contributor

TRIM 7.1 SP 1 Weird Behavior when drag/drop into folder

So with the new 7.1 service pack we've noticed that when you drop an electronic document from your desktop onto a folder, it can result in errors in certain circumstances.  If the record type you select has either "Client", "Representative", or "Addressee" as a required field, TRIM will report that the required field was not provided... and then doesn't save the record.  If you remove the mandatory indicator then you will get the registration form; otherwise you're stuck!  If you try this with a manadatory additional field it works fine.

 

I assume it has something to do with the new way in which the "Verify" method of the object behaves.  Though TRIM Context should still let you save it.

 

Has anyone else seen this?

 

Cheers,

Erik

4 REPLIES
Valued Contributor

Re: TRIM 7.1 SP 1 Weird Behavior when drag/drop into folder

Does it do that even if the "Display a data entry form when creating a new record" option is enabled in Tools>Options>Dropped Files tab?

Honored Contributor

Re: TRIM 7.1 SP 1 Weird Behavior when drag/drop into folder

Yeah.... tried disabling that, re-enabling it... didn't make a difference!

HPE Expert

Re: TRIM 7.1 SP 1 Weird Behavior when drag/drop into folder

QCCR2D43709 - TRIM Context and TRIM Destop--Can't drag/drop a document to a Container if Author is a mandatory field

 

I've added your extra information to the CR, i.e. that it's the same problem with Client, Addressee, Representative...

 

No known workaround yet except the one you've already discovered - make the field non-mandatory on the entry form. :-(


Neil

Note: Any posts I make on this forum are my own personal opinion and (unless explicitly stated) do not constitute a formal commitment on behalf of HPE.

(Please state the version of CM you're using in all posts. At any given time, HPE are supporting approx. 30+ released versions)

HPE Software Support Online (SSO): https://softwaresupport.hpe.com/
Honored Contributor

Re: TRIM 7.1 SP 1 Weird Behavior when drag/drop into folder

Gotta love TRIM! :)

I did a different work-around to ensure the same functionality existed. Instead of using the stock properties I made a UDF for each, using different names, wrote a script to copy the location to the new field for all existing records, and then set the UDF's to be manadatory. Worked like a charm!
//Add this to "OnDomLoad" event