Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

4500 trunking mode not working.. help..

ddicky
Occasional Contributor

4500 trunking mode not working.. help..

 



Hey,



  I'm newbie to 3com switch and are setting up a simple network in our office.Basically I need 2 vlan to be able to talk to each other  on all the 26 ports &  I set the trunking mode on the all the 26 ports.It means at anytime I need to connect to any of the 26 ports , as long as my client devices are configured correctly with the IP range below and gateway I should able to ping or talk to to each other. But I have no luck doing that work. 



vlan 1 192.168.1.0/24 , vlan IP 192.168.1.1/24



vlan 2 192.168.2.0/24 vlan ip 192.168.2.1/24



 



I just downloaded latest version from 3com website and load into the switch



Any advise or command are highly appreciated.



 



4 REPLIES
vangass
Frequent Advisor

Re: 4500 trunking mode not working.. help..

Hi,



 



Well, it wouldn't work if your client devices aren't in trunk mode.



Every frame going out from your trunk port on switch is tagged with VLAN id and on the other side of the link another device has to be also in trunk mode to untag arriving frames. Standard client device (like PC) doesn't recognize arriving tagged frames so it's discarding them. IP address doesn't matter in this case.



 



Regards,


Vangass



ddicky
Occasional Contributor

Re: 4500 trunking mode not working.. help..

Thanks for your response Vangass.



Does it means if my pc is on vlan 1,I must plug  it into a vlan1 port and no way I can get it running if I plug into a vlan 2 port although all are configured as trunk port?



 



vangass
Frequent Advisor

Re: 4500 trunking mode not working.. help..

Yes, thats right.


In 3Com 5500 series (for sure, don't know about others) there is a possibility to set different vlan on access port depending on mac-address of the connected host -> see mac-authentication in the manual.



Regards


V.



Fred_Mancen_1
Super Advisor

Re: 4500 trunking mode not working.. help..

You can configure the ports as hybrid ports, using the VLANs you want as untagged VLANs. Try this script:



interface ethernet 1/0/N => Where N is the port number.



port link-type hybrid



port hybrid vlan 1 2 4 8 34 untagged



port hybrid pvid vlan <native_vlan_id>



You don't need to specify a PVID VLAN ID if you prefer, and in this mode any host that doesn't support trunk mode will work properly in these ports.



HTH