HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

5120-EI IRF configuration issues

 
LostedMan
Occasional Advisor

5120-EI IRF configuration issues

Hi all.  I'm fairly familar with the 3Com Comware-based switches running Comware version 3.  I'm helping out a friend who has an IRF stack of 3 HP 5120-EI switches (JG237A).  I've helped him out before, and my feeling is that these switches are a weird mix of Comware and Procurve commands.  (As an aside, how on earth did HP decide to put port #1 on the bottom left?  Why not leave it at the top left like everyone else and most of HP's other switches?) He wants to add another IRF member to this stack, and so far, he's had no success on his own.  Either the switch stack locks up, or configuration files get lost.  I've worked on XRN stacks before, but not IRF per se.  Any thing I should look out for as possible causes?

TIA,

Brian

 

3 REPLIES
johnk3r
Respected Contributor

Re: 5120-EI IRF configuration issues

Hello !

Please post the IRF configuration here. And a look at this article:

http://blog.yogi-way.lv/2011/10/how-to-replace-h3c-stack-member.html

**************************************
ATP FLEXNETWORK V3 | ACSA
VoIP-Buddy
HPE Pro

Re: 5120-EI IRF configuration issues

Here is the IRF manual for you... HP 5120 EI IRF Manual

All of the other 5120 EI manuals can be found here... HP 5120 EI Manuals

Just as an aside, the 5120 is running Comware 5.  It is quite a bit different than Comware 3 and IRF is nothing like XRN.  There is nothing ProCurve-like about it.

Good luck!  I hope this helps.

Regards,

David

LostedMan
Occasional Advisor

Re: 5120-EI IRF configuration issues

Redacted config:

#

version 5.20.99, Release 2221P02

#

sysname Stack

#

voice vlan aging 5

voice vlan mac-address 000f-d300-0000 mask ffff-ff00-0000

undo voice vlan security enable

voice vlan track lldp

#

irf mac-address persistent timer

irf auto-update enable

undo irf link-delay

irf member 1 priority 32

irf member 2 priority 24

irf member 3 priority 20

#

domain default enable system

#

telnet server enable

#

cluster enable

stack ip-pool x.x.x.x 255.255.255.0

stack role master

#

loopback-detection enable

#

mirroring-group 1 local

#

password-recovery enable

#

acl number 3997

rule 0 permit ip dscp ef

rule 1 permit tcp destination-port eq www

rule 2 permit udp destination-port eq snmp

rule 3 permit udp destination-port eq snmptrap

rule 4 permit ip dscp cs6

rule 5 permit ip dscp cs7

#

acl number 4999

rule 0 permit type 8868 ffff

rule 1 permit source-mac 00e0-bb00-0000 ffff-ff00-0000

rule 2 permit source-mac 0003-6b00-0000 ffff-ff00-0000

rule 3 permit source-mac 00e0-7500-0000 ffff-ff00-0000

rule 4 permit source-mac 00d0-1e00-0000 ffff-ff00-0000

rule 5 permit source-mac 0001-e300-0000 ffff-ff00-0000

rule 6 permit source-mac 000f-e200-0000 ffff-ff00-0000

rule 7 permit source-mac 0060-b900-0000 ffff-ff00-0000

rule 8 deny dest-mac 0000-0000-0000 ffff-ffff-ffff

#

vlan 1

#

vlan 2

#

vlan 3

#

vlan 4

#

vlan 5

#

domain system

access-limit disable

state active

idle-cut disable

self-service-url disable

#

qos policy default

#

user-group system

group-attribute allow-guest

#

stp instance 0 root primary

stp enable

#

user-profile privilege

#

interface Bridge-Aggregation1

description \\ Link to top switch //

port link-type hybrid

port hybrid vlan 2 tagged

port hybrid vlan 1 untagged

link-aggregation mode dynamic

undo ntdp enable

#

interface Bridge-Aggregation2

description \\ Link to bottom switch //

port link-type hybrid

port hybrid vlan 2 tagged

port hybrid vlan 1 untagged

link-aggregation mode dynamic

undo ntdp enable

#

interface NULL0

#

interface Vlan-interface1

ip address x.x.x.x 255.255.252.0

dhcp relay server-select 1

#

interface Vlan-interface2

ip address x.x.x.x 255.255.255.0

#

interface Vlan-interface3

ip address x.x.x.x 255.255.255.0

#

interface Vlan-interface5

ip address x.x.x.x 255.255.0.0

undo dhcp select server global-pool

#

>>>

output suppressed

>>>

interface Ten-GigabitEthernet1/2/1

port link-type trunk

port trunk permit vlan 1 to 4049

undo ntdp enable

#

interface Ten-GigabitEthernet1/2/2

port link-type trunk

port trunk permit vlan 1 to 4049

undo ntdp enable

#

interface Ten-GigabitEthernet1/1/1

#

interface Ten-GigabitEthernet1/1/2

#

interface Ten-GigabitEthernet2/1/1

#

interface Ten-GigabitEthernet2/1/2

#

interface Ten-GigabitEthernet3/1/1

#

interface Ten-GigabitEthernet3/1/2

#

ip route-static 0.0.0.0 0.0.0.0 x.x.x.x

#

snmp-agent

snmp-agent community read public

snmp-agent sys-info version all

#

dhcp enable

#

ntp-service source-interface Vlan-interface1

ntp-service unicast-server x.x.x.x

#

ssh server enable

ssh user admin service-type all authentication-type password

#

ip https enable

#

load xml-configuration

#

user-interface aux 0 2

user-interface vty 0 15

authentication-mode scheme

user privilege level 3

idle-timeout 60 0

#

irf-port 1/1

port group interface Ten-GigabitEthernet1/1/1 mode normal

#

irf-port 1/2

port group interface Ten-GigabitEthernet1/1/2 mode normal

#

irf-port 2/1

port group interface Ten-GigabitEthernet2/1/1 mode normal

#

irf-port 2/2

port group interface Ten-GigabitEthernet2/1/2 mode normal

#

irf-port 3/1

port group interface Ten-GigabitEthernet3/1/1 mode normal

#

irf-port 3/2

port group interface Ten-GigabitEthernet3/1/2 mode normal

#

return