Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

A3100 - Voice VLAN issue

IsmaelToumi
Occasional Contributor

A3100 - Voice VLAN issue

Hi, 

 

I am experiencing a strange issue on a HP A3100 POE 8 ports

Comware Software, Version 3.10, Release 2211P06

 

When a first IP Phone is plugged, everything works fine. It gets an IP address on the Voice VLAN and boots correctly.

However, other IP Phones plugged into the switch boot correctly but stay stuck at the "2/5 network setup" step ...

 

My suspicions are on the "voice vlan mode automatic" and "voice vlan legacy" function.

 

Does anyone knows exactly what are the purposes and when to use these 2 functions ?

 

We have a simple network configuration : 

- 1 DATA VLAN : 100

- 1 VOICE VLAN : 101

- the 8 ports have been defined as hybrid

- the Alcatel OUI has been added to the switch

- 1 uplink port with the VLANs 100 and 101 tagged

 

Here is an extract of the configuration : 

 

### VLANS ###

vlan 100

name DATA VLAN 

port Ethernet 1/0/1 to Ethernet 1/0/8

 

vlan 101

name VOICE VLAN 

 

voice vlan 101 enable

voice  vlan  mac-address  0080-9F00-0000 mask  FFFF-FF00-0000 description TEL ALCATEL

 

loopback-detection Ethernet 1/0/1 to Ethernet 1/0/8  enable

 

interface Ethernet 1/0/1

port link-type hybrid

port hybrid vlan 100 untagged

port hybrid pvid vlan 100

loopback-detection shutdown enable

voice vlan enable

poe enable

 

interface Ethernet 1/0/2

port link-type hybrid

port hybrid vlan 100 untagged

port hybrid pvid vlan 100

voice vlan enable

poe enable

loopback-detection shutdown enable

 

....

 

## UPlink
interface GigabitEthernet 1/1/1
duplex full
speed 100
port link-type trunk
port trunk permit vlan 100 101

 

Is there something wrong ?

 

"Voice VLAN mode automatic" is by default on the ports. When an IP Phone is powerd on, it sends a DHCP request.

As this frame arrives to the switch port, the IP Phone MAC @ should matche the OUI we added. 

At this point, does the switch forward by itslef this request on the Voice VLAN ??

Should I use the "Voice VLAN legacy" function ?

 

Thanks in advance for your help !

Best regards.

Ismael