Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

A5120 loopback-detection problem (simple thing, but not working?!)

Tomas S.
Occasional Contributor

A5120 loopback-detection problem (simple thing, but not working?!)

I am new to "A" HP networking a i learn on A5120EI switch. I've tried setup loop-detection to prevent bad cabling, but simply - it's not working. Commands:

 

<switch> loop-detection enable

<switch> loop-detection interval 5

<switch> int giga 1/0/1

<switch-GigabitEthernet1/0/1>loop-detection enable

<switch-GigabitEthernet1/0/1>quit

<switch> int giga 1/0/2

<switch-GigabitEthernet1/0/2>loop-detection enable

<switch-GigabitEthernet1/0/2>quit

 

Then i connect these port themselfs and on giga1/0/3 see on notebook classic loop (ntb cpu is almost 100%). What's wrong? Also i need setup loop-detection on all ports, is it possible do it in 1-2 commands? Thank you for yout help

3 REPLIES
manuel.bitzi
Trusted Contributor

Re: A5120 loopback-detection problem (simple thing, but not working?!)

Hi grax

 

loopback-detection only identifies loops on the same port (i.ie. because of short circuits). For a detection over multiple ports, you need stp.

 

br

Manuel

 

 

H3CSE, MASE Network Infrastructure [2011], Switzerland
C0LDWiR3D
Frequent Advisor

Re: A5120 loopback-detection problem (simple thing, but not working?!)

You can use the following for loopback multi port:

  loopback-detection multi-port-mode enable

 

Cheers

 

Peter_Debruyne
Honored Contributor

Re: A5120 loopback-detection problem (simple thing, but not working?!)

* previous mentioned multi-port will help you (default loopback is intended for single port loops (which cannot be handled by stp) : e.g. 1 port connected to an unmanaged switch at user desk, loop on the unmanaged switch at user desk)

* use the 'interface range'  command to apply it to all access ports.

* if access ports are hybrid/trunk (for voice vlan), you need to enable the 'control' and define an action as well (like block or shutdown the port)

 

* alternative is to enable stp global, enable all access ports as 'stp edge enable', enable bpdu-protection to ensure looped ports will be shutdown.

* in this case you can use 'stp disable' on the uplink ports, to avoid using stp on the backbone of your network (if that is using link-agg/irf), so stp is actually 'downgraded' to a pure loop detect protocol.

 

Best regards,Peter