Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

A5500 Need it to passthrough IPv6 without wanting to control it...

RCW_Jason
Collector

A5500 Need it to passthrough IPv6 without wanting to control it...

I am trying to get three A5500 24G switches to passthrough IPv6 without actually controlling it, but I can't seem to get it to work. The issue is I am advertising a /36 on my network (broken into a crudload of /64s) from a MikroTik 36-core CloudCore Gigabit router. All the devices connected directly to the MikroTik autoconfigure (stateless) to get their IPv6 addresses fine. The problem seems to be that the A5500's are connected to the MikroTik, and anything that has to go through the A5500's can't even see the stateless IPv6 system configured on the MikroTik. Is there any way to fix this WITHOUT configuring the A5500's to do their own stateless IPv6, as in a simple passthrough? Would it be any easier if I just did the IPv6 via DHCPv6 on a dedicated DHCP server rather than IPv6 Stateless Autoconfigure? Any help would be greatly appreciated.

4 REPLIES
Apachez-
Trusted Contributor

Re: A5500 Need it to passthrough IPv6 without wanting to control it...

Would be great if you could paste your current configuration (dont forget to remove any passwords and keys/certs).

 

My best guess is that you need to enable ipv6 before the unit will start to handle those ethertypes. On the other hand enabling ipv6 should only be needed if you want to route ipv6 traffic, if you are just about to switch it (lets say between int1 och int2 and both belongs to the same VLAN) then it shouldnt be needed to enable ipv6.

RCW_Jason
Collector

Re: A5500 Need it to passthrough IPv6 without wanting to control it...

All IPv6 stuff happens over Vlan251... Here is the switch config:

 

login as: omitted
omitted@omitted's password:

******************************************************************************
* Copyright (c) 2010-2011 Hewlett-Packard Development Company, L.P. *
* Without the owner's prior written consent, *
* no decompiling or reverse-engineering shall be allowed. *
******************************************************************************

<downtown-switch>system-view
System View: return to User View with Ctrl+Z.
[downtown-switch]display current-co
[downtown-switch]display current-configuration
#
version 5.20.99, Release 5101P01
#
sysname downtown-switch
#
clock timezone MST minus 07:00:00
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
#
domain default enable system
#
ipv6
#
telnet server enable
#
undo ip http enable
#
vlan 1
#
vlan 240 to 241
#
vlan 250 to 251
#
vlan 260
#
vlan 310
#
vlan 410
#
vlan 655
#
radius scheme system
primary authentication 127.0.0.1 1645
primary accounting 127.0.0.1 1646
user-name-format without-domain
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
group-attribute allow-guest
#
local-user omitted
password simple omitted
authorization-attribute level 3
service-type ssh
#
interface NULL0
#
interface Vlan-interface1
ip address dhcp-alloc client-identifier mac Vlan-interface1
#
interface Vlan-interface240
#
interface Vlan-interface241
#
interface Vlan-interface250
description management network
#
interface Vlan-interface251
description Public and Management
ip address omitted 255.255.255.0
#
interface Vlan-interface260
#
interface Vlan-interface310
#
interface GigabitEthernet1/0/1
port link-mode bridge
description Link to FRT
port link-type trunk
port trunk permit vlan 1 107 240 to 241 250 to 251 260 310 to 311 410 to 411
port trunk pvid vlan 241
#
interface GigabitEthernet1/0/2
port link-mode bridge
description Link to MikroTik
port link-type trunk
port trunk permit vlan 1 240 to 241 250 to 251 260 310 to 311 410 to 411
port trunk pvid vlan 250
#
interface GigabitEthernet1/0/3
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/4
port link-mode bridge
description Link to SF UBNT
port link-type trunk
port trunk permit vlan 1 107 240 to 241 250 to 251 260 310 to 311 410 to 411
port trunk pvid vlan 251
#
interface GigabitEthernet1/0/5
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/6
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/7
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/8
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/9
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/10
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/11
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/12
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/13
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/14
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/15
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/16
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/17
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/18
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/19
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/20
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/21
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/22
port link-mode bridge
port access vlan 250
#
interface GigabitEthernet1/0/23
port link-mode bridge
port access vlan 250
#
interface GigabitEthernet1/0/24
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/25
port link-mode bridge
port access vlan 251
#
interface GigabitEthernet1/0/26
port link-mode bridge
#
interface GigabitEthernet1/0/27
port link-mode bridge
#
interface GigabitEthernet1/0/28
port link-mode bridge
#
interface M-GigabitEthernet0/0/0
#
interface Ten-GigabitEthernet1/0/29
port link-mode bridge
#
interface Ten-GigabitEthernet1/0/30
port link-mode bridge
#
snmp-agent
snmp-agent local-engineid 800063A203D07E28347701
snmp-agent community read omitted
snmp-agent sys-info version v2c v3
#
ntp-service unicast-server omitted
#
ssh server enable
#
arp timer aging 2
#
load xml-configuration
#
load tr069-configuration
#
user-interface aux 0
user-interface vty 0 15
authentication-mode scheme
user privilege level 3
protocol inbound ssh
#
return

Apachez-
Trusted Contributor

Re: A5500 Need it to passthrough IPv6 without wanting to control it...

By the way, which model is it - SI, EI or HI?

 

Given your version number I assume its HI and in that case the latest version is R5501P06 (compared to your currently running 5101P01 which is from february 2012) and I would strongly recommend you to update the firmware (and bootrom if needed) followed by reboot before further troubleshooting.

 

Looking through your config I cant see any obvious errors other than int 22-23 belongs to vlan250 and no vlans are set for int 26-28 (I guess this would mean they actually belongs to vlan 1).

RCW_Jason
Collector

Re: A5500 Need it to passthrough IPv6 without wanting to control it...

Vlan 250 on those ports is intentional, and any ports that are unused are left at default configuration until we decide to use them, that is why there are no Vlans on them. Yes it is an HI. I will try upgrading the firmware.