Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Aastra IP phone on HP 5130-24G-PoE

dsiprod
Occasional Visitor

Aastra IP phone on HP 5130-24G-PoE

Hello,

We trying to configure Aastra IP phone on HP 5130-24G-PoE+-4SFP+ (370W) EI JG936A (HP Comware Software, Version 7.1.045, Release 3108P03
) without success.


The phone cannot take an IP adress by our DHCP, but we have not this problem with our computer.

From interface Giga 1 to 7 : we are unable to take an IP adress on phone, but lldp seems to works !

[test-switch-hp]display lldp neighbor-information
LLDP neighbor-information of port 6[GigabitEthernet1/0/6]:
LLDP agent nearest-bridge:
LLDP neighbor index : 1
ChassisID/subtype : 169.254.193.174/Network address(IPv4)
PortID/subtype : 0008-5d42-xxxx/MAC address
Capabilities : Bridge, Telephone


He is our configuration :

sysname test-switch-hp
#
undo voice-vlan security enable
voice-vlan mac-address 8000-0000-0000 mask ff00-0000-0000
voice-vlan mac-address 0008-5d00-0000 mask ffff-ff00-0000 description aastra
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
irf member 1 priority 1
#
dhcp snooping enable
#
dns domain test.lan
#
lldp global enable
lldp mode service-bridge
lldp timer notification-interval 5
lldp compliance cdp

loopback-detection global enable vlan 1 to 4094
#
password-recovery enable
#
vlan 1
#
vlan 10
name DATA
description Vlan_PC
#
vlan 100
name VLAN_Admin_Switch
#
vlan 1100
name TOIP_Aastra
#
stp bpdu-protection
stp global enable
#
interface NULL0
stp bpdu-protection
stp global enable
#
interface NULL0
#
interface Vlan-interface1
shutdown
interface Vlan-interface100
ip address 10.10.0.1 255.255.0.0
#
interface GigabitEthernet1/0/1
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 10 1100
port trunk pvid vlan 10
voice-vlan qos trust
undo voice-vlan mode auto
voice-vlan 1100 enable
broadcast-suppression pps 3000
undo jumboframe enable
stp edged-port
lldp compliance admin-status cdp txrx
poe enable
#
#
interface GigabitEthernet1/0/2
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 1100 tagged
port hybrid pvid vlan 10
voice-vlan qos trust
undo voice-vlan mode auto
voice-vlan 1100 enable
mac-vlan enable
stp edged-port
lldp compliance admin-status cdp txrx
lldp notification med-topology-change enable
poe enable
dhcp snooping trust
#
interface GigabitEthernet1/0/3
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 10 1100
port trunk pvid vlan 10
voice-vlan qos trust
undo voice-vlan mode auto
voice-vlan 1100 enable
stp edged-port
qos trust dot1p
poe enable
#
interface GigabitEthernet1/0/4
port access vlan 1100
voice-vlan qos trust
undo voice-vlan mode auto
voice-vlan 1100 enable
stp edged-port
poe enable
#
interface GigabitEthernet1/0/5
port link-type hybrid
port hybrid vlan 1 10 untagged
port hybrid pvid vlan 10
voice-vlan qos trust
undo voice-vlan mode auto
voice-vlan 1100 enable
stp edged-port
poe enable
#
interface GigabitEthernet1/0/6
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 1100 tagged
port hybrid vlan 11 untagged
port hybrid pvid vlan 11
voice-vlan qos trust
undo voice-vlan mode auto
voice-vlan 1100 enable
stp edged-port
poe enable

...

interface Ten-GigabitEthernet1/0/25
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 2 to 4094
voice-vlan qos trust
lldp compliance admin-status cdp txrx
qos trust dscp
dhcp snooping trust

Thanks for your help :)

5 REPLIES
VoIP-Buddy
HPE Pro

Re: Aastra IP phone on HP 5130-24G-PoE

Phones are different than PC's when it comes to DHCP.  Phones require additional DHCP options to know what they need to do.  If they don't get the options they need in a DHCP offer they won't take it.

 

I did a quick Google search and found this article on how to provision DHCP for the Aastra phones.  I hope it helps:

 

http://pcloadletter.co.uk/2010/12/16/configuring-ericsson-handsets-by-dhcp/

 

Regards,

 

David

dsiprod
Occasional Visitor

Re: Aastra IP phone on HP 5130-24G-PoE

Thanks for your reply, but our IP phones works perfectly on Cisco 2960 Switch and takes IP + Specifics options.

 Regards

VoIP-Buddy
HPE Pro

Re: Aastra IP phone on HP 5130-24G-PoE

Ok.  Then the next step would be to do a Wireshark capture of the traffic to a phone to see what it is doing and if it is trying to respond to the DHCP messages.

 

David

dsiprod
Occasional Visitor

Re: Aastra IP phone on HP 5130-24G-PoE

In fact this is a bug from Comware 7, we are waiting for a patch...

krahmani323
Occasional Visitor

Re: Aastra IP phone on HP 5130-24G-PoE

Hi dsiprod,

 

Thanks for your inputs.

I was just wondering (because we are encoutering a similar issue with Cisco IP phones) if you could share some details on the suspected bug. We are aslo in R3108 and are wondering if we are also hitting a bug.

 

Sometime after a reboot of a phone it does not go to the correct voice vlan and stay stucked in the data vlan.

 

Thank you.

Karim