Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

BPDU Protection - 5130 EI Switches

Ed Nicoll
Occasional Contributor

BPDU Protection - 5130 EI Switches

Can someone help me with the config for edged port BPDU protection on the 5130? We have configured our edge ports using the following commands but when you do a DISPLAY STP BRIEF it tells me that the protection is NONE. 

stp edged-port

and in the main config we have used the following commands:

stp global enable

stp bpdu-protection

This config works ok on 5500 EI switches but must be different on Comware 7. Any help would be much appreciated. Thank you.

 

3 REPLIES
sdide
Respected Contributor

Re: BPDU Protection - 5130 EI Switches

Hi,

I think the output of that command is a bit strange. The guide says that the "Protection" column should be BPDU, if you have bpdu guard on. How ever i can reproduce your result. I run  Release 3113P05.

STP conf:

 stp mode pvst
 stp bpdu-protection
 stp pathcost-standard dot1t
 stp global enable

Test interface:

interface GigabitEthernet1/0/2
 port access vlan 599
 stp edged-port
 poe enable

If I run : display stp brief, i get the same output, protection NONE. Even though the port is stp edged-port.

doing a : display stp - you can see that BPDU is configured for the port (if the link is up).

-------[VLAN 599 Global Info]-------
 Protocol status     : Enabled
 Bridge ID           : 32768.bcea-fa00-cab1
 Bridge times        : Hello 2s MaxAge 20s FwdDelay 15s
 VlanRoot ID/RPC     : 8192.000a-b8df-7b80, 20000
 RootPort ID         : 128.1
 BPDU-Protection     : Enabled
 TC or TCN received  : 0
 Time since last TC  : 22 days 3h:1m:16s

----[Port2(GigabitEthernet1/0/2)][FORWARDING]----
 Port protocol       : Enabled
 Port role           : Designated Port
 Port ID             : 128.2
 Port cost(Dot1T)    : Config=auto, Active=200000
 Desg.bridge/port    : 32768.bcea-fa00-cab1, 128.2
 Port edged          : Config=enabled, Active=enabled
 Point-to-Point      : Config=auto, Active=true
 Transmit limit      : 10 packets/hello-time
 Protection type     : Config=BPDU, Active=none
 Rapid transition    : True
 Port times          : Hello 2s MaxAge 20s FwdDelay 15s MsgAge 1s

And it works - if i connect a link that transmits BPDU's. It shuts.

%Oct 14 14:37:27:648 2016 HP-5130-24G IFNET/3/PHY_UPDOWN: GigabitEthernet1/0/2 link status is up.
%Oct 14 14:37:27:670 2016 HP-5130-24G IFNET/5/LINK_UPDOWN: Line protocol on the interface GigabitEthernet1/0/2 is up.
%Oct 14 14:37:30:449 2016 HP-5130-24G STP/4/STP_BPDU_PROTECTION: BPDU-Protection port GigabitEthernet1/0/2 received BPDUs.
%Oct 14 14:37:30:490 2016 HP-5130-24G IFNET/3/PHY_UPDOWN: GigabitEthernet1/0/2 link status is down.
%Oct 14 14:37:30:492 2016 HP-5130-24G IFNET/5/LINK_UPDOWN: Line protocol on the interface GigabitEthernet1/0/2 is down.

So it works, but the output of display stp brief is strange I think.

Regards.

 

 

Søren Dideriksen, Network Administrator
Region Midtjylland
16again
Respected Contributor

Re: BPDU Protection - 5130 EI Switches

Probably, config=xxxxx shows configured value , whereas active=xxxxxx shows current status

Point-to-point is configured as auto, and somehow ended up in enabled state.

yohnF
Occasional Advisor

Re: BPDU Protection - 5130 EI Switches

config global:

undo stp global enable

stp mode rstp

_____

 

Config interface:

stp port bpdu-protection enable

loopback-detection enable vlan 1 to 4094

loopback-detection action shutdown

technical support