Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

BPDU-protection and loopback-detection, in which order to configure?

hansvb
Frequent Advisor

BPDU-protection and loopback-detection, in which order to configure?

Hii all,

 

we had an issue today with a loop created on an edge switch

Someone had connected port 10 to port 12 on the same switch

Users were complaining the netwerk connection dropped for several seconds and worked again afterwards.

Als the servers showed they were suffering of high-network traffic

 

I noticed in IMC that the 2 interfaces on that switch went up and down at the same time, over and over again with an interval of 30s. On those interfaces i configured also loopback-detection but this didn't raise a trap in IMC

Now i was wondering, i configured the switch as shown below

 

stp enable
stp pathcost-standard dot1t
stp bpdu-protection

 

port-group manual EdgePorts
group-member g1/0/1 to g1/0/24
stp edged-port enable
loopback-detection enable

 

The default timer for loopback-detection is 30s, but BPDU protection uses default a shorter interval

Should i adjust the loopback-detection timer or the BPDU protection timer on my edge switches

Or am i doing it completely wrong ?

 

Please advise

Thx in advance for ur feedback

2 REPLIES
internalnews
Frequent Advisor

Re: BPDU-protection and loopback-detection, in which order to configure?

 

On edge ports, you probably should run loopback-detection lolely:

 

system-view

loopback-detection enable
 loopback-detection multi-port-mode enable
 loopback-detection interval-time 5

interfac giga 1/0/1

 loopback-detection enable
 loopback-detection control enable
 loopback-detection per-vlan enable
 loopback-detection action semi-block

 

PKish
Occasional Collector

Re: BPDU-protection and loopback-detection, in which order to configure?

I'm having an issue with the BPDU protection timer as well.  I know the defualt is 30 seconds, and in COMWARE 5 you were able to turn it off via the 'shutdown-interval 0' command.  (http://h20564.www2.hp.com/hpsc/doc/public/display?docId=emr_na-c02603913&sp4ts.oid=5202302)

 

For some reason in COMWARE 7 the 'shutdown-interval' command only allows 1-300 now, 0 is not an option.  Is there a different way to make sure the port stays in a DOWN state until its manually enabled.  On Cisco's the timer is off by default.  We have customers that will down right refuse to purchase an HP switch unless there is a way to disable this retry.

 

Assitance is appreciate.

Phil