Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Blocking BPDU packets on HPE 5130

Dominic_Z
Occasional Visitor

Blocking BPDU packets on HPE 5130

I'm currently trying to connect a 3rd party Cisco 800 (uplink to their network) to our TOR switches.

Our switches are HPE 5130's (System image version: 7.1.070, Release 1309P03).

The problem is that the Cisco shuts down it's ports the moment it is connected to our switch. After contacting the 3rd party they said the port went into blocking mode as seen by the log output of the cisco 800:

%SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet1 VLAN1.

%SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet1 on VLAN1. Inconsistent port type.

I've tried the "bpdu-drop any" on the interface of the 5130, but this does not prevent the port forwarding the BPDU packet. So far I cannot find any command that totally prevents BPDU packets being transmitted from this port on the 5130. The cisco 800 is currently connected to an old cisco 3560 switch which has a " spanning-tree bpdufilter enable" configured that does the trick.

So, what can I do that makes the 5130 behave the same als the 3560 by completly blocking BPDU packets traversing the port on the 5130 towards the cisco 800?

2 REPLIES
Vince-Whirlwind
Honored Contributor

Re: Blocking BPDU packets on HPE 5130

undo sto enable?

You can try this on the interfaces or on the VLAN, whichever seems the most sensible.

You probably should enable loopguard (Comware calls it "loopback-detection") on your edge switches, as well, especially if you're disabling STP on them.
loopback-detection enable globally, then on the interface, then loopback-detection action shut.
(If it's not an access port, you need additional commands to make it work on the trunk and on all vlans on the trunk.)

Highlighted
Dominic_Z
Occasional Visitor

Re: Blocking BPDU packets on HPE 5130

Vince, already tried the "undo stp enable". STP is globally enabled on this switch though I'd like to disable it in general.

Now before people start, yes I know no STP is bad, but trust me that i've got very good and substantiated reasons for not wanting this on the network at this time.

interface GigabitEthernet1/0/23
 description Uplink to AZN
 port access vlan 500
 speed 100
 duplex full
 bpdu-drop any
 undo stp enable

Any other suggestions?