Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot pass IPv6 packets using HP 5830s

SOLVED
Go to solution

Cannot pass IPv6 packets using HP 5830s

I'm in the process of enabling IPv6 in our domain. At this point I'm working with a very small subset of servers and devices. I'm only working with a single VLAN, too. It's more of a proof-of-concept than a full-scale deployment.

Right now im working with a firewall, two 5830s, two DCs (Windows, virtual), one physical server (Windows), and one web server (Windows, virtual). Everything is configured for IPv6 at this point. The problem? I cannot get the 5830s to pass IPv6 packets. No combination of pings work from any devices to another. Instead, i just get "Destination Host Unreachable"

If i try to ping from the firewall to any device, nothing. If i try to ping from the switches to any device, nothing. If i try to ping from server to any device, nothing. The oddest part? If i try to ping via fe80 addresses, that works.

At this point i've narrowed down the problem to the switches. afaik, they are configured correctly. I have given them unique IPv6 addresses. I've enabled IPv6; I've enabled IPv6 for the VLAN in question. I have specified a default route. Lord knows what else i've tried. im sure im forgetting stuff at this point.

We were running a very old firmware on them. just last week we updated the latest, and it's still a no-go.

We run a pretty simple domain. We dont have a myriad of different protocols. the switches act as top-of-rack pass-throughs with a few VLANs. That's it. We're not running IRF, or BGP, or OSMP or any of thsoe.

To prove that im not losing my mind, i took a separate HP switch, outside of this domain and gave it a random IPv6 address. I assigned an IPv6 address to a server connected to that switch. That's the only 2 things i did and they ping each other just fine. So what's wrong w/ these 5830s?

If anyone needs images or screenshots, let me know. I'm totally and completely stuck at this point. Thanks!

5 REPLIES
Solution

Re: Cannot pass IPv6 packets using HP 5830s

For anyone encountering the same issue, we did figure it out eventually.

I compared our switch config to another, identical switch that had not been modified. It is part of a separate domain. They were nearly identical, except for a single line. At some point I had enabled Neighbor Discovery on the switches. This is disabled by default when IPv6 is enabled. As soon as I disabled ND, via the CLI, the switches started to pass IPv6 packets.

Quite the odd one - I would never have thought that ND would completely render IPv6 useless on these switches.

Apachez-
Trusted Contributor

Re: Cannot pass IPv6 packets using HP 5830s

Sounds like you might have something else broken because ND is part of IPv6.

ND is the IPv6 edition of ARP:

https://en.wikipedia.org/wiki/Neighbor_Discovery_Protocol

Re: Cannot pass IPv6 packets using HP 5830s

Yeah, i know ND is part of IPv6, which is why i enabled it in the 1st place. On these switches, by default, ND is disabled. As soon as I disabled it again, things started working. I have no idea why.

16again
Respected Contributor

Re: Cannot pass IPv6 packets using HP 5830s

What's the exact command you entered to fix this?
Pinging LinkLocal fe80 addresses worked right away, seems to me like ND is also required for those addresses

Re: Cannot pass IPv6 packets using HP 5830s

by default, ND is disabled when IPv6 is enabled. I thought, at the time, that ND would be good and necessary, so i enabled it w/ some command like "neighbor discovery enable". When i disabled it again, i typed something like "undo neighbor discovery enable."

sorry, i dont remember right off w/o going back to a manual to find it.