Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Cisco 3850 LACP to a HP 5920

TimothySutton
Occasional Visitor

Cisco 3850 LACP to a HP 5920

I cannot seem to get this working correctly. I am trying to get a Cisco 3850 to talking to a HP 5920 over LACP. When I go to ping between the two devices I get nothing. 

 

Cisco Configuration

interface Port-channel4
switchport trunk allowed vlan 2,51,400
switchport mode trunk
switchport nonegotiate
no port-channel standalone-disable
spanning-tree bpdufilter enable
!
interface TenGigabitEthernet1/0/46
switchport trunk allowed vlan 2,51,400
switchport mode trunk
switchport nonegotiate
no cdp enable
channel-protocol lacp
channel-group 4 mode active
spanning-tree bpdufilter enable
lacp rate fast

!

interface TenGigabitEthernet1/0/48
switchport trunk allowed vlan 2,51,400
switchport mode trunk
switchport nonegotiate
no cdp enable
channel-protocol lacp
channel-group 4 mode active
spanning-tree bpdufilter enable
lacp rate fast



 

 

HP Configuration

interface Bridge-Aggregation2
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 2 51 400
link-aggregation mode dynamic

interface Ten-GigabitEthernet1/0/23
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 2 51 400
lacp period short
port link-aggregation group 2

interface Ten-GigabitEthernet1/0/24
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 2 51 400
lacp period short
port link-aggregation group 2

 

 

Any help would be great. 

 

show interfaces Port-channel 4
Port-channel4 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 50f7.2210.87b0 (bia 50f7.2210.87b0)
MTU 1500 bytes, BW 2000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, link type is auto, media type is
input flow-control is off, output flow-control is unsupported
Members in this channel: Te1/0/46 Te1/0/48
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 1000 bits/sec, 1 packets/sec
5 minute output rate 4000 bits/sec, 5 packets/sec
8606 packets input, 1162852 bytes, 0 no buffer
Received 8606 broadcasts (8605 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 8605 multicast, 0 pause input
0 input packets with dribble condition detected
29649 packets output, 2552866 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

 


Status from Bridge Aggregation on the HP device. 

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Port Status: S -- Selected, U -- Unselected, I -- Individual
Flags: A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,
D -- Synchronization, E -- Collecting, F -- Distributing,
G -- Defaulted, H -- Expired


Aggregate Interface: Bridge-Aggregation2
Aggregation Mode: Dynamic
Loadsharing Type: Shar
System ID: 0x8000, d894-037b-e3ad
Local:
Port Status Priority Oper-Key Flag
--------------------------------------------------------------------------------
XGE1/0/23 S 32768 2 {ABCDEF}
XGE1/0/24 S 32768 2 {ABCDEF}
Remote:
Actor Partner Priority Oper-Key SystemID Flag
--------------------------------------------------------------------------------
XGE1/0/23 303 32768 4 0x8000, 50f7-2210-8780 {ABCDEF}
XGE1/0/24 305 32768 4 0x8000, 50f7-2210-8780 {ABCDEF}

2 REPLIES
VoIP-Buddy
HPE Pro

Re: Cisco 3850 LACP to a HP 5920

Timothy,

That looks good so far.  At least both ports on the 5920 are Selected.

On the 5920, you only configure the ports for the link-agg group and do all of the rest of the configuration through the bridge-agg interface.

What traffic are you trying to get through?  You have no IP address on the Bridge-agg interface but you do have VLANs configured.  Maybe put a temporary address on the bridge-agg to be able to ping it?

Why are you doing LACP short interval? 

Have you looked in the logbuffer... display logbuffer revese to see if there are any issues being reported?

Can you try to debug LACP to see if it says what the issue is with the Cisco?  From user lever, try debug link-aggregation lacp packet to see what is going on?  Do a terminal debug and terminal mon to see it on the console.

Regards,

David

parnassus
Honored Contributor

Re: Cisco 3850 LACP to a HP 5920


TimothySutton wrote:

 

show interfaces Port-channel 4
Port-channel4 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 50f7.2210.87b0 (bia 50f7.2210.87b0)
MTU 1500 bytes, BW 2000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, link type is auto, media type is
input flow-control is off, output flow-control is unsupported
Members in this channel: Te1/0/46 Te1/0/48
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 1000 bits/sec, 1 packets/sec
5 minute output rate 4000 bits/sec, 5 packets/sec
8606 packets input, 1162852 bytes, 0 no buffer
Received 8606 broadcasts (8605 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 8605 multicast, 0 pause input
0 input packets with dribble condition detected
29649 packets output, 2552866 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

If you're using TenGigabit (per second) interfaces Te1/0/46 and Te1/0/48 Cisco Switch side and Ten-GigabitEthernet1/0/23 and Ten-GigabitEthernet1/0/24 HPE Switch side...why the BW (BandWidth) parameter reports only 2 Gbps (it looks like you really aggregated two 1 Gbps physical ports - see the reference to 1000Mb/s reported for each Port Channel member port - instead of two 10 Gbps physical ports)?

Is all OK from physical cabling standpoint?

Involved physical interfaces are OK?

Edit:

A more reasonable show interfaces port-channel command involving a Port Channel with TenGigabit member port(s) should be like:

CISCO_show_interfaces_port_channel_with_TenGiga_ports_as_members.png

Note how the BW parameter is 10000000 Kbit/sec and the port-channel Member 0 reported speed is 10000Mb/s, that's because - in that particular example - the Port Channel had just one 10 Gbps member port active - specifically the Member 0 - and not two...as in your case.