Online Expert Day - HPE Data Storage - Live Now
April 24/25 - Online Expert Day - HPE Data Storage - Live Now
Read more
Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Cisco IP Phones, Cisco 3560 and ProCurve 2810 help needed

mtegler
Occasional Visitor

Cisco IP Phones, Cisco 3560 and ProCurve 2810 help needed

When I plug a Cisco IP phone into a Cisco switch, it works perfectly. When I plug into a Procurve switch it doesn't work at all.

 

I followed the documentation here: 

 

http://www.tecnocael.it/ftp/docs/ProCurve_Cisco.pdf

 

No joy.

 

This is the running config for the Procurve:

hostname "procurve-2810-2nd" 
interface 1 
   name "to 1st" 
exit
ip default-gateway 192.168.10.2 
snmp-server community "public" Unrestricted 
vlan 1 
   name "DEFAULT_VLAN" 
   untagged 1-48 
   ip address 192.168.10.5 255.255.255.0 
   qos priority 0 
   exit 
vlan 100 
   name "voice" 
   ip address 10.1.1.3 255.255.255.0 
   qos priority 6 
   tagged 1-48 
   voice 
   exit 
lldp enable-notification 1-48 
ip ssh

And here is the Cisco config:

 

 

version 12.2
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname Core-3560G-SW
!
logging buffered 20000 notifications
enable secret 5 $1$N8dP$feY/PreqDkGrKP1OMc3Zv/
!
aaa new-model
aaa authentication login default local enable
!
aaa session-id common
clock timezone UTC -6
clock summer-time UTC recurring
ip subnet-zero
no ip source-route
ip routing
no ip gratuitous-arps
no ip domain-lookup
!
ip igmp snooping vlan 1 immediate-leave
!
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33 
mls qos srr-queue input cos-map queue 1 threshold 2  1
mls qos srr-queue input cos-map queue 1 threshold 3  0
mls qos srr-queue input cos-map queue 2 threshold 1  2
mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3  3 5
mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3  32
mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 2  1
mls qos srr-queue output cos-map queue 4 threshold 3  0
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1  8
mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
!
!
errdisable recovery cause storm-control
errdisable recovery interval 30
no file verify auto
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1,777 priority 4096
!
vlan internal allocation policy ascending
!

interface GigabitEthernet0/17
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 switchport voice vlan 100
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust 
 spanning-tree portfast
 spanning-tree link-type point-to-point
!         
interface GigabitEthernet0/18
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 switchport voice vlan 100
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust 
 spanning-tree portfast
 spanning-tree link-type point-to-point
!
interface Vlan1
 ip address 192.168.10.3 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
!
interface Vlan100
 ip address 10.1.1.2 255.255.255.0
!
interface Vlan777
 description TEST VLAN 777
 ip address 172.16.10.1 255.255.255.0
 ip helper-address 10.65.1.5
 no ip redirects
 no ip unreachables
 no ip proxy-arp
end

Also whenever I plug a Cisco phone into the ProCurve I get this error every time:

 

Excessive CRC/Alignment Errors on port 5

 

Doesn't matter what port, cable or phone I plug into it

 

Any help would be greatly appreciated 

2 REPLIES
cenk sasmaztin
Honored Contributor

Re: Cisco IP Phones, Cisco 3560 and ProCurve 2810 help needed

please make test

 

connect any small hub/switch on hp switch port

and connect cisco phone this small switch

 

please test and say me result 

 

 

cenk

PJCaballero
Occasional Visitor

Re: Cisco IP Phones, Cisco 3560 and ProCurve 2810 help needed

REgarding Cisco phones you need to know how the phone guest the VLAN configuration. At the beggining it takes that info through CDP, but it can also get the info through LLDP-MED, but it depends on the phone model and phone firmware. I did get a 7941 phone works with a procurve 2650. BAsically you have to be sure the phone supports LLDP-MED, make sure LLDP is working on the switch and configure a voice vlan. Your config seems to be ok so check the phone´s firmware

 

 

 

Here you have an application note on how to do it :

http://h17007.www1.hp.com/docs/interoperability/Cisco/4AA2-2301EEE.pdf

http://h40060.www4.hp.com/procurve/uk/en/pdfs/application-notes/AN-C8_ProCurve-LLDP-IP-phones-final-081208.pdf

 

REgarding to cisco phones suppport on LLDP-MED:

https://supportforums.cisco.com/docs/DOC-14879