Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Comware 5: dscp ignored despite 'qos trust dscp'

SOLVED
Go to solution
Highlighted
siriobalmelli
Occasional Contributor

Comware 5: dscp ignored despite 'qos trust dscp'

I am marking DSCP using an input QoS policy.

The details of the policy setup are irrelevant, a packet capture from a machine connected to the output port confirms that:

- packet DSCP is 0 by default (without the policy)

- DSCP changes to the desired value (cs6 in this case) when I apply the input policy.

However, when I run

display qos queue-statistics interface

on the output port (I should see prioritization of marked packets here) all queues counters are 0 except for queue 2.

My output port configuration is as follows: 

#
interface GigabitEthernet1/0/10
 port link-mode bridge
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan [list of VLANs]
 flow-control
 qos lr outbound cir 514560 cbs 16000000
 qos trust dscp
#

I have also tried:

- without qos lr on the output port

- with wrr queueing discipline on the output port

- with remark local-precedence in the QoS policy

- with remark ip-precedence

- using remark dscp on an output rule instead of input

In all cases every queue statistic except queue2 stays 0.

I've been through the "H3C S5830 Switch Series ACL and QoS Configuration Guide" document and I don't see any other info on the topic.

Any clue or insight is much appreciated :)

My version information is as follows:

HP Comware Platform Software
Comware Software, Version 5.20.105, Release 1118P13
Copyright (c) 2010-2016 Hewlett-Packard Development Company, L.P.
HP A5830AF-48G uptime is 75 weeks, 6 days, 8 hours, 34 minutes


Slot 1 (M):
Uptime is 75 weeks,6 days,8 hours,34 minutes
A5830AF-48G with 1 Processor
1024M   bytes SDRAM
64M     bytes Nor Flash Memory
CPLD A Version is 005
CPLD B Version is NULL
BootWare Version is 1.06
[SubSlot 0] 48GE + 2COMBO SFP + 2SFP Plus
  Hardware Version is REV.C
Patch Version  :    None

 

1 REPLY
siriobalmelli
Occasional Contributor
Solution

Re: Comware 5: dscp ignored despite 'qos trust dscp'

Turns out that:

Remarking dot1p works; remarking dscp requires qos trust dscp on the input port (remarking is done before mapping, turns out). For a global configuration this is too much config crud, so I stuck with dot1p.

The display qos queue-statistics interface [interface] command is misleading: multicast packets ARE classified but not listed in the queue??