HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Comware & avaya IP phones

 
SOLVED
Go to solution
Jasim
Visitor

Comware & avaya IP phones

Hello All,

We are having an issue with our avaya phones & HP comware switches, the phones are either getting into a boot-loop or will have delay and jitters while using the phone. This behaviour is experienced intermittently and usually occurs on ports which are configured as hybrid ports. If we seperate the voice and data traffic then the phones would come out of the loop and even the phones which have delays & jitters will function properly.

The current port configuration is as below (voice vlan 610 and data vlan 22)

interfarace gig1/0/1
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 610 tagged
port hybrid vlan 22 untagged
port hybrid pvid vlan 22
poe enable
stp edged-port enable

We have already upgraded the firmware on HP A5120 switch and also the phone firmwares have been upgraded, but we still face this issue.

A couple of time we have seen "LLDP TTL has expired" messages on the phone. I am suspecting it is an LLDP issue but I am unable to find any documentation for the interoperability between HP comware & Avaya phones.

I will appreciate if anyone can point me towards a link or if anyone has experience a similar issue then please share your input.

 

Sincerely

Jasim

 

10 REPLIES
johnk3r
Respected Contributor
Solution

Re: Comware & avaya IP phones

Hello!

I encountered a similar problem on a client, to solve this problem I did the following:

The data vlan was heavily flooded with multicast IPV6 packets

The ports are in the UP / DOWN state constantly

3º Performed the control of broadcast / multicast packets (pps) on the interfaces of switches (suppression)

Applied IGMP policy for multicast flood control

**************************************
ATP FLEXNETWORK V3 | ACSA
Vince-Whirlwind
Honored Contributor

Re: Comware & avaya IP phones

What purpose are you using hybrid mode for?

I would never use it myself. Use trunk.

VoIP-Buddy
HPE Pro

Re: Comware & avaya IP phones

Jasim,

Take a look at the LAN Switching Guide.  There is a chapter on configuring Voice VLANs.  Let the switch help you... there are 2 methods that you can use:

  • Identifying phones using the OUI Address.  Use the voice-vlan command to set it up.  The switch already knows about one Avaya OUI MAC and that should be in the table already... 0004-0D00-0000 Avaya phone.  If your phones have a different MAC address, you can add it to the table.
  • Identifying the phones with LLDP.  Use the voice-vlan track lldp to turn that on.  By default it is off.
  • The above methods are not mutually exclusive.  You can define both if that makes sense for your environment.  For example, some phones that support LLDP and others that don't.

In regards to the Comware support for CDP, it is not a full implementation.  For PoE purposes, we will only listen to LLDP MED-TLVs for other phones, the switch will use other methods to figure out what PoE class a device is and set the power accordingly.

We have lots of customers using Avaya phones with our Comware switches.  If you take a look at the configuration guide you'll get the whole story on how to set it up.

Regards,

David

Jasim
Visitor

Re: Comware & avaya IP phones

@Vince-Whirlwind

 

Already tried with trunk configuration but still the issue exists. Below is the configuration used with 610 being the voice vlan and 22 data vlan

 

port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 22 610
port trunk pvid vlan 22
poe enable
stp edged-port enable

 

 

Jasim
Visitor

Re: Comware & avaya IP phones

@VoIP-Buddy (David)

We have already added the voice-vlan OUI for our specific models and I have enabled voice vlan track lldp as well but issue still persists.

I tried searching for the config guides for comware & avaya phone but I was unable to find it. Actually I am new to HP switches so still figuring out few things.

I will appreciate if you can point me to any specific link.

Vince-Whirlwind
Honored Contributor

Re: Comware & avaya IP phones

Does the phone get VLAN 610 from LLDP?
Is it getting a VLAN610 IP address from a DHCP server in VLAN22?
How is its PC port configured?
What does the switch log say while the erratic behaviour is occurring?
What are the CPU and MEM stats at that time?
What are the switchport stats and switchport error stats like on the two phones and the controller at that time?

Jasim
Visitor

Re: Comware & avaya IP phones

I am following the below document to configure the switchport in mode auto

http://www.h3c.com.hk/Technical_Support___Documents/Technical_Documents/Switches/H3C_S5120/H3C_S5120_Series_Switches/Configuration/Operation_Manual/H3C_S5120-SI_CG-Release_1101-6W105/201108/723577_1285_0.htm#_Toc301272522

port-config :


interface GigabitEthernet1/0/20
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 22 untagged
voice vlan 610 enable
poe enable
stp edged-port enable

 

encounterd the below log messages on switch for multiple ports.

#May 17 11:35:37:481 2017 L7SW01 POE/1/PSE_PORT_ON_OFF_CHANGE:
Trap 1.3.6.1.2.1.105.0.1: PSE ID 4, IfIndex 9437200, Detection Status 3.

%May 17 11:35:37:484 2017 L7SW01 POE/4/PD_STATUS:
GigabitEthernet1/0/17: Port poe on: 802.3af-compliant PD ,rawstatus=0x1

 

FOR A DIFFERENT PORT

%May 17 11:37:54:205 2017 L7SW01 LLDP/5/LLDP_NEIGHBOR_AGE_OUT: Neighbor aged out on Port GigabitEthernet1/0/18 (IfIndex 9437201), Chassis ID is 172.24.11.173, Port ID is b447-5e34-b556.

Tried to trace this port but no end device is connected to this port, just to the patch panel.

>dis poe interface gig1/0/20
Port Power Enabled : enabled
Port Power Priority : low
Port Operating Status : on
Port IEEE Class : 2
Port Detection Status : delivering-power
Port Power Mode : signal
Port Current Power : 3400 mW
Port Average Power : 3526 mW
Port Peak Power : 3800 mW
Port Max Power : 30000 mW
Port Current : 64 mA
Port Voltage : 52.6 V
Port PD Description :

 

dis voice vlan state
Maximum of Voice VLANs: 8
Current Voice VLANs: 1
Voice VLAN security mode: Security
Voice VLAN aging time: 1440 minutes
Voice VLAN enabled port and its mode:
PORT                           VLAN     MODE         COS        DSCP
--------------------------------------------------------------------
GigabitEthernet1/0/1    610       AUTO           6              46

 

 

LLDP statistics information of port 
The number of LLDP frames transmitted : 74480
The number of LLDP frames received : 37108
The number of LLDP frames discarded : 0
The number of LLDP error frames : 2775
The number of LLDP TLVs discarded : 2775
The number of LLDP TLVs unrecognized : 0
The number of LLDP neighbor information aged out : 14
The number of CDP frames transmitted : 0
The number of CDP frames received : 0
The number of CDP frames discarded : 0
The number of CDP error frames : 0

 

Slot 1 CPU usage:
23% in last 5 seconds
23% in last 1 minute
23% in last 5 minutes

DHCP server is located in a different vlan (server vlan) and both pc's and phones lease address from it.

 

VoIP-Buddy
HPE Pro

Re: Comware & avaya IP phones

Jasim
Visitor

Re: Comware & avaya IP phones

@johnk3r

Ran Gns3 on the vlan where we were having this issue continously and captured tons of ipv6 multicast packets.

Now the issue is resolved by implementing multicast suppression.

Thanks :)

Highlighted
Mike-Ruiz
Occasional Visitor

Re: Comware & avaya IP phones

how do you configure the port.