Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Comware to Procurve Vlan1 Communication

Halil_HP
Visitor

Comware to Procurve Vlan1 Communication

Hello,

Last day i had a case that, i couldn't communicate 2 switches with eachother.

The topology is the most simple u may think of, such as;

Procurves running om the topology, on default configuration (Vlan1), and i tried to connect a Comware switch to one of them. Comware (51xx) is also running on default configuration. 

On both switchs vlan 1 (comware int vlan 1) have IP on the same subnet,  all ports on default (means " access vlan 1 " as you know ). But can not ping each other.

Also tried  " vlan X " on both switches and trunk on uplink ports. But, couldn't ping eighter.

What could I miss on this situation? Was there any trick on comware?

Kind Regards..

8 REPLIES
HP-Browniee
Respected Contributor

Re: Comware to Procurve Vlan1 Communication

From where are you trying to ping? from the switch or from your pc ?

If it is from your pc, try to disable your firewall.

Halil_HP
Visitor

Re: Comware to Procurve Vlan1 Communication

Hello,

I am trying it from switch to switch, i can ping it from laptop. The problem is, i just can not make uplink work.

Configs as below;

PROCURVE:

; J9775A Configuration Editor; Created on release #YA.16.03.0003
; Ver #0f:02.43.18.82.34.61.18.28.f3.84.9c.63.ff.37.27:d6
hostname "HP-2530-48G-S"
fault-finder broadcast-storm sensitivity high
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-hdx sensitivity high
fault-finder duplex-mismatch-fdx sensitivity high
trunk 14 trk13 trunk
trunk 13 trk14 trunk
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-12,15-52,Trk13-Trk14
ip address 10.3.1.20 255.255.0.0
exit
spanning-tree Trk13 priority 4
spanning-tree Trk14 priority 4
no tftp server
loop-protect 1-12,15-39
no dhcp config-file-update
device-profile name "default-ap-profile"
cos 0
exit
password manager

-------

COMWARE:

<HPE>dis cur
#
version 7.1.045, Release 3111P02
#
sysname HPE
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
irf member 1 priority 1
#
lldp global enable
#
password-recovery enable
#
vlan 1
#
stp global enable
#
interface NULL0
#
interface Vlan-interface1
ip address 10.3.1.40 255.255.0.0
#
interface GigabitEthernet1/0/1
#
interface GigabitEthernet1/0/2
#
interface GigabitEthernet1/0/3
#
interface GigabitEthernet1/0/4
#
interface GigabitEthernet1/0/5
#
interface GigabitEthernet1/0/6
#
interface GigabitEthernet1/0/7
#
interface GigabitEthernet1/0/8
#
interface GigabitEthernet1/0/9
#
interface GigabitEthernet1/0/10
#
interface GigabitEthernet1/0/11
#
interface GigabitEthernet1/0/12
#
interface GigabitEthernet1/0/13
#
interface GigabitEthernet1/0/14
#
interface GigabitEthernet1/0/15
#
interface GigabitEthernet1/0/16
#
interface GigabitEthernet1/0/17
#
interface GigabitEthernet1/0/18
#
interface GigabitEthernet1/0/19
#
interface GigabitEthernet1/0/20
#
interface GigabitEthernet1/0/21
#
interface GigabitEthernet1/0/22
#
interface GigabitEthernet1/0/23
#
interface GigabitEthernet1/0/24
#
interface Ten-GigabitEthernet1/0/25
#
interface Ten-GigabitEthernet1/0/26
#
interface Ten-GigabitEthernet1/0/27
#
interface Ten-GigabitEthernet1/0/28
#
scheduler logfile size 16
#
line class aux
user-role network-admin
#
line class vty
user-role network-operator
#
line aux 0
user-role network-admin
#
line vty 0 63
user-role network-operator
#
radius scheme system
user-name-format without-domain
#
domain system
#
domain default enable system
#
role name level-0
description Predefined level-0 role
#
role name level-1
description Predefined level-1 role
#
role name level-2
description Predefined level-2 role
#
role name level-3
description Predefined level-3 role
#
role name level-4
description Predefined level-4 role
#
role name level-5
description Predefined level-5 role
#
role name level-6
description Predefined level-6 role
#
role name level-7
description Predefined level-7 role
#
role name level-8
description Predefined level-8 role
#
role name level-9
description Predefined level-9 role
#
role name level-10
description Predefined level-10 role
#
role name level-11
description Predefined level-11 role
#
role name level-12
description Predefined level-12 role
#
role name level-13
description Predefined level-13 role
#
role name level-14
description Predefined level-14 role
#
user-group system
#
return
<HPE>

 

King Regards. 

sdide
Respected Contributor

Re: Comware to Procurve Vlan1 Communication

Hi,

Are the switches directly connected?

I.e on the comware switch

] display lldp neighbor-information verbose

Regards

Søren Dideriksen, Network Administrator
Region Midtjylland
Halil_HP
Visitor

Re: Comware to Procurve Vlan1 Communication

Hello,

Output show as;

[HPE]display lldp neighbor-information verbose
LLDP neighbor-information of port 23[GigabitEthernet1/0/23]:
LLDP agent nearest-bridge:
LLDP neighbor index : 1
Update time : 0 days, 23 hours, 33 minutes, 29 seconds
Chassis type : MAC address
Chassis ID : 9457-a52b-28c0
Port ID type : Locally assigned
Port ID : 21
Time to live : 120
Port description : 21
System name : HP-2530-48G
System description : HP J9775A 2530-48G Switch, revision YA.16.03.0003, ROM YA
.15.19 (/ws/swbuildm/rel_tacoma_qaoff/code/build/lakes(sw
buildm_rel_tacoma_qaoff_rel_tacoma))
System capabilities supported : Bridge
System capabilities enabled : Bridge
Management address type : IPv4
Management address : 10.3.4.124
Management address interface type : IfIndex
Management address interface ID : Unknown
Management address OID : 0
Port VLAN ID(PVID) : 1
Auto-negotiation supported : Yes
Auto-negotiation enabled : Yes
OperMau : Speed(1000)/Duplex(Full)
Power port class : PSE
PSE power supported : No
PSE power enabled : No
PSE pairs control ability : No
Power pairs : Signal
Port power classification : Class 0
Unknown organizationally-defined TLV:
TLV OUI : 00-16-b9
TLV subtype : 2
Index : 1
TLV information : 0x0001

[HPE]

 

Regards..

sdide
Respected Contributor

Re: Comware to Procurve Vlan1 Communication

Hi,

What address are you pinging?

The procurve 2530, says it has: "Management address : 10.3.4.124", but you wrote it as if you configured 10.3.1.20.

You can do a "display interface brief | incl ^Vlan" to see what address it has assigned to interface vlan1

Regards

 

Søren Dideriksen, Network Administrator
Region Midtjylland
Halil_HP
Visitor

Re: Comware to Procurve Vlan1 Communication

Hi,

Thank you for your attention. Don't mind ip addresses, the outputs has taken in different times, its the reason that ip address shown diffrent, i was trying something. Consider as there is no ip address configuration problem.

Just curious, if is there any little trick or something for communicate between comware and procurve switches.

 

Regards.

HP-Browniee
Respected Contributor

Re: Comware to Procurve Vlan1 Communication

Hello

The fact you can ping everything from your client, means that your uplink works fine. 

Can you try to do following commands on your comware switch, and check again if you can ping or not.

 ip ttl-expires enable
 ip unreachables enable

I think one of the switches is just blocking pings.

 

sdide
Respected Contributor

Re: Comware to Procurve Vlan1 Communication

Hi,

Is the problem asymmetric? (I mean can you ping from the Aruba, but not from the Comware, or vice versa)

Anyways, you can try to explicitly allowing ping on the Aruba device.

# ip icmp echo broadcast-request

 Regards

Søren Dideriksen, Network Administrator
Region Midtjylland