HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Configuration Link aggregation between 5500G and 4800G

 
SOLVED
Go to solution
freddy13
Occasional Contributor

Configuration Link aggregation between 5500G and 4800G

Hi...

 

I have 2 switches 5500G in XRN stack like the Core of the Lan.

3 swtches 4800G in IRF Stack.

I need to do a link aggregation between those but the 5500G doesnt support the Dynamic Mode of the link aggregation, and the 4800G dont support the static or manual mode.

 

I tried to do this:

 

Switch  5500G

link-aggregation group 1 mode static
#
interface GigabitEthernet 1/0/25
undo shutdown
port link-aggregation group 1
#
interface GigabitEthernet 1/0/26
undo shutdown
port link-aggregation group 1

save

reset saved-configuration
reboot

Switch 4800G

 

interface Bridge-Aggregation1
link-aggregation mode dynamic
port link-type trunk
port trunk permit vlan all

interface GigabitEthernet1/0/31
port link-type trunk
port trunk permit vlan all
port link-aggregation group 1

interface GigabitEthernet1/0/32
port link-type trunk
port trunk permit vlan all
port link-aggregation group 1


but not funtion.

 

I hope Someone can help me.

 

 

P.S. This thread has been moved from ProCurve / ProVision-Based to Comware-Based. - Hp Forum Moderator

 

 

 

 

5 REPLIES
Fredrik Lönnman
Honored Contributor
Solution

Re: Configuration Link aggregation between 5500G and 4800G

use link-aggregation group 1 mode manual on the 5500G and remove the link-aggregation mode dynamic from the 4800G and it will work.

---
CCIE Service Provider
MASE Network Infrastructure [2011]
H3CSE
CCNP R&S

freddy13
Occasional Contributor

Re: Configuration Link aggregation between 5500G and 4800G

But the 4800G only have the dynamic mode, dont have manual or static mode.

You can explain me what i need to do inthe 4800G.

Thanks.

 

Fredrik Lönnman
Honored Contributor

Re: Configuration Link aggregation between 5500G and 4800G

Try "undo link-aggregation mode".

---
CCIE Service Provider
MASE Network Infrastructure [2011]
H3CSE
CCNP R&S

chrisuk85
Occasional Advisor

Re: Configuration Link aggregation between 5500G and 4800G

I have had issues with this too.

 

On the web interface for the 4800G there are two options: Dynamic (LACP Enabled) and Static (LACP Disabled)

 

On the web interface for the 5500G there are two options: Manual (LACP Disabled) and Static (LACP Enabled)

 

I currently have two ports set up between these two units. On the 4800G I have it in static mode and on the 5500G it's in Manual mode. So essentially no LACP on either.

 

I am however not convinced this is correct....

 

On the 4800G link-aggregation summary:

 

Aggregation Interface Type:
BAGG -- Bridge-Aggregation, RAGG -- Route-Aggregation
Aggregation Mode: S -- Static, D -- Dynamic
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

AGG         AGG       Partner ID               Select Unselect   Share
Interface   Mode                               Ports  Ports      Type
------------------------------------------------------------------------
BAGG1       S         none                     2      0          Shar

 

Partner ID is "none" - which I would not expect to see normally.

 

Also:

 

[SWITCH]dis brief int bridge
The brief information of interface(s) under bridge mode
Interface            Link      Speed        Duplex   Link-type  PVID
BAGG1                UP        2G(a)        full(a)  trunk      1

 

So it seems up and it is showing 2G (2 connections so this is correct)...however I am not so sure.

 

Story is similar on the 5500G - shows no partner information and doesn't know the ports of the 4800G.

 

I have tested pulling connections and it doesn't affect data transfers. I have also checked STP and no ports are in blocking state...so it does seem to be working to some extent...

 

Can anybody shed some light on exactly what is going on with this?

 

It is very straight forward between 4800G and 2928G for example, but then they are both Comware5 so this is obviously why. The 5500G we have is quite old and is Comware3.

Alan-WJ
Occasional Advisor

Re: Configuration Link aggregation between 5500G and 4800G

On the 4800 use a bridge-aggregation and then add ports to the bridge aggregation. The modes for LACP are different between commware 3 and 5 (5500 and 4800) Static, dynamic and manual on the 5500 but just static and manual on the 4800. Dynamic can be a problem as the link-aggregation group numbers are formed automatically i.e you have no control on the link-agg number even though it uses the next available. Static always uses the same link-agg number. Also make sure that all of the ports in the link-agg at each end have the same configurations if not you can have mismatches which cause the link-agg to  fail.