Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Configuring multiple sFlow collectors on 5940 interfaces

 
cttripp1
Advisor

Configuring multiple sFlow collectors on 5940 interfaces

I have two iMC servers set up as sFlow collectors (working independently from each other/not sharing database).  I've configured a couple of 5940 switches with both servers in the global configuration part, but when I try to configure the individual interfaces on the switches, I can only point sFlow to one iMC server or the other, but not both.

If I configure the interfaces by pointing to either iMC collector, they work just fine.  Each individual collector works as expected.

But I can't configure the interfaces to point at both iMC collector instances simultaneously.  If I leave the interface configuration at its default and run the 'display sflow' command, the return output shows the switch pointing to collector 0.  But then neither iMC sFlow collector shows receives any sFlow data.

Is there a way to configure the interfaces to send sFlow data to both collectors?

3 REPLIES 3
Highlighted
Giri12
HPE Pro

Re: Configuring multiple sFlow collectors on 5940 interfaces

Hi

Please share the configuration on the 5940.


Accept or Kudo
cttripp1
Advisor

Re: Configuring multiple sFlow collectors on 5940 interfaces

See below; I deleted those bits that are unrelated to the issue.  

[DRMT-R1R1-HPSP-1]display current
#
version 7.1.070, Release 2510P02
#
sysname DRMT-R1R1-HPSP-1
#
clock timezone EST minus 05:00:00
clock summer-time EDT 02:00:00 March second Sunday 02:00:00 November first Sunday 01:00:00
clock protocol ntp
#
ip vpn-instance mgmt
route-distinguisher 10.255.100.0:2
#
irf domain 1
irf mac-address persistent always
irf auto-update enable
undo irf link-delay
irf member 1 priority 32
irf member 2 priority 30
#
link-aggregation lacp traffic-redirect-notification enable
#
archive configuration location flash:/ARCHIVE filename-prefix BACKUP
#
tunnel global source-address 10.255.12.1
#
vxlan tunnel mac-learning disable
#
router id 10.255.12.1
#
ospf 1
import-route direct
graceful-restart ietf
area 0.0.0.0
network 10.11.0.0 0.0.255.255
network 10.12.0.0 0.0.255.255
network 10.201.99.0 0.0.0.255
network 10.255.1.0 0.0.0.255
network 10.255.2.0 0.0.0.255
network 10.255.100.0 0.0.0.255
#
dns domain atl.fhlb.com
#
sflow agent ip 10.201.99.1
sflow source ip 10.201.99.1
sflow collector 1 ip 10.1.99.11 description ntaserverWithoutVpn
sflow collector 2 ip 10.101.99.11 description ntaserverWithoutVpn
#
lldp global enable
#
port-isolate group 1
#
system-working-mode standard
hardware-resource vxlan border8k
fan prefer-direction slot 1 port-to-power
fan prefer-direction slot 2 port-to-power
password-recovery enable
#
# VLAN, VSI, IRF port info, STP deleted

interface Bridge-Aggregation1
description Downlink to DRMT-R1R1-HPFL-1
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 20 25 99 255
port-isolate enable group 1
link-aggregation mode dynamic
mad enable
#
interface NULL0
#
interface LoopBack0
ip address 10.255.12.1 255.255.255.255
#
interface Vlan-interface11
shutdown
ip address 10.11.4.1 255.255.0.0
#
interface Vlan-interface12
shutdown
ip address 10.12.4.1 255.255.0.0
#
interface Vlan-interface99
description Network Management IB
ip address 10.201.99.1 255.255.255.0
#
interface Vlan-interface255
description Old Management Interface (still in use)
ip address 10.255.100.1 255.255.255.0
#
# Unused port configs deleted
#
interface Ten-GigabitEthernet1/0/1
port link-mode route
description WAN-A
mtu 9008
ip address 10.255.1.3 255.255.255.0
ospf dr-priority 10
sflow sampling-rate 20000
dci enable
#
interface Ten-GigabitEthernet2/0/1
port link-mode route
description WAN-B
mtu 9008
ip address 10.255.2.3 255.255.255.0
ospf dr-priority 10
sflow sampling-rate 20000
dci enable
#
# Unused ports deleted
#
interface Ten-GigabitEthernet1/0/47
port link-mode bridge
description Downlink to DRMT-R1R1-HPFL-1 Ten1/0/49
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 20 25 99 255
port-isolate enable group 1
sflow sampling-rate 20000
port link-aggregation group 1
#
interface Ten-GigabitEthernet1/0/48
port link-mode bridge
description Downlink to DRMT-R1R1-HPFL-1 Ten2/0/49
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 20 25 99 255
port-isolate enable group 1
sflow sampling-rate 20000
port link-aggregation group 1
#
# Unused ports deleted
#
interface Ten-GigabitEthernet2/0/47
port link-mode bridge
description Downlink to DRMT-R1R1-HPFL-1 Ten3/0/49
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 20 25 99 255
port-isolate enable group 1
sflow sampling-rate 20000
port link-aggregation group 1
#
interface Ten-GigabitEthernet2/0/48
port link-mode bridge
description Downlink to DRMT-R1R1-HPFL-1 Ten4/0/49
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 20 25 99 255
port-isolate enable group 1
sflow sampling-rate 20000
port link-aggregation group 1
#
# Route protocol, line configs, info-center, snmp-agent, hwtacacs, domain and role info deleted.

cttripp1
Advisor

Re: Configuring multiple sFlow collectors on 5940 interfaces

It turns out this is not possible.  While a 5940 can be configured with multiple collectors, the individual interfaces can only be configured with a single collector.  A big shortcoming IMHO; it defeats the purpose of having redundant collectors.