Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Connectng HP A5830 Sever farm Switches to Cisco Core 6513 Switches

aali
Frequent Advisor

Connectng HP A5830 Sever farm Switches to Cisco Core 6513 Switches

Is there any HP doccument that can show step-by-step best practices of connecting HP and Cisco Switches.  It is fairly simple I believe and all I need ot do the following:

 

Make sure that the root priority of HP are higher (in numbers) than Cisco.  I beleive Cisco's root priority are all zero so I should be fine.

 

Enable STP on HP switches and forced version to RSTP since Cisco Distribution Switches are running PVST+

 

For Trunking on HP, I will do the following

 

Will create (2) 10Gb LACP from HP to each Cisco 6513s switches.

 

Interface bridge-aggregation 1

  link-aggregation mode dynamic

 

int tengigabit  1/0/23

port link-aggregation group 1

 

int tengigabit  1/0/24

port link-aggregation group 1

 

 

Interface bridge-aggregation 1

port link-type trunk

port trunk permit vlan X,X,X,X

 

Interface bridge-aggregation 2

  link-aggregation mode dynamic

 

int tengigabit  1/0/25

port link-aggregation group 2

 

int tengigabit  1/0/26

port link-aggregation group 2

 

 

Interface bridge-aggregation 2

port link-type trunk

port trunk permit vlan X,X,X,X

 

What LACP mode should be at Cisco for trunks  to become active.

 

 

5 REPLIES
GrahamB154
Occasional Advisor

Re: Connectng HP A5830 Sever farm Switches to Cisco Core 6513 Switches

Strangely my last post didn't get saved, so i'll write this again.

 

You might want to double check the native VLAN setting between your cisco and HP switch. We had a problem where there was a  native vlan mismatch between a Juniper switch and a cisco switch and it caused an STP loop which caused a network outage.

 

The rest of your configuration looks fine, it's best practise to make the core switches the STP root bridges, so give them a low STP priority. I'm not sure what you are menioning when you refer to root priority of cisco switches being 0. Do you mean the port priorities? The main thing you want is the root bridge to be elected to be the HP switches. So make sure that the STP priority are lower than the cisco ones. Not higher - the bridge-id is made up of a bridge priority (which you can configure) and the MAC address of the switch.

 

The trunking configuration looks good, on the cisco side you can set the trunk to be either desirable (actively negotiates LACP) or auto (passive - therefore responds to active requests for LACP bundle)

 

on the Cisco switch it's something like this:

 

interface tengigabitethernet0/0/0

channel-protocol lacp

channel-group 1 mode desirable

 

interface tengigabitethernet0/0/1

channel-protocol lacp

channel-group 1 mode desirable 

 

then

 

interface Port-channel 1

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20 ...etc

switchport trunk native vlan 99

 

Cheers,

 

Graham

 

 

Michael A. McKenney
Respected Contributor

Re: Connectng HP A5830 Sever farm Switches to Cisco Core 6513 Switches

I was reading a document on A58xx switches and other switches.   A58xx uses IRF / LACP instead of xSTP but when you connect them to non-HP A58xx switches, you need to configure an STP protocol.   I was looking at this because I want to use a Cisco ASA-5520 for secondary routes and use A58xx VLAN to VLAN for primary routes.

aali
Frequent Advisor

Re: Connectng HP A5830 Sever farm Switches to Cisco Core 6513 Switches

Thank you for your response and sorr for typing it again.  I will double check the native VLANs to be the same at both Cisco and HP.  By default, both Cisco and HP have native VLAN of 1 but will make sure that nobody changed native VLAN on Cisco existing switches.  If they did then I will match at the HP end as well.

Regarding Root Bridge, actually, we are not replacing Cisco Distrubiton Switches with HP.  The Cisco 6513s will continue to be operate as distribution switches and shoulb be the root bridges.  HP switches will act as server farm switches and will be connecting over (2) 10GB LACP to Cisco distribution switches.  That is why I don't want HP switches to take over Cisco switches as root bridges.  The root priorities on Cisco 6513s switches are set to 0 for certain VLANs and 4096 for other VLANs and Vice Versa on the 2nd set of 6513.  Typical Cisco model for VLANs load balancing between two distribution switches.  

I am very sure that by default HP root priorities are higher than 4096 so I won't have to change any settings there.

HP A5830 does support PVST mode and was wondering if I should turn on PVST instead of RSTP since Cisco 6513s are configured with PVST+

Last, not sure how HP switches will behave when it comes to root port or designated root port and wanted to find out if I need to manually configure the settings for root or desiganted root ports.

ktako
Occasional Collector

Re: Connectng HP A5830 Sever farm Switches to Cisco Core 6513 Switches

Here is an example configuration for HP Comware and Cisco  using Bridge Aggregation (HP)  and Port Channel (Cisco)

 

********************************************HP Comware*******************************************************

vlan 1 to 900

interface Bridge-Aggregation1

description link to Cisco
link-aggregation mode dynamic
quit

 

int gig 1/0/49
shut

description link to Cisco gig 1/3
port link-aggregation group 1

 

int gig 5/0/49
shut

description link to Cisco gig 1/5
port link-aggregation group 1


interface Bridge-Aggregation 1

description link to Cisco

port link-type trunk
port trunk permit vlan all

 

************The below  will be seen when the vlans are permitted*****************************


 Please wait........................................... Done.
 Configuring GigabitEthernet1/0/49........................................... Done.
 Configuring GigabitEthernet5/0/49........................................... Done.
 

int gig 1/0/49
undo shut

int gig 5/0/49
undo shut


**or on the  HP  switch change the following if you use a different PVID in this example 990, and to allow specific vlans**

 

interface Bridge-Aggregation 1

description link to Cisco
port link-type trunk
undo port trunk permit vlan all

port trunk pvid vlan 990
port trunk permit vlan 1 to 899


*************************Cisco IOS********************************************************************************
vlan 1 - 900

!
interface Port-channel1
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan all
 switchport mode trunk
 no shut
!

interface GigabitEthernet1/3
 description chan-group link to HP 5500 gig 1/0/49
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan all
 switchport mode trunk
 channel-group 1 mode active
 no shutdown
!
interface GigabitEthernet1/5
 description chan-group link to HP 5500  to gig 5/0/49
 switchport
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan all
 switchport mode trunk
 channel-group 1 mode active
 no shutdown
!

 ***************or on Cisco change to the following if you use a different PVID and to allow specific vlans*****


interface Port-channel1
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 990
 switchport trunk allowed vlan 2-889
 switchport mode trunk
!
interface GigabitEthernet1/3
 description chan-group link to 5500 gig 1/0/49
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 990
 switchport trunk allowed vlan 2-889
 switchport mode trunk
 no logging event link-status
 channel-group 1 mode active
!
interface GigabitEthernet1/5
 description chan-group link 5500 gig 1/0/49
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 990
 switchport trunk allowed vlan 2-889
 switchport mode trunk
 no logging event link-status
 channel-group 1 mode active
!

ktako
Occasional Collector

Re: Connectng HP A5830 Sever farm Switches to Cisco Core 6513 Switches

For those aslo wanting to aggregate links at layer 3 only between HP ComWare and Cisco swithes here is a configuration for this.....sometimes refered to as Layer 3 Port Channel

 

Layer 3  Channel between HP Comware (Route Aggregation)  and Cisco IOS ( L3 Port Channel)

***************************HP Comware Switch********************************************

interface Route-Aggregation1
 link-aggregation mode dynamic
 ip address X.X.X.2 255.255.255.252

#
interface GigabitEthernet1/0/49
 port link-mode route
 port link-aggregation group 1
#
#
interface GigabitEthernet5/0/49
 port link-mode route
 port link-aggregation group 1
#


********************************Cisco IOS ************************************************
!
interface Port-channel1
 ip address X.X.X.1 255.255.255.252
!
!
interface GigabitEthernet1/3
 description chan-group link to 5500HI gig 1/0/49
 no ip address
 no logging event link-status
 channel-protocol lacp
 channel-group 1 mode active
!
interface GigabitEthernet1/5
 description chan-group link 5500HI gig 1/0/49
 no ip address
 no logging event link-status
 channel-protocol lacp
 channel-group 1 mode active