Comware Based

DHCP delivers addresses to ports that have multiple VLANs

 
CesarMartinez
Occasional Advisor

DHCP delivers addresses to ports that have multiple VLANs

 Good day friends,

I come with a doubt which I do not know where to attack.

This problem is old:

The Wi-Fi network has two vlan's one for guests and another for officials, vlan 1 (172.16.3.0) is for officials and vlan 1500 (10.0.0.0) is for guests. The vlan 1 is the general vlan, which also delivers addresses to desktop computers, the idea was that it also delivered to mobile equipment (cell phones and laptops), but due to the problem that arises, this SSID (ie Wi-Fi) has not been shared. by vlan 1 it is not operational yet). The DHCP service for vlan 1 is in a ws2012, the problem that arises is that the scope for vlan 1 (which currently serves only for desktops) is filled with cell phones, 172.16.3.0 addresses to mobile phones, but I When I ping these cell phones, no address answers me.

Now I realize the following:

The IP telephones go through vlan 30 172.19.1.0, they have statically assigned ip, I managed to put them through DHCP, I created this scope in ws2012, and now I realize that this is being filled with addresses 172.19.1.0 to desktop and desktop computers. the same way to ping do not respond me. In the port of my computer assigned to vlan 1 and vlan 30 voice, the scope of DHCP for vlan 1 and 30 is giving me two addresses, but only responds to ping the vlan 1. I do not think it's a DHCP problem, I think it's something of configuration in the Switchcore HP A5120-48G.

I appreciate your help friends.

3 REPLIES 3
gc_09
HPE Pro

Re: DHCP delivers addresses to ports that have multiple VLANs

Hello,

 

Can you please share the config from the switch ?

I am an HPE Employee

Accept or Kudo

CesarMartinez
Occasional Advisor

Re: DHCP delivers addresses to ports that have multiple VLANs

Of course. I omitted the configuration of the ports because it does not allow me to exceed the characters. I did not find the option to attach, I appreciate if you share an email to send the information.
In addition to the problem, I need to give internet to vlan 30, do I have to create an additional route? or do I have to do this in the firewall?
Thanks for your help.


#
version 5.20.99, Release 2220P02
#
sysname HP Core
#
clock timezone Bogota minus 05:00:00
#
super password level 3 cipher $c$3$5itrJSRuWLljdLgOueNclz74Y+9pWDDjM+kBtRHQI6w/
#
dhcp relay server-group 1 ip 172.16.0.11
dhcp relay server-group 2 ip 172.16.0.12
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
irf member 1 priority 32
irf member 2 priority 31
#
domain default enable system
#
telnet server enable
#
cluster enable
stack stack-port 1 port GigabitEthernet1/0/1
stack stack-port 1 port GigabitEthernet1/0/2
stack stack-port 1 port GigabitEthernet1/0/3
stack stack-port 1 port GigabitEthernet1/0/4
stack stack-port 1 port GigabitEthernet1/0/5
stack stack-port 1 port GigabitEthernet1/0/6
stack stack-port 1 port GigabitEthernet1/0/7
stack stack-port 1 port GigabitEthernet1/0/8
stack stack-port 1 port GigabitEthernet1/0/9
stack stack-port 1 port GigabitEthernet1/0/10
stack stack-port 1 port GigabitEthernet1/0/11
stack stack-port 1 port GigabitEthernet1/0/12
stack stack-port 1 port GigabitEthernet1/0/13
stack stack-port 1 port GigabitEthernet1/0/14
stack stack-port 1 port GigabitEthernet1/0/15
stack stack-port 1 port GigabitEthernet1/0/16
stack stack-port 1 port GigabitEthernet1/0/17
stack stack-port 1 port GigabitEthernet1/0/18
stack stack-port 1 port GigabitEthernet1/0/19
stack stack-port 1 port GigabitEthernet1/0/20
stack stack-port 1 port GigabitEthernet1/0/21
stack stack-port 1 port GigabitEthernet1/0/22
stack stack-port 1 port GigabitEthernet1/0/23
stack stack-port 1 port GigabitEthernet1/0/24
stack stack-port 1 port GigabitEthernet1/0/25
stack stack-port 1 port GigabitEthernet1/0/26
stack stack-port 1 port GigabitEthernet1/0/27
stack stack-port 1 port GigabitEthernet1/0/28
stack stack-port 1 port GigabitEthernet1/0/29
stack stack-port 1 port GigabitEthernet1/0/30
stack stack-port 1 port GigabitEthernet1/0/31
stack stack-port 1 port GigabitEthernet1/0/32
stack stack-port 1 port GigabitEthernet1/0/33
stack stack-port 1 port GigabitEthernet1/0/34
stack stack-port 1 port GigabitEthernet1/0/35
stack stack-port 1 port GigabitEthernet1/0/36
stack stack-port 1 port GigabitEthernet1/0/37
stack stack-port 1 port GigabitEthernet1/0/38
stack stack-port 1 port GigabitEthernet1/0/39
stack stack-port 1 port GigabitEthernet1/0/40
stack stack-port 1 port GigabitEthernet1/0/41
stack stack-port 1 port GigabitEthernet1/0/42
stack stack-port 1 port GigabitEthernet1/0/43
stack stack-port 1 port GigabitEthernet1/0/44
stack stack-port 1 port GigabitEthernet1/0/45
stack stack-port 1 port GigabitEthernet1/0/46
stack stack-port 1 port GigabitEthernet1/0/47
stack stack-port 1 port GigabitEthernet1/0/48
stack stack-port 1 port GigabitEthernet1/0/49
stack stack-port 1 port GigabitEthernet1/0/50
stack stack-port 1 port GigabitEthernet1/0/51
stack stack-port 1 port GigabitEthernet1/0/52
#
loopback-detection enable
#
password-recovery enable
#
vlan 1
description Principal
#
vlan 2
description Radiologia
#
vlan 3
description firewall
#
vlan 5
description diveo-test
#
vlan 6
description TRONCAL SIP CLARO
#
vlan 7
description RX new
name RX new
#
vlan 8
description wi-fi invitados
#
vlan 10
description URGENCIAS
#
vlan 11
description FARMACIA PRINCIPAL
#
vlan 12
description Internet
#
vlan 13
description Consulta_Externa
#
vlan 14
description TRONCAL SIP CLARO
#
vlan 15
description INTERNET CLARO NOVO
#
vlan 30
description Telefonos IP
#
vlan 40
description Segmento 2
#
vlan 41
description SISTEMAS
#
vlan 70
description IBM-TEST
#
vlan 100
description wi-fi
#
vlan 110
description WiFi-net
#
vlan 160
description Internet Claro
#
vlan 200
description Internet UNE
#
vlan 400
description pub-resonador
#
vlan 500
description softphone
#
vlan 501
description VLAN UCI
#
vlan 502
description internet_provicional
#
vlan 1500
description wi-fi2
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
group-attribute allow-guest
#
local-user RW
password cipher $c$3$WSEbIGWzEeTcMBZzkqvRQiS37M9QEalPisNEK44=
authorization-attribute level 3
service-type telnet
service-type ftp
service-type web
local-user admin
password cipher $c$3$CKJsWuTCCVE9m1qAWULt5fPZQHI0LqpmvWaRJtFeoA==
authorization-attribute level 1
service-type telnet
service-type ftp
service-type web
#
stp instance 0 root primary
stp instance 1 root primary
stp enable
#
interface Bridge-Aggregation1
port link-type trunk
port trunk permit vlan 1 to 3 5 7 to 8 10 to 11 13 to 15 30 40 to 41 70 100 110
port trunk permit vlan 400 500 to 503 1500
link-aggregation mode dynamic
undo ntdp enable
#
interface NULL0
#
interface Vlan-interface1
ip address 172.16.0.3 255.255.0.0
dhcp select relay
dhcp relay server-select 1
#
interface Vlan-interface3
ip address 172.18.2.1 255.255.255.248
undo dhcp select server global-pool
#
interface Vlan-interface5
#
interface Vlan-interface8
#
interface Vlan-interface10
ip address 172.10.100.1 255.255.255.0
dhcp select relay
dhcp relay address-check enable
dhcp relay server-select 1
#
interface Vlan-interface11
ip address 172.11.100.1 255.255.255.0
dhcp select relay
dhcp relay address-check enable
dhcp relay server-select 1
#
interface Vlan-interface12
#
interface Vlan-interface13
ip address 172.13.100.1 255.255.255.0
dhcp select relay
dhcp relay server-select 1
#
interface Vlan-interface30
ip address 172.19.0.1 255.255.254.0
dhcp select relay
dhcp relay server-select 1
#
interface Vlan-interface40
ip address 172.21.0.1 255.255.0.0
dhcp select relay
dhcp relay server-select 1
#
interface Vlan-interface41
ip address 172.16.11.1 255.255.255.0
#
interface Vlan-interface70
ip address 172.22.0.5 255.255.255.248
#
interface Vlan-interface100
#
interface Vlan-interface110
ip address 172.30.80.1 255.255.240.0
#
interface Vlan-interface400
#
interface Vlan-interface500
ip address 192.168.100.1 255.255.255.0
dhcp select relay
dhcp relay server-select 1
#
interface Vlan-interface501
ip address 192.168.101.1 255.255.255.0
dhcp select relay
dhcp relay server-select 1
#
interface Vlan-interface1500
ip address 10.0.3.254 255.255.0.0
dhcp select relay
dhcp relay server-select 2
#

#
interface Ten-GigabitEthernet1/1/1
#
interface Ten-GigabitEthernet1/1/2
#
interface Ten-GigabitEthernet2/1/1
#
interface Ten-GigabitEthernet2/1/2
#
ip route-static 0.0.0.0 0.0.0.0 Vlan-interface3 172.18.2.2 preference 1
ip route-static 10.10.10.0 255.255.255.0 Vlan-interface100 10.10.10.254
ip route-static 172.18.2.0 255.255.255.248 Vlan-interface3 172.18.2.2 preference 1
ip route-static 172.19.0.0 255.255.255.0 Vlan-interface30 172.19.0.1
ip route-static 172.21.0.0 255.255.255.0 Vlan-interface40 172.21.0.1
ip route-static 172.22.0.0 255.255.255.248 Vlan-interface70 172.22.0.5
ip route-static 172.22.147.178 255.255.255.255 Vlan-interface3 172.18.2.2
ip route-static 172.22.147.178 255.255.255.255 Vlan-interface1 172.18.2.2
ip route-static 172.23.0.0 255.255.255.192 Vlan-interface70 172.22.0.1
ip route-static 172.24.0.0 255.255.255.248 Vlan-interface3 172.18.2.2
ip route-static 172.25.0.0 255.255.255.252 Vlan-interface3 172.18.2.2
ip route-static 192.168.1.100 255.255.255.255 Vlan-interface3 172.18.2.2
#
snmp-agent
snmp-agent local-engineid 800063A203CC3E5FA0FC95
snmp-agent community read public
snmp-agent community read Monitor
snmp-agent community write private
snmp-agent sys-info contact Admin Redes
snmp-agent sys-info location CORE SISTEMAS
snmp-agent sys-info version v2c v3
snmp-agent group v3 Sistemas privacy
snmp-agent usm-user v3 Monitor Sistemas cipher authentication-mode sha $c$3$4plbIjkkwsz0Ru3URVcSlsv7lgdnOCbMyIHbjsxU/7ETXAmQX+M= privacy-mode aes128 $c$3$v1XiTXHImV0/jAqXvY0NcXcaSoAWDFrxgca3qT5g0rty2Q==
snmp-agent packet max-size 2500
#
dhcp enable
#
ntp-service unicast-server 172.16.0.11
#
load xml-configuration
#
user-interface aux 0 1
user-interface vty 0 15
#
irf-port 1/1
port group interface Ten-GigabitEthernet1/1/1 mode normal
port group interface Ten-GigabitEthernet1/1/2 mode normal
#
irf-port 2/1
port group interface Ten-GigabitEthernet2/1/1 mode normal
#
irf-port 2/2
port group interface Ten-GigabitEthernet2/1/2 mode normal
#
return

gc_09
HPE Pro

Re: DHCP delivers addresses to ports that have multiple VLANs

There are quite a few question with respect to the configuration of DHCP relay, etc.

At this point, it will be good to log a case with the support - https://www.hpe.com/au/en/support.html

 

I am an HPE Employee

Accept or Kudo