Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

DHCP issue with Ciscosg500(Access) & HP5800(Core)

reil331
Occasional Contributor

DHCP issue with Ciscosg500(Access) & HP5800(Core)

guys need your help, already scoured the internet. My network was working fine until i added a HP 5800 in the mix. Setup is cisco sg500 switch will send request to UbuntuServer16 as my DHCP server. Now my boss decided to add HP as the Core switch. Already aggregated them but the subnet on a specific interface range would not automatically configure a ip add. Below are the configuration on the LACP aggregation. Thank you in advance.

#############
Cisco SG500
#############
int g1/1/1
Speed 1000
Duplex Full
channel-group 1 mode auto
switchport mode trunk
exit

int g1/1/2
Speed 1000
Duplex Full
channel-group 1 mode auto
switchport mode trunk
exit

LACP
port-channel 1
switchport mode trunk
switchport trunk native vlan 1
switchport trunk allowed vlan add 100
switchport trunk allowed vlan add 200

###########
HP A5800
###########

[HP]interface Bridge-Aggregation 1
[HP-Bridge-Aggregation1] display this
#
interface Bridge-Aggregation1
port link-type trunk
port trunk permit vlan 1 100 200
link-aggregation mode dynamic
#
#
vlan 100
name IT_Dept
quit
vlan 200
name Sales_Dept
#
[HP-GigabitEthernet1/0/1] display this
#
interface GigabitEthernet1/0/1
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 100 200
port link-aggregation group 1
#
[HP-GigabitEthernet1/0/3] display this
#
interface GigabitEthernet1/0/3
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 100 200
port link-aggregation group 1
Edit

9 REPLIES
Highlighted
johnk3r
Respected Contributor

Re: DHCP issue with Ciscosg500(Access) & HP5800(Core)

Please send the DHCP settings of the HPE switch, including the Vlan interface information.

**************************************
ATP FLEXNETWORK V3 | ACSA
reil331
Occasional Contributor

Re: DHCP issue with Ciscosg500(Access) & HP5800(Core)


[] dhcp enable
[] dhcp relay server-group 1 ip 192.168.100.1
[] dhcp relay server-group 2 ip 192.168.200.1


interface Vlan-interface100
ip address 192.168.100.1 255.255.255.0
dhcp select relay
dhcp relay server-select 1
ip address dhcp-alloc

 

interface Vlan-interface200
ip address 192.168.200.1 255.255.255.0
dhcp select relay
dhcp relay server-select 2
ip address dhcp-alloc

 

Vince-Whirlwind
Honored Contributor

Re: DHCP issue with Ciscosg500(Access) & HP5800(Core)

I think we need to see your new network design, specifically,
- host subnets with subnet ask/default gateway
- VLAN interface IP addressing config
- DHCP server IP details - when you say the new switch is the "core", do you also mean it is to become your DHCP server?

Baically, whichever device is your network hosts' default gateway, needs the IP helper/DHCP relay pointing at your DHCP server.
What you seem to have is DHCP relay in each subnet pointing at itself. Maybe the DHCP-relay server-group IP address should be pointing at the old DHCP server, if it is going to remain the DHCP server?

reil331
Occasional Contributor

Re: DHCP issue with Ciscosg500(Access) & HP5800(Core)

Sure, see attached. The dhcp server is ubuntu16.04. It was working fine before until HP 5800 was added on the network. I admit have zero knowledge it HP and currently learning the navigation on its CLI. how i wish i could access simulate this at home like gns3. Anyways appreciate your assistance.

pattap
Regular Advisor

Re: DHCP issue with Ciscosg500(Access) & HP5800(Core)

if your HP switch is acting as a gateway for clients in both vlans you need to have config as per reli331's post but you don't need "ip address dhcp-alloc" this part of the config would tell the vlan interface to get IP address from DCHP for itself, so

dhcp enable
dhcp relay server-group 1 ip 192.168.100.1
dhcp relay server-group 2 ip 192.168.200.1
#
interface Vlan-interface100
ip address 192.168.100.1 255.255.255.0
dhcp select relay
dhcp relay server-select 1
#
interface Vlan-interface200
ip address 192.168.200.1 255.255.255.0
dhcp select relay
dhcp relay server-select 2

or if you want to keep the two DHCP server in one group

dhcp enable
dhcp relay server-group 1 ip 192.168.100.1
dhcp relay server-group 1 ip 192.168.200.1
#
interface Vlan-interface100
ip address 192.168.100.1 255.255.255.0
dhcp select relay
dhcp relay server-select 1
#
interface Vlan-interface200
ip address 192.168.200.1 255.255.255.0
dhcp select relay
dhcp relay server-select 1

can you post output of dis link-agg ver br1

also you could try debug function for DHCP relay

<hp>terminal monitor
The current terminal is enabled to display logs.
<hp>terminal debugging
The current terminal is enabled to display debugging logs.
<hp>debugging dhcp relay all

to disable debug
<hp>undo debugging all


DHCP request on the switch with debug on should look like:

*Jun  8 13:19:47:026 2018 hp DHCPR/7/PACKET:
To <IP address of your DCHP> port 67, interface is selected by routing table
    Message type: REQUEST (1)
    Hardware type: 1, Hardware address length: 6
    Hops: 1, Transaction ID: 2213528159
    Seconds: 15, Broadcast flag: 0
    Client IP address: 0.0.0.0   Your IP address: 0.0.0.0
    Server IP address: 0.0.0.0   Relay agent IP address: 192.168.100.1
    Client hardware address: aaaa-bbbb-cccc
    Server host name: not configured
    Boot file name: not configured
    DHCP message type: DHCPREQUEST (3)

 

once your client gets IP it would look like

*Jun  8 13:19:47:034 2018 hp DHCPR/7/PACKET:
To 192.168.100.56 port 68, interface Vlan-interface100
    Message type: REPLY (2)
    Hardware type: 1, Hardware address length: 6
    Hops: 0, Transaction ID: 2213528159
    Seconds: 15, Broadcast flag: 0
    Client IP address: 0.0.0.0   Your IP address: 192.168.100.56
    Server IP address: 0.0.0.0   Relay agent IP address: 192.168.100.1
    Client hardware address: aaaa-bbbb-cccc
    Server host name: not configured
    Boot file name: not configured
    DHCP message type: DHCPACK (5)

 you could also post some outputs of your debug, they are really useful

 

 

 
reil331
Occasional Contributor

Re: DHCP issue with Ciscosg500(Access) & HP5800(Core)

Thanks @pattap, cisco is the access switch while the HP acts as the core. The Ubuntu acts as the DHCP Server. 


Current issue: DHCP won't function on the test PCs when I'll trunk\connect the cisco & hp using 2 cross-over cables.
Done with the isolation when i connect the test pc->cisco or hp ->Ubuntu(DHCP), dhcp will run. Which means the issue is between Cisco(access) & HP(Core). I'm using a Ubuntu16.04 as the DHCP server.

Below is the updated configurations: 

------------------------------------------
Cisco SG500

set system mode router


vlan 100
vlan 200


########
VLANS
########

int vlan 100
name IT_Dept
ip add 192.168.100.1 255.255.255.0


int vlan 200
name Sales_Dept
ip add 192.168.200.1 255.255.255.0


##############
ACCESS PORTS
##############


int range gig 1/1/7-12
switch mode access
switchport access vlan 100


int range gigE 1/1/31-36
switch mode access
switchport access vlan 200


##################
LACP Aggregation
##################

int port-channel 1
switchport mode trunk
switchport trunk allowed vlan add 100
switchport trunk allowed vlan add 200
switchport trunk native vlan 1

------------------------------------------

------------------------------------------
HPE 5800

vlan 100

name IT_Dept

vlan 200

name Sales_Dept


#######
LACP
#######

interface Bridge-Aggregation 1
port link-type
port trunk permit vlan 1 100 200
link-aggregation mode dynamic

 

#############
Trunk Ports
#############

int gig 1/0/1
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 100 200
link-aggregation mode dynamic


int gig 1/0/2
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 100 200
link-aggregation mode dynamic


int gig 1/0/3
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 100 200
link-aggregation mode dynamic


int gig 1/0/4
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 100 200
link-aggregation mode dynamic

 

##############
Access Ports
##############

int gigE 1/0/17,19,21,23,25,27,29,31
port link-type access
port access vlan 100

int gigE 1/0/18,20,22,24,26,28,30,32
port link-type access
port access vlan 200

 

 

pattap
Regular Advisor

Re: DHCP issue with Ciscosg500(Access) & HP5800(Core)

when you said your HP is the core I was expecting the routing point to be configured on there but according to the above config your vlan interfaces are configured on cisco,

assuming your DHCP is located on vlan other than 100 or 200 you need to configure ip helper on your cisco kit to make sure broadcast (dhcpreqests) is passed across to your DHCP

to make sure your bridge aggregation/etherchannel is ok issue dis link-agg ver br1/show etherchannel summary respectively

Vince-Whirlwind
Honored Contributor

Re: DHCP issue with Ciscosg500(Access) & HP5800(Core)

2 things I would do, so I am not troubleshopoting mutliple things in parallel:

1/ remove all LACP config until you have connectivity established using a simple link, then add LACP

2/ configure static addresses on the hosts on the HP switch (1 in each VLAN) and establish connectivity, *then* test DHCP.

reil331
Occasional Contributor

Re: DHCP issue with Ciscosg500(Access) & HP5800(Core)

Guys done with isolation for the day, i've remove the Ubuntu(dhcp server) in isolation 1.

isolation 1:

test pc1 able to reach test pc2 between LAG\LACP ciscosg500 & hp5800. static ip addresses was assigned at each test pcs.

 

isolation 2:

Ubuntu(dhcp server) was now added back connecting to HP5800(Core).                                                                              PC1 at vlan 100 can reach the bondo.100 interface at Ubuntu(192.168.100.1). Static ip add was assigned.
While pc2 at vlan 200 cant reach the bondo.200 interface(192.168.200.1). Static ip add was assigned.
Done swapping and same result.

conclusion: do i need to separate the 4 trunk ports with LACP config in HP5800. Port from int gig 1/0/1 to int gig 1/0/4 are under the same bridge aggregation 1. Plan to separate them by tommorow, int gig 1/0/1 & int gig 1/0/2 should be under bagg1 which will be connected to ciscosg500(access) while int gig 1/0/3 & int gig 1/0/4 to be assign on Ubuntu(dhcp).