Comware Based
1753701 Members
5152 Online
108799 Solutions
New Discussion

EVPN: BGP - Advertise IPs of local hosts (/32) to WAN router

 
MichaelM55
Trusted Contributor

EVPN: BGP - Advertise IPs of local hosts (/32) to WAN router

Hello,

so I setup case 2 of "EVI 2.0 EVPN Data Center Interconnect (EVPN DCI) deployment guide"1.png

 

We have VM1 and VM2 connected to 5940-3 which will take their local distributed gateway. On 5940-3 I can see "host routes" from 5940-3.

dis ip ro vpn vpna

10.80.22.21/32 BGP 255 0 192.168.1.14 Vsi1000

10.80.23.21/32 BGP 255 0 192.168.1.14 Vsi1000

Imagine another Router "R" that is connected to WAN with OSPF and has e.g. loopback IP address of 192.168.20.34. Also the router has BGP configured.

How can I advertise the information of those host routes to that router? I tried a lot to get those routing information, BGP state is established of course, but I cannot any routes towards that router.

Let´s look at 5940-3:

bgp 100
peer 192.168.1.14 as-number 200
peer 192.168.1.14 connect-interface loopback 0
peer 192.168.1.14 ebgp-max-hop 64

peer 192.168.20.34 connect-interface loopback 0

address-family ipv4

peer 192.168.20.34 enable


address-family l2vpn evpn
peer 192.168.1.14 enable
peer 192.168.1.14 router-mac-local

And for mentioned router "R":

bgp 100
router-id 192.168.20.34

peer 192.168.1.13 connect-interface loopback 0

address-family ipv4

peer 192.168.1..13 enable

 

Some hints would be great.

 

 

 

-----------------

Sample 5940-3 ED configuration
sysname 5940-3
#
l2vpn enable
vxlan tunnel mac-learning disable
vxlan tunnel arp-learning disable
#
hardware-resource vxlan border24k
#
interface LoopBack0
ip address 192.168.1.13 255.255.255.255
#
tunnel global source-address 192.168.1.13
#
vsi vpna-22
arp suppression enable
vxlan 22
evpn encapsulation vxlan
route-distinguisher auto
vpn-target 1:22 both
# Manual vpn-target is required as DCs are in different AS#s
#
vsi vpna-23
arp suppression enable
vxlan 23
evpn encapsulation vxlan
route-distinguisher auto
vpn-target 1:23 both
# Manual vpn-target is required as DCs are in different AS#s
#
bgp 100
peer 192.168.1.14 as-number 200
peer 192.168.1.14 connect-interface loopback 0
peer 192.168.1.14 ebgp-max-hop 64
address-family l2vpn evpn
peer 192.168.1.14 enable
peer 192.168.1.14 router-mac-local
#
interface ten-gigabitethernet 1/2/1
service-instance 22
encapsulation s-vid 22
xconnect vsi vpna-22
service-instance 23
encapsulation s-vid 23
xconnect vsi vpna-23

#

ip vpn-instance vpna
route-distinguisher 1:1
address-family ipv4
vpn-target 2:2
address-family evpn
vpn-target 1:1
#
interface vsi-interface 22
ip binding vpn-instance vpna
ip address 10.80.22.1 255.255.255.0
mac-address 1-22-1
distributed-gateway local
#
interface vsi-interface 23
ip binding vpn-instance vpna
ip address 10.80.23.1 255.255.255.0
mac-address 1-23-1
distributed-gateway local
#
# Assign L3 gateway interface into VSI
vsi vpna-22
gateway vsi-interface 22
#
vsi vpna-23
gateway vsi-interface 23
#
interface vsi-interface 1000
ip binding vpn-instance vpna
l3-vni 1000
#
interface ten-gigabitethernet 1/1/22
port link-mode route
description WAN
mtu 9000
ip address 192.168.2.18 255.255.255.252
dci enable
#
ospf 1
area 0.0.0.0
network 192.168.0.0 0.0.255.255
# OSPF is used for underlay connectivity, replace with other routing protocols if required

 

Sample 5940-4 ED configuration
sysname 5940-4
#
l2vpn enable
vxlan tunnel mac-learning disable
vxlan tunnel arp-learning disable
#
hardware-resource vxlan border24k
#
interface LoopBack0
ip address 192.168.1.14 255.255.255.255
#
tunnel global source-address 192.168.1.14
#
vsi vpna-22
arp suppression enable
vxlan 22
evpn encapsulation vxlan
route-distinguisher auto
vpn-target 1:22 both
# Manual vpn-target is required as DCs are in different AS#s
#
vsi vpna-23
arp suppression enable
vxlan 23
evpn encapsulation vxlan
route-distinguisher auto
vpn-target 1:23 both
# Manual vpn-target is required as DCs are in different AS#s
#
bgp 200
peer 192.168.1.13 as-number 100
peer 192.168.1.13 connect-interface loopback 0
peer 192.168.1.13 ebgp-max-hop 64
address-family l2vpn evpn
peer 192.168.1.13 enable
peer 192.168.1.13 router-mac-local
#
interface ten-gigabitethernet 1/2/1
service-instance 22
encapsulation s-vid 22
xconnect vsi vpna-22

#

service-instance 23
encapsulation s-vid 23
xconnect vsi vpna-23
#
ip vpn-instance vpna
route-distinguisher 1:1
address-family ipv4
vpn-target 2:2
address-family evpn
vpn-target 1:1
#
interface vsi-interface 22
ip binding vpn-instance vpna
ip address 10.80.22.1 255.255.255.0
mac-address 1-22-1
distributed-gateway local
#
interface vsi-interface 23
ip binding vpn-instance vpna
ip address 10.80.23.1 255.255.255.0
mac-address 1-23-1
distributed-gateway local
#
vsi vpna-22
gateway vsi-interface 22
#
vsi vpna-23
gateway vsi-interface 23
#
interface vsi-interface 1000
ip binding vpn-instance vpna
l3-vni 1000
#
interface ten-gigabitethernet 1/1/22
port link-mode route
description WAN
mtu 9000
ip address 192.168.2.22 255.255.255.252
dci enable
#
ospf 1
area 0.0.0.0
network 192.168.0.0 0.0.255.255

 

1 REPLY 1
b_k
Visitor

Re: EVPN: BGP - Advertise IPs of local hosts (/32) to WAN router

I too would like to know how to get this working, I followed the same guide and came to the same conclusion.

I've tried all manner of static routes into and out of the vpn-instance and nothing seems to let traffic traverse the boundary between public and vpna.