Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

H3C Switches and MSTP: port priority and cost values are ignored by the switches

NullDevice
Occasional Contributor

H3C Switches and MSTP: port priority and cost values are ignored by the switches

Hello!

We have a few different H3C switches in production, like S5120-28,  A5800 and A5120.

We didn't have STP configured until now. But now we needed it for a special purpose. (additional redundant Layer2 Backup-connection to another site).

We tested MSTP and it is working fine. - Except for that its not respecting our custom values "cost" and "port priority".  Because there is a backup-port for the backup connection, and a productive port for the faster primary connection.
But its always puts the backup-port to FORWARDING state, and the primary one to DISCARDING.

interface GigabitEthernet1/0/19
 description "STPTEST1"
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 77 to 78
 port trunk pvid vlan 79
 poe enable
 stp instance 0 port priority 16
 stp instance 1 port priority 16
#
interface GigabitEthernet1/0/20
 description "STPTEST1"
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 77 to 78
 port trunk pvid vlan 79
 poe enable
 stp instance 0 port priority 32
 stp instance 1 port priority 32
#

MSTID      Port                         Role  STP State     Protection
   0        GigabitEthernet1/0/19        ROOT  FORWARDING    NONE
   0        GigabitEthernet1/0/20        ALTE  DISCARDING    NONE
   1        GigabitEthernet1/0/19        MAST  FORWARDING    NONE
   1        GigabitEthernet1/0/20        ALTE  DISCARDING    NONE
[SW-VIE-IT29]

We also tried setting the cost  value lower on the primary port, and set a higher one on the other one.
But its still not respecting it: The backup-port (1/0/19) is still the forwarding one and the primary one is blocked.

Does anyone know how to configure it properly?

EDIT:
Oops, i forgot to post my region configuration:

 

stp region-configuration
 region-name STPTEST1
 revision-level 1
 instance 1 vlan 77 to 79
 active region-configuration
#
 stp enable
#

I have this configuration on both of the switches.
I tried setting either cost and/or port priority on only one, or on both of the interconnected switches.  In both cases, the switches did not respect our cost/prio settings which one ports to primarily use.

 

What is kind of weird with MSTP, is that i needed to forcefully configure an instance 1, because instance 0 contains all of the vlans 0-4096 , and it seems we cannot change that.
Additionally, instance 0 is also listed on the ports 1/0/19 and 1/0/20 , even they are only in vlans 77 to 79.  And instance 0 now is all vlans except for 77 to 79.   So its a bit weird why we do also have an instance 0 (MSTID 0) on those ports, even its for vlans that are not on those ports.   But well if it finally works also with this, it would be fine.

Regards,
ND

2 REPLIES
bala5
HPE Pro

Re: H3C Switches and MSTP: port priority and cost values are ignored by the switches

Hi,

I am unsure with the topology and you can segment the vlan by using instance with priority.

you can refer this guide as referrence point.

 

http://h20628.www2.hp.com/km-ext/kmcsdirect/emr_na-c04038052-1.pdf

Page 825

Bala
I work for HPE
NullDevice231
Occasional Visitor

Re: H3C Switches and MSTP: port priority and cost values are ignored by the switches

Hi!

Yes i know this guide.  I configured the "cost" values like in pages 830 to 835.
But my question is why they are not working in my configuration above.  Any ideas?

regards
ND