Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 5130, Shoretel IP-230, LLDP-MED

Joco
Occasional Visitor

HP 5130, Shoretel IP-230, LLDP-MED

We are currently on firmware 5130_7.10.R3109P05.  Trying to get a Shoretel IP-230 to get the correct LLDP-MED information for our Voice VLAN.  

I have tried several things however the current configuration is:

 

version 7.1.045, Release 3109P05
#
sysname Communications
#
clock timezone UsCanada minus 07:00:00
clock protocol ntp
#
telnet server enable
#
voice-vlan track lldp
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
irf member 1 priority 1
#
dot1x
#
lldp global enable
lldp mode service-bridge
lldp timer notification-interval 5

 

My Test Port is:

#

interface GigabitEthernet1/0/13
port link-type hybrid
port hybrid vlan 50 tagged
port hybrid vlan 1 untagged
undo voice-vlan mode auto
voice-vlan 50 enable
stp edged-port
lldp compliance admin-status cdp txrx
lldp notification med-topology-change enable
lldp tlv-enable dot1-tlv protocol-vlan-id
lldp tlv-enable med-tlv network-policy 21
qos trust dot1p
poe enable
poe max-power 4600
dhcp snooping trust

 

Where I started from is:

interface GigabitEthernet1/0/15
description GigabitEthernet1/0/1 Interface
port link-type hybrid
port hybrid vlan 1 untagged
voice-vlan qos trust
voice-vlan 50 enable
poe enable

 

 

Any help would be appreciated!

 

Ken Clever

Josephine County

3 REPLIES
Apachez-
Trusted Contributor

Re: HP 5130, Shoretel IP-230, LLDP-MED

I dunno about Comware v7 but in v5 you often had to modify what the Comware-device accepts as a voip-device based on its mac-address.

 

So verify if this perhaps applies for your shoretel's aswell?

 

See here for more info: http://h30499.www3.hp.com/t5/Comware-Based/Aastra-IP-phone-on-HP-5130-24G-PoE/td-p/6716982

Joco
Occasional Visitor

Re: HP 5130, Shoretel IP-230, LLDP-MED

Apachez, Thanks for your suggestion.  I actually had tried that previously, and it didn't work.  However, I re-added the mac-address information into the config.   I have the following:

 

#
undo voice-vlan security enable
voice-vlan track lldp
voice-vlan mac-address 0010-4900-0000 mask ffff-ff00-0000 description Shoretel
#

 

Still not working.   

This is the sequence of what I'm seeing:

 

Here is the sequence:

1)  I plug the phone in

2)  Phone starts up

3)  Starts 802.1x

4) Starts LLDP

5) Moves to the Voice VLAN

6) Starts the Waiting for DHCP Counter

7) Gets a DHCP address from Voice VLAN (because it does recieve a lease in the DHCP server for that subnet)

8) DHCP Counter doesn't stop, around the 70 Second Marks it actually gets a DHCP address of our primary DHCP Server

 

That link that you sent me said something about a Comware 7 bug, any idea if that got fixed?

 

 

antonio62410
Occasional Visitor

Re: HP 5130, Shoretel IP-230, LLDP-MED

I have the same problem with Mitel IP Phones 6865 i with LLDP-MED.

I have upgraded to the latest firmware 5130_7.10.R3109P07 and the POE firmware to 5130_7.10.R3109P07 and my problem is not resolved.

So I think there is a bug with LLDP-MED in Comware V7.